[PATCH] gnu: proof-general: Update to 4.5-1.d668946.

  • Open
  • quality assurance status badge
Details
2 participants
  • Morgan Smith
  • Suhail Singh
Owner
unassigned
Submitted by
Morgan Smith
Severity
normal
M
M
Morgan Smith wrote 5 days ago
(address . guix-patches@gnu.org)(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
CH3PR84MB3424159484E9E8C6FDB414A7C5042@CH3PR84MB3424.NAMPRD84.PROD.OUTLOOK.COM
* gnu/packages/coq.scm (proof-general): Update to 4.5-1.d668946.
[phases] Remove unneeded phases and fix shebang fix.

Change-Id: I5ce2775cf18775737853d76b5a50d461aa9d14e6
---

Currently the coqtags program included in proof-general does not work as the
shebang is patched incorrectly.

This patch fixes that and updates proof-general.


gnu/packages/coq.scm | 24 ++++--------------------
1 file changed, 4 insertions(+), 20 deletions(-)

Toggle diff (57 lines)
diff --git a/gnu/packages/coq.scm b/gnu/packages/coq.scm
index ea0868f226..e6df4bf98f 100644
--- a/gnu/packages/coq.scm
+++ b/gnu/packages/coq.scm
@@ -135,7 +135,7 @@ (define-public proof-general
;; The latest release is from 2022 and there has been more than 100 commits
;; since then.
;; Commit from 2024-04-29.
- (let ((commit "cb23709ad0c9a9ca0ee48b3ee73c29caea243b98")
+ (let ((commit "d6689469298b4140dc1f0f8b0ff7e8f937041ffe")
(revision "1"))
(package
(name "proof-general")
@@ -148,7 +148,7 @@ (define-public proof-general
(file-name (git-file-name name version))
(sha256
(base32
- "1spd8rz95s1x91i4lbbb6zabb8014fihx6ai6pgad1nwyr0y9bir"))))
+ "1d12z41rn5nh15qj4sf0w8xrbd9djxlrz0r6g38fiq63i7krbm4x"))))
(build-system gnu-build-system)
(native-inputs
`(("emacs" ,emacs-minimal)
@@ -168,30 +168,14 @@ (define-public proof-general
#:phases
(modify-phases %standard-phases
(delete 'configure)
- (add-after 'unpack 'disable-byte-compile-error-on-warn
- (lambda _
- (substitute* "Makefile"
- (("\\(setq byte-compile-error-on-warn t\\)")
- "(setq byte-compile-error-on-warn nil)"))))
- (add-after 'unpack 'modify-readme-name
- ;; The README file is called "README.md", but the Make variable
- ;; "DOC_FILES" still refers to "README".
- (lambda _
- (substitute* "Makefile"
- (("README") "README.md"))))
(add-after 'unpack 'patch-hardcoded-paths
(lambda _
(substitute* "Makefile"
(("/sbin/install-info") "install-info"))))
- (add-after 'unpack 'remove-which
+ (add-after 'unpack 'do-not-patch-script-shebangs
(lambda _
(substitute* "Makefile"
- (("`which perl`") "perl")
- (("`which bash`") "bash"))))
- (add-after 'unpack 'clean
- (lambda _
- ;; Delete the pre-compiled elc files for Emacs 23.
- (invoke "make" "clean")))
+ (("install-bin: scripts") "install-bin:"))))
(add-after 'install 'install-doc
(lambda* (#:key make-flags #:allow-other-keys)
;; XXX FIXME avoid building/installing pdf files,

base-commit: 8e71580aae17f0c84896519d63246ab4bbb77fc4
--
2.46.0
S
S
Suhail Singh wrote 5 days ago
(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
87y10eyrzx.fsf@gmail.com
Morgan Smith <Morgan.J.Smith@outlook.com> writes:

Toggle quote (17 lines)
> * gnu/packages/coq.scm (proof-general): Update to 4.5-1.d668946.
> [phases] Remove unneeded phases and fix shebang fix.
>
> ...
>
> diff --git a/gnu/packages/coq.scm b/gnu/packages/coq.scm
> index ea0868f226..e6df4bf98f 100644
> --- a/gnu/packages/coq.scm
> +++ b/gnu/packages/coq.scm
> @@ -135,7 +135,7 @@ (define-public proof-general
> ;; The latest release is from 2022 and there has been more than 100 commits
> ;; since then.
> ;; Commit from 2024-04-29.
> - (let ((commit "cb23709ad0c9a9ca0ee48b3ee73c29caea243b98")
> + (let ((commit "d6689469298b4140dc1f0f8b0ff7e8f937041ffe")
> (revision "1"))

Shouldn't the revision be incremented as well?

--
Suhail
M
M
Morgan Smith wrote 5 days ago
[PATCH v2] gnu: proof-general: Update to 4.5-2.d668946.
(address . suhailsingh247@gmail.com)
CH3PR84MB34247FFAAB0F1F0DBDCF2120C5052@CH3PR84MB3424.NAMPRD84.PROD.OUTLOOK.COM
* gnu/packages/coq.scm (proof-general): Update to 4.5-2.d668946.
[phases] Remove unneeded phases and fix shebang fix.

Change-Id: I5ce2775cf18775737853d76b5a50d461aa9d14e6
---

Yes I should bump the revision. Thanks for catching that!

gnu/packages/coq.scm | 26 +++++---------------------
1 file changed, 5 insertions(+), 21 deletions(-)

Toggle diff (59 lines)
diff --git a/gnu/packages/coq.scm b/gnu/packages/coq.scm
index ea0868f226..3ef91ad78a 100644
--- a/gnu/packages/coq.scm
+++ b/gnu/packages/coq.scm
@@ -135,8 +135,8 @@ (define-public proof-general
;; The latest release is from 2022 and there has been more than 100 commits
;; since then.
;; Commit from 2024-04-29.
- (let ((commit "cb23709ad0c9a9ca0ee48b3ee73c29caea243b98")
- (revision "1"))
+ (let ((commit "d6689469298b4140dc1f0f8b0ff7e8f937041ffe")
+ (revision "2"))
(package
(name "proof-general")
(version (git-version "4.5" revision commit))
@@ -148,7 +148,7 @@ (define-public proof-general
(file-name (git-file-name name version))
(sha256
(base32
- "1spd8rz95s1x91i4lbbb6zabb8014fihx6ai6pgad1nwyr0y9bir"))))
+ "1d12z41rn5nh15qj4sf0w8xrbd9djxlrz0r6g38fiq63i7krbm4x"))))
(build-system gnu-build-system)
(native-inputs
`(("emacs" ,emacs-minimal)
@@ -168,30 +168,14 @@ (define-public proof-general
#:phases
(modify-phases %standard-phases
(delete 'configure)
- (add-after 'unpack 'disable-byte-compile-error-on-warn
- (lambda _
- (substitute* "Makefile"
- (("\\(setq byte-compile-error-on-warn t\\)")
- "(setq byte-compile-error-on-warn nil)"))))
- (add-after 'unpack 'modify-readme-name
- ;; The README file is called "README.md", but the Make variable
- ;; "DOC_FILES" still refers to "README".
- (lambda _
- (substitute* "Makefile"
- (("README") "README.md"))))
(add-after 'unpack 'patch-hardcoded-paths
(lambda _
(substitute* "Makefile"
(("/sbin/install-info") "install-info"))))
- (add-after 'unpack 'remove-which
+ (add-after 'unpack 'do-not-patch-script-shebangs
(lambda _
(substitute* "Makefile"
- (("`which perl`") "perl")
- (("`which bash`") "bash"))))
- (add-after 'unpack 'clean
- (lambda _
- ;; Delete the pre-compiled elc files for Emacs 23.
- (invoke "make" "clean")))
+ (("install-bin: scripts") "install-bin:"))))
(add-after 'install 'install-doc
(lambda* (#:key make-flags #:allow-other-keys)
;; XXX FIXME avoid building/installing pdf files,

base-commit: 8e71580aae17f0c84896519d63246ab4bbb77fc4
--
2.46.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 74931@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74931
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch