(address . guix-patches@gnu.org)(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
* gnu/packages/coq.scm (proof-general): Update to 4.5-1.d668946.
[phases] Remove unneeded phases and fix shebang fix.
Change-Id: I5ce2775cf18775737853d76b5a50d461aa9d14e6
---
Currently the coqtags program included in proof-general does not work as the
shebang is patched incorrectly.
This patch fixes that and updates proof-general.
gnu/packages/coq.scm | 24 ++++--------------------
1 file changed, 4 insertions(+), 20 deletions(-)
Toggle diff (57 lines)
diff --git a/gnu/packages/coq.scm b/gnu/packages/coq.scm
index ea0868f226..e6df4bf98f 100644
--- a/gnu/packages/coq.scm
+++ b/gnu/packages/coq.scm
@@ -135,7 +135,7 @@ (define-public proof-general
;; The latest release is from 2022 and there has been more than 100 commits
;; since then.
;; Commit from 2024-04-29.
- (let ((commit "cb23709ad0c9a9ca0ee48b3ee73c29caea243b98")
+ (let ((commit "d6689469298b4140dc1f0f8b0ff7e8f937041ffe")
(revision "1"))
(package
(name "proof-general")
@@ -148,7 +148,7 @@ (define-public proof-general
(file-name (git-file-name name version))
(sha256
(base32
- "1spd8rz95s1x91i4lbbb6zabb8014fihx6ai6pgad1nwyr0y9bir"))))
+ "1d12z41rn5nh15qj4sf0w8xrbd9djxlrz0r6g38fiq63i7krbm4x"))))
(build-system gnu-build-system)
(native-inputs
`(("emacs" ,emacs-minimal)
@@ -168,30 +168,14 @@ (define-public proof-general
#:phases
(modify-phases %standard-phases
(delete 'configure)
- (add-after 'unpack 'disable-byte-compile-error-on-warn
- (lambda _
- (substitute* "Makefile"
- (("\\(setq byte-compile-error-on-warn t\\)")
- "(setq byte-compile-error-on-warn nil)"))))
- (add-after 'unpack 'modify-readme-name
- ;; The README file is called "README.md", but the Make variable
- ;; "DOC_FILES" still refers to "README".
- (lambda _
- (substitute* "Makefile"
- (("README") "README.md"))))
(add-after 'unpack 'patch-hardcoded-paths
(lambda _
(substitute* "Makefile"
(("/sbin/install-info") "install-info"))))
- (add-after 'unpack 'remove-which
+ (add-after 'unpack 'do-not-patch-script-shebangs
(lambda _
(substitute* "Makefile"
- (("`which perl`") "perl")
- (("`which bash`") "bash"))))
- (add-after 'unpack 'clean
- (lambda _
- ;; Delete the pre-compiled elc files for Emacs 23.
- (invoke "make" "clean")))
+ (("install-bin: scripts") "install-bin:"))))
(add-after 'install 'install-doc
(lambda* (#:key make-flags #:allow-other-keys)
;; XXX FIXME avoid building/installing pdf files,
base-commit: 8e71580aae17f0c84896519d63246ab4bbb77fc4
--
2.46.0