[PATCH] gnu: radicale: Update to 3.3.2.

  • Done
  • quality assurance status badge
Details
2 participants
  • Jonathan Brielmaier
  • Ludovic Courtès
Owner
unassigned
Submitted by
Jonathan Brielmaier
Severity
normal

Debbugs page

Jonathan Brielmaier wrote 3 months ago
(address . guix-patches@gnu.org)(name . Jonathan Brielmaier)(address . jonathan.brielmaier@web.de)
cdc8741302f22660b9c30484803e1768c68400c5.1734462183.git.jonathan.brielmaier@web.de
* gnu/packages/dav.scm (radicale): Update to 3.3.2.
[build-system]: Switch to pyproject-build-system.
[native-inputs]: Remove no longer used python-pytest-runner. Add
python-setuptools and python-wheel.
[propagated-inputs]: Remove no longer used python-dateutil. Add
python-pika.

Change-Id: I2fa789fb828cba01bb246e1f747cf170881fc3bb
---
gnu/packages/dav.scm | 17 ++++++++++-------
1 file changed, 10 insertions(+), 7 deletions(-)

Toggle diff (50 lines)
diff --git a/gnu/packages/dav.scm b/gnu/packages/dav.scm
index e4b85ae2d94..ec76181bb90 100644
--- a/gnu/packages/dav.scm
+++ b/gnu/packages/dav.scm
@@ -4,7 +4,7 @@
;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2021 Tanguy Le Carrour <tanguy@bioneland.org>
-;;; Copyright © 2022 Jonathan Brielmaier <jonathan.brielmaier@web.de>
+;;; Copyright © 2022, 2024 Jonathan Brielmaier <jonathan.brielmaier@web.de>
;;; Copyright © 2024 Nicolas Graves <ngraves@ngraves.fr>
;;;
;;; This file is part of GNU Guix.
@@ -45,7 +45,7 @@ (define-module (gnu packages dav)
(define-public radicale
(package
(name "radicale")
- (version "3.1.8")
+ (version "3.3.2")
(source
(origin
(method git-fetch)
@@ -54,17 +54,20 @@ (define-public radicale
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1qy2azn02bw772yhzgqvyf1pyl0ijj9ccvl1078w9icl261yljap"))))
- (build-system python-build-system)
+ (base32 "0walj1b7jrcc85maav04ciiipcqsl0mwbq3icksql26vr4i3y19z"))))
+ (build-system pyproject-build-system)
(native-inputs
(list python-pytest
python-pytest-cov
python-pytest-flake8
python-pytest-isort
- python-pytest-runner
- python-waitress))
+ python-setuptools
+ python-waitress
+ python-wheel))
(propagated-inputs
- (list python-dateutil python-defusedxml python-passlib
+ (list python-defusedxml
+ python-passlib
+ python-pika
python-vobject))
(synopsis "Basic CalDAV and CardDAV server")
(description "Radicale is a CalDAV and CardDAV server for UNIX-like

base-commit: 8e71580aae17f0c84896519d63246ab4bbb77fc4
--
2.46.0
Jonathan Brielmaier wrote 3 months ago
(address . 74929@debbugs.gnu.org)
83f9c781-ee64-493c-a876-b232ea947668@web.de
I'm using this patch on my personal server, which runs a radicale
service. Let's see how it behaves...
Ludovic Courtès wrote 3 months ago
(name . Jonathan Brielmaier)(address . jonathan.brielmaier@web.de)(address . 74929-done@debbugs.gnu.org)
87r05y6zn6.fsf@gnu.org
Jonathan Brielmaier <jonathan.brielmaier@web.de> skribis:

Toggle quote (9 lines)
> * gnu/packages/dav.scm (radicale): Update to 3.3.2.
> [build-system]: Switch to pyproject-build-system.
> [native-inputs]: Remove no longer used python-pytest-runner. Add
> python-setuptools and python-wheel.
> [propagated-inputs]: Remove no longer used python-dateutil. Add
> python-pika.
>
> Change-Id: I2fa789fb828cba01bb246e1f747cf170881fc3bb

Applied, thanks! :-)
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 74929@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74929
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help