Christopher O'Neill wrote 3 months ago
(address . guix-patches@gnu.org)
* gnu/packages/sync.scm (onedrive): Update to 2.5.3. Move several commits
ahead to incorporate OpenSSL version error fix and other fixes.
Change-Id: I98ea4153af7053e5b551baa68f04a80fa7e3b0a3
---
gnu/packages/sync.scm | 7 ++++---
1 file changed, 4 insertions(+), 3 deletions(-)
Toggle diff (25 lines)
diff --git a/gnu/packages/sync.scm b/gnu/packages/sync.scm
index af736d0c28..3cba6a5d4e 100644
--- a/gnu/packages/sync.scm
+++ b/gnu/packages/sync.scm
@@ -374,16 +374,17 @@ (define-public owncloud-client
(define-public onedrive
(package
(name "onedrive")
- (version "2.4.25")
+ ;; Move ahead of 2.5.3 for OpenSSL version check error and other fixes
+ (version "2.5.3-1.71a71da")
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/abraunegg/onedrive")
- (commit (string-append "v" version))))
+ (commit "71a71da1e0c981969900fa690c93905e0cc4b9b5")))
(file-name (git-file-name name version))
(sha256
- (base32 "1i93mq4r9w8cqrdfsfv8wparfd3dbrppc5z04ab056545hk0x89k"))))
+ (base32 "1rr3aw363gln4i8j3b43mih1acqj5way7ybs0mndxkhsayw67vb0"))))
(build-system gnu-build-system)
(arguments
(list
--
2.46.0