(address . guix-patches@gnu.org)
* gnu/packages/emacs-xyz.scm (emacs-sicp): New variable.
Change-Id: Ia0da0c971fc5c2d2bd2e0129708683608d41916e
---
gnu/packages/emacs-xyz.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)
Toggle diff (36 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 2809894d1a..8dea34351a 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -8005,6 +8005,29 @@ (define-public emacs-page-break-lines
as horizontal rules.")
(license license:gpl3+)))
+(define-public emacs-sicp
+ (let ((commit "552b44fd873b5cadde4e76d10cef4d6e21a4287a")
+ (revision "0"))
+ (package
+ (name "emacs-sicp")
+ (version (git-version "0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/webframp/sicp-info")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0v3cwflnbqbw1k2m1yvl8xxna0ipgdqki7y9jpvqyhm6lhrkrmdi"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/webframp/sicp-info")
+ (synopsis "Structure and Interpretation of Computer Programs in Info format")
+ (description
+ "This package provides the second edition of the book Structure and
+Interpretation of Computer Programs (SICP) in Info format.")
+ (license license:gpl3+))))
+
(define-public emacs-simple-httpd
(package
(name "emacs-simple-httpd")
base-commit: a9003b8e6b40b59c9545ae87bb441d3549630db7