[PATCH] gnu: pinebook-pro-image-type: augment partition offset.

  • Done
  • quality assurance status badge
Details
2 participants
  • dannym
  • Yarl Baudig
Owner
unassigned
Submitted by
Yarl Baudig
Severity
normal
Y
Y
Yarl Baudig wrote on 15 Dec 2024 15:07
(address . guix-patches@gnu.org)(name . Yarl Baudig)(address . yarl-baudig@mailoo.org)
20241215140842.59402-1-yarl-baudig@mailoo.org
* gnu/system/images/pinebook-pro.scm: augment partition offset
to make room for the bootloader.

Change-Id: I91a3758243a13960165d40b94efe017e6e059a22
---
u-boot.itb is too big and overwrites the system partition.
gnu/system/images/pinebook-pro.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/system/images/pinebook-pro.scm b/gnu/system/images/pinebook-pro.scm
index 3a0f3abf1f..2282e13719 100644
--- a/gnu/system/images/pinebook-pro.scm
+++ b/gnu/system/images/pinebook-pro.scm
@@ -61,7 +61,7 @@ (define pinebook-pro-image-type
(constructor (lambda (os)
(image
(inherit
- (raw-with-offset-disk-image (* 9 (expt 2 20)))) ;9MiB
+ (raw-with-offset-disk-image (* 16 (expt 2 20)))) ;16MiB
(operating-system os)
(platform aarch64-linux))))))
--
2.46.0
D
D
dannym wrote 6 days ago
merged pinebook partition offset change to master
(address . 74887-done@debbugs.gnu.org)
0d5c47ae7e7dc02cee1f51e1ae97b707@friendly-machines.com
Hi,

I've merged the pinebook partition offset change to guix master as
commit 41e192c922ec4747e399ee956f162602b6391edd.

Cheers,
Danny
Closed
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 74887@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74887
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch