[PATCH] add qt6ct configuration tool

  • Done
  • quality assurance status badge
Details
2 participants
  • Josep Bigorra
  • Zheng Junjie
Owner
unassigned
Submitted by
Josep Bigorra
Severity
normal
J
J
Josep Bigorra wrote on 13 Dec 2024 14:03
(address . guix-patches@gnu.org)
CAM_04A0_31hqKsFfXjNmBYOOK88mbmS-2Na-ej4QtGx4bKTrzA@mail.gmail.com
Hi all, I am submitting a patch adding the qt6ct tool so that we can
configure Qt6 application properly on Guix.

Hope I didn't miss anything!
Thanks, regards,

Joe
From b1b926172e5f2006ebea21419063e4378a894ec5 Mon Sep 17 00:00:00 2001
Message-ID: <b1b926172e5f2006ebea21419063e4378a894ec5.1734094970.git.jjbigorra@gmail.com>
From: Josep Bigorra <jjbigorra@gmail.com>
Date: Fri, 13 Dec 2024 14:02:26 +0100
Subject: [PATCH] add qt6ct to guix packages

---
gnu/packages/qt.scm | 39 +++++++++++++++++++++++++++++++++++++++
1 file changed, 39 insertions(+)

Toggle diff (59 lines)
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index cd0b3d6..1ef84c0 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -31,6 +31,7 @@
;;; Copyright © 2022, 2024 Zheng Junjie <873216071@qq.com>
;;; Copyright © 2023 Herman Rimm <herman@rimm.ee>
;;; Copyright © 2024 Foundation Devices, Inc. <hello@foundation.xyz>
+;;; Copyright © 2024 Josep Bigorra <jjbigorra@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -268,6 +269,44 @@ (define-public qt5ct
(home-page "https://qt5ct.sourceforge.io/")
(license license:bsd-2)))
+(define-public qt6ct
+ (package
+ (name "qt6ct")
+ (version "0.9")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/trialuser02/qt6ct")
+ (commit version)))
+ (sha256
+ (base32 "0dknk4qqzqc5wa763nclb1k6jkmvjh8kzz8kfp4iggy9jy0vnzgb"))))
+ (build-system qt-build-system)
+ (arguments
+ (list
+ #:qtbase qtbase
+ #:tests? #f ; No target
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch
+ (lambda _
+ (substitute* '("src/qt6ct-qtplugin/CMakeLists.txt"
+ "src/qt6ct-style/CMakeLists.txt")
+ (("\\$\\{PLUGINDIR\\}")
+ (string-append #$output "/lib/qt6/plugins"))))))))
+ (native-inputs
+ (list qttools))
+ (inputs
+ (list qtsvg
+ libxkbcommon))
+ (synopsis "Qt6 Configuration Tool")
+ (description "Qt6CT is a program that allows users to configure Qt6
+settings (such as icons, themes, and fonts) in desktop environments or
+window managers, that don't provide Qt integration by themselves.")
+ (home-page "https://github.com/trialuser02/qt6ct")
+ (license license:bsd-2)))
+
(define-public kddockwidgets
(package
(name "kddockwidgets")
--
2.46.0
Z
Z
Zheng Junjie wrote on 14 Dec 2024 14:24
(name . Josep Bigorra)(address . jjbigorra@gmail.com)(address . 74850-done@debbugs.gnu.org)
87ikrm4cte.fsf@iscas.ac.cn
Josep Bigorra <jjbigorra@gmail.com> writes:

Toggle quote (10 lines)
> Hi all, I am submitting a patch adding the qt6ct tool so that we can
> configure Qt6 application properly on Guix.
>
> Hope I didn't miss anything!
> Thanks, regards,
>
> Joe
>
> [2. text/x-patch; 0001-add-qt6ct-to-guix-packages.patch]...

adjust message and indent


gnu: Add qt6ct.

* gnu/packages/qt.scm (qt6ct): New variable.


pushed, closing.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEfr6klGDOXiwIdX/bO1qpk+Gi3/AFAmddhx0ACgkQO1qpk+Gi
3/DYAA/+OTMlSFRuglyyCmrdYK5dWZUZTjsCxsRjWmNps9xGZ2FIhZiFRLfVhLl2
YPVTlV7AdBzn/j31YebfB73QtTYYzPT9fRd6G+h3uf53auM8d/jng0936jP7ckEe
fpJu755R8sgbTGZc9Fc5+X3eZT8EDAR61GIwSTXcKfuwm6j+07j8bCJNgPoGR89g
rTXS1UenxbgtAmEFAeeUHen49WqAMv25yEkAbZ5r2asbdYVvV0GwGBg/rhRSq/WU
+uh8INkvAk66TW2j6M5lAIMN2NSipVY6CeMowFEW3EDeVnfm4VGwN5u/fNoaKzLc
OQQ0KCZn8AlPVjRZ1qpxA4GF+N6p9Sfs4ekQ6zzxq0EVnTCj4nZ9cZpl2VFs9sF8
pQhGJtwPEyWWKL6yQc5aemHmG0Q3/py4ftpTfw6E5PRv20bt14NFGGjbBysBhm5b
gJMCkBJyM6kvsFX5IbSQ3xZhBFBlXr2VlK1zkB92xYb5L02c5lcLHe+ts6tY1GGL
sF6zKE7mdBGzEZkiZb3KWjxHIF2b2/7Zlhaq9Xu6eZlN04Cwq5G1htzMzS2GVrU2
WEp0WJBy+8MWOFsH5bAG0sI+iNFeAfws5lKRaCSWJno20PYj1hmviXwgyBfo9Ian
bFg4qoz7VYdsf7y48OHRaLorfODXDLyYo5VjhUy7+YTA19MLhMI=
=kMbD
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 74850@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74850
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch