[PATCH 1/2] gnu: nvi: Refactor.

  • Open
  • quality assurance status badge
Details
One participant
  • Herman Rimm
Owner
unassigned
Submitted by
Herman Rimm
Severity
normal
H
H
Herman Rimm wrote on 12 Dec 21:27 +0100
(address . guix-patches@gnu.org)
5f4667ec07e73b337d6fae74d22ebf2e8097fd7c.1734035192.git.herman@rimm.ee
* gnu/packages/nvi.scm (nvi)[arguments]: Use G-exps. Replace
config.guess.

Change-Id: I03b0c334426c637ba3e55910de02d8f4b15616fb
---
gnu/packages/nvi.scm | 52 ++++++++++++++++++++++++--------------------
1 file changed, 28 insertions(+), 24 deletions(-)

Toggle diff (81 lines)
diff --git a/gnu/packages/nvi.scm b/gnu/packages/nvi.scm
index f1f461f2b4..bb23aa790a 100644
--- a/gnu/packages/nvi.scm
+++ b/gnu/packages/nvi.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 Marek Benc <merkur32@gmail.com>
;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2024 Herman Rimm <herman@rimm.ee>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -25,6 +26,7 @@ (define-module (gnu packages nvi)
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system gnu)
+ #:use-module (guix gexp)
#:use-module (guix licenses)
#:use-module (guix utils))
@@ -65,30 +67,32 @@ (define-public nvi
(build-system gnu-build-system)
(arguments
- `(#:out-of-source? #t
- #:configure-flags
- '("--enable-widechar"
- ,@(if (%current-target-system)
- '("vi_cv_sprintf_count=yes")
- '()))
- #:phases
- (modify-phases %standard-phases
- (add-before 'configure 'fix-configure
- (lambda* (#:key inputs native-inputs #:allow-other-keys)
- ;; Replace outdated config.sub and config.guess:
- (with-directory-excursion "dist"
- (for-each (lambda (file)
- (chmod file #o755)
- (install-file
- (string-append
- (assoc-ref
- (or native-inputs inputs) "automake")
- "/share/automake-"
- ,(version-major+minor
- (package-version automake))
- "/" file) "."))
- '("config.sub")))
- #t)))))
+ (list
+ #:out-of-source? #t
+ #:configure-flags
+ #~'("--enable-widechar"
+ #$@(if (%current-target-system)
+ '("vi_cv_sprintf_count=yes")
+ '()))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'configure 'fix-configure
+ (lambda* (#:key inputs native-inputs #:allow-other-keys)
+ ;; Replace outdated config.sub and config.guess:
+ (with-directory-excursion "dist"
+ (for-each
+ (lambda (file)
+ (chmod file #o755)
+ (install-file
+ (format #f "~a/share/automake-~a/~a"
+ (assoc-ref (or native-inputs inputs)
+ "automake")
+ #$(version-major+minor
+ (package-version automake))
+ file)
+ "."))
+ '("config.sub" "config.guess")))
+ #t)))))
(inputs
(list bdb ncurses))
(native-inputs

base-commit: a9003b8e6b40b59c9545ae87bb441d3549630db7
--
2.45.2
H
H
Herman Rimm wrote on 12 Dec 21:31 +0100
[PATCH 2/2] gnu: nvi: Fix cross-compilation.
(address . 74838@debbugs.gnu.org)
b0a5a321dc1b992db9afe024548c6f5fc2cb34b8.1734035192.git.herman@rimm.ee
* gnu/packages/nvi.scm (nvi)[arguments]: Disable
incompatible-pointer-type and implicit-function-declaration errors.

Change-Id: I03b0c334426c637ba3e55910de02d8f4b15616fb
---
gnu/packages/nvi.scm | 8 +++++++-
1 file changed, 7 insertions(+), 1 deletion(-)

Toggle diff (21 lines)
diff --git a/gnu/packages/nvi.scm b/gnu/packages/nvi.scm
index bb23aa790a..ce65bcd916 100644
--- a/gnu/packages/nvi.scm
+++ b/gnu/packages/nvi.scm
@@ -92,7 +92,13 @@ (define-public nvi
file)
"."))
'("config.sub" "config.guess")))
- #t)))))
+ #t))
+ (add-before 'configure 'fix-build
+ (let ((flags '("-g" "-O2" "-Wno-incompatible-pointer-types"
+ "-Wno-implicit-function-declaration")))
+ (lambda _
+ (when #$(or (target-hurd64?) (%current-target-system))
+ (setenv "CPPFLAGS" (string-join flags)))))))))
(inputs
(list bdb ncurses))
(native-inputs
--
2.45.2
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 74838@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74838
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch