[PATCH] gnu: Add emacs-disproject.

  • Open
  • quality assurance status badge
Details
One participant
  • aurtzy
Owner
unassigned
Submitted by
aurtzy
Severity
normal
A
A
aurtzy wrote on 12 Dec 19:43 +0100
(address . guix-patches@gnu.org)(name . aurtzy)(address . aurtzy@gmail.com)
b6d7564322b26082d2daafaacaf3dfd382d69109.1734029013.git.aurtzy@gmail.com
* gnu/packages/emacs-xyz.scm (emacs-disproject): New variable.

Change-Id: Ib7a56b7458a729d4893f20f89df0a75217272498
---

Hi,

Full disclosure: I'm the maintainer of this project.

Cheers,

aurtzy

gnu/packages/emacs-xyz.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (48 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 2809894d1a..3506a4225e 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -148,6 +148,7 @@
;;; Copyright © 2024 Spencer King <spencer.king@nursiapress.com>
;;; Copyright © 2024 emma thompson <bigbookofbug@proton.me>
;;; Copyright © 2024 Liam Hupfer <liam@hpfr.net>
+;;; Copyright © 2024 aurtzy <aurtzy@gmail.com>
;;;
;;; This file is part of GNU Guix.
@@ -1537,6 +1538,31 @@ (define-public emacs-project-tab-groups
separate, named tab groups.")
(license license:gpl3+))))
+(define-public emacs-disproject
+ (package
+ (name "emacs-disproject")
+ (version "1.3.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/aurtzy/disproject")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0210mllmhgmq4lx7fzcp6h43df7npn17y8qn2a7d2dcj6rgbf75k"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-transient))
+ (home-page "https://github.com/aurtzy/disproject")
+ (synopsis "Transient interface for managing and interacting with projects")
+ (description
+ "Disproject is a package for GNU Emacs that implements Transient menus for
+dispatching project-related commands on top of the @code{project.el} library. It
+aims to provide a more featureful version of the @code{project-switch-project}
+command, which it is inspired by. Those who are familiar with Projectile may also
+find similarities to @code{projectile-commander}.")
+ (license license:gpl3+)))
+
(define-public emacs-golden-ratio
(let ((commit "375c9f287dfad68829582c1e0a67d0c18119dab9")
(revision "0"))

base-commit: 3d3556ace06571f60ff9ffd23c5cf2bf75ca1321
--
2.46.0
A
A
aurtzy wrote on 13 Dec 20:46 +0100
[PATCH v2] gnu: Add emacs-disproject.
(address . 74834@debbugs.gnu.org)(name . aurtzy)(address . aurtzy@gmail.com)
d0450201b7409fe54bb711523807fe6c41313bdc.1734119175.git.aurtzy@gmail.com
* gnu/packages/emacs-xyz.scm (emacs-disproject): New variable.

Change-Id: Ib7a56b7458a729d4893f20f89df0a75217272498
---

v2 updates to recently released patch version.

gnu/packages/emacs-xyz.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (48 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 2809894d1a..d77b61df80 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -148,6 +148,7 @@
;;; Copyright © 2024 Spencer King <spencer.king@nursiapress.com>
;;; Copyright © 2024 emma thompson <bigbookofbug@proton.me>
;;; Copyright © 2024 Liam Hupfer <liam@hpfr.net>
+;;; Copyright © 2024 aurtzy <aurtzy@gmail.com>
;;;
;;; This file is part of GNU Guix.
@@ -1537,6 +1538,31 @@ (define-public emacs-project-tab-groups
separate, named tab groups.")
(license license:gpl3+))))
+(define-public emacs-disproject
+ (package
+ (name "emacs-disproject")
+ (version "1.3.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/aurtzy/disproject")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "03wf14vilnysj9szcffsadhw86p68v3083dv98d99c8axm51n6hz"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-transient))
+ (home-page "https://github.com/aurtzy/disproject")
+ (synopsis "Transient interface for managing and interacting with projects")
+ (description
+ "Disproject is a package for GNU Emacs that implements Transient menus for
+dispatching project-related commands on top of the @code{project.el} library. It
+aims to provide a more featureful version of the @code{project-switch-project}
+command, which it is inspired by. Those who are familiar with Projectile may also
+find similarities to @code{projectile-commander}.")
+ (license license:gpl3+)))
+
(define-public emacs-golden-ratio
(let ((commit "375c9f287dfad68829582c1e0a67d0c18119dab9")
(revision "0"))

base-commit: 0787a180b3ca64d3958438920ca1b58a2a27fba4
--
2.46.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 74834@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74834
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch