[PATCH] gnu: cl-nodgui: Update to 0.7.2.0-2.9a1b2c6.

  • Done
  • quality assurance status badge
Details
2 participants
  • GNU Guix Live
  • Guillaume Le Vaillant
Owner
unassigned
Submitted by
GNU Guix Live
Severity
normal
G
G
GNU Guix Live wrote on 12 Dec 12:16 +0100
(address . guix-patches@gnu.org)
edeca2d07f416296426137d778ec9490f667c33d.1734005596.git.cage-dev@twistfold.it
Change-Id: If230ce77603bfc30686a1036908687d461312b75
---
gnu/packages/lisp-xyz.scm | 25 ++++++++-----------------
1 file changed, 8 insertions(+), 17 deletions(-)

Toggle diff (59 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 16f3fe6b1b..ecbbd125f6 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -22844,11 +22844,11 @@ (define-public ecl-nkeymaps
(sbcl-package->ecl-package sbcl-nkeymaps))
(define-public sbcl-nodgui
- (let ((commit "dc3efed8f93d4955e59347824f8f6d018e1a22e0")
- (revision "1"))
+ (let ((commit "9a1b2c6419adce2ba317497328276f8d63843279")
+ (revision "2"))
(package
(name "sbcl-nodgui")
- (version (git-version "0.7.0.3" revision commit))
+ (version (git-version "0.7.2.0" revision commit))
(source
(origin
(method git-fetch)
@@ -22857,10 +22857,12 @@ (define-public sbcl-nodgui
(commit commit)))
(file-name (git-file-name "cl-nodgui" version))
(sha256
- (base32 "1kjbimzl9q74dz1fhl03n49607li55q6h0kdygfyr0n8cnf5638j"))))
+ (base32 "1qanhxn46bwq8a10v61n46q4j8avp7n1m2687bi2wdylz1pgakyq"))))
(build-system asdf-build-system/sbcl)
(native-inputs
(list sbcl-clunit2))
+ (propagated-inputs
+ (list tk tklib))
(inputs
(list sbcl-alexandria
sbcl-bordeaux-threads
@@ -22878,19 +22880,8 @@ (define-public sbcl-nodgui
sbcl-sdl2-ttf
sbcl-static-vectors
sbcl-trivial-garbage
- sbcl-zpng
- tk
- tklib))
- (arguments
- (list #:phases
- #~(modify-phases %standard-phases
- (add-after 'unpack 'fix-paths
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "src/wish-communication.lisp"
- (("#-freebsd \"wish\"")
- (string-append "#-freebsd \""
- (search-input-file inputs "/bin/wish")
- "\""))))))))
+ sbcl-zpng))
+ (arguments '())
(synopsis "Common Lisp bindings for the Tk GUI toolkit")
(description
"Nodgui (@emph{No Drama GUI}) is a Common Lisp binding for the Tk GUI

base-commit: 27750bd0cddddab9e900f289a5520314ef66487e
--
2.46.0
G
G
Guillaume Le Vaillant wrote on 17 Dec 11:50 +0100
(name . GNU Guix Live)(address . cage-dev@twistfold.it)(address . 74818@debbugs.gnu.org)
87ttb2wpkz.fsf@kitej
GNU Guix Live <cage-dev@twistfold.it> skribis:

Toggle quote (37 lines)
> Change-Id: If230ce77603bfc30686a1036908687d461312b75
> ---
> gnu/packages/lisp-xyz.scm | 25 ++++++++-----------------
> 1 file changed, 8 insertions(+), 17 deletions(-)
>
> diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
> index 16f3fe6b1b..ecbbd125f6 100644
> --- a/gnu/packages/lisp-xyz.scm
> +++ b/gnu/packages/lisp-xyz.scm
> @@ -22844,11 +22844,11 @@ (define-public ecl-nkeymaps
> (sbcl-package->ecl-package sbcl-nkeymaps))
>
> (define-public sbcl-nodgui
> [...]
> + (propagated-inputs
> + (list tk tklib))
> (inputs
> (list sbcl-alexandria
> sbcl-bordeaux-threads
> @@ -22878,19 +22880,8 @@ (define-public sbcl-nodgui
> sbcl-sdl2-ttf
> sbcl-static-vectors
> sbcl-trivial-garbage
> - sbcl-zpng
> - tk
> - tklib))
> - (arguments
> - (list #:phases
> - #~(modify-phases %standard-phases
> - (add-after 'unpack 'fix-paths
> - (lambda* (#:key inputs #:allow-other-keys)
> - (substitute* "src/wish-communication.lisp"
> - (("#-freebsd \"wish\"")
> - (string-append "#-freebsd \""
> - (search-input-file inputs "/bin/wish")
> - "\""))))))))

Hi.
Why did you replace the 'fix-paths' phase by propagated inputs?
We usually try to avoid propagating inputs if possible as it can create
conflicts in profiles.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCZ2FXfA8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j8BegEAmUU4+Em1gPI6K/1cR3tezNxL9c8UccZhvryX
3/eM08MA/jDLWbz6R9g3z0gMhEj2yYrisdF7QUH/8YTBNEmOXmes
=L56g
-----END PGP SIGNATURE-----

C
(name . Guillaume Le Vaillant)(address . glv@posteo.net)(address . 74818@debbugs.gnu.org)
8dd71996-a19c-42a0-9c5f-5cdf53718b89@twistfold.it
On 17/12/24 11:50, Guillaume Le Vaillant wrote:

> Hi.

Hi, thanks for reviewing this patch!

> Why did you replace the 'fix-paths' phase by propagated inputs?
> We usually try to avoid propagating inputs if possible as it can
> create conflicts in profiles.

I was not aware of this issue, sorry! This version of the library, at
runtime, tries to guess the path of a valid wish executable and, then,
starts a process executing said executable, communicating with the
parent process via a pipe. The `fix-path' is no more applicable as it
assumes that the path to wish is hardcoded in the source code, which is
not true, starting from this version of the library. Moreover leaving
the `tk' dependency to `inputs' makes the library unable to guess a path
for wish, leading to a crash at runtime. My changes seems to make the
library works as intended but I am very open to suggestions if a better
solution exists.

Bye!
C.
G
G
GNU Guix Live wrote on 17 Dec 20:19 +0100
[PATCH] gnu: cl-nodgui: Update to 0.7.2.0-2.9a1b2c6.
(address . glv@posteo.net)(address . 74818@debbugs.gnu.org)
aea393a0a0d09beb17dc35e98b8b35903bc25a20.1734462643.git.cage-dev@twistfold.it
Change-Id: If230ce77603bfc30686a1036908687d461312b75
---
gnu/packages/lisp-xyz.scm | 15 ++++++++-------
1 file changed, 8 insertions(+), 7 deletions(-)

Toggle diff (52 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 827febc703..a01e48d93e 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -22844,11 +22844,11 @@ (define-public ecl-nkeymaps
(sbcl-package->ecl-package sbcl-nkeymaps))
(define-public sbcl-nodgui
- (let ((commit "dc3efed8f93d4955e59347824f8f6d018e1a22e0")
- (revision "1"))
+ (let ((commit "9a1b2c6419adce2ba317497328276f8d63843279")
+ (revision "2"))
(package
(name "sbcl-nodgui")
- (version (git-version "0.7.0.3" revision commit))
+ (version (git-version "0.7.2.0" revision commit))
(source
(origin
(method git-fetch)
@@ -22857,7 +22857,7 @@ (define-public sbcl-nodgui
(commit commit)))
(file-name (git-file-name "cl-nodgui" version))
(sha256
- (base32 "1kjbimzl9q74dz1fhl03n49607li55q6h0kdygfyr0n8cnf5638j"))))
+ (base32 "1qanhxn46bwq8a10v61n46q4j8avp7n1m2687bi2wdylz1pgakyq"))))
(build-system asdf-build-system/sbcl)
(native-inputs
(list sbcl-clunit2))
@@ -22880,15 +22880,16 @@ (define-public sbcl-nodgui
sbcl-trivial-garbage
sbcl-zpng
tk
- tklib))
+ tklib
+ tcllib))
(arguments
(list #:phases
#~(modify-phases %standard-phases
(add-after 'unpack 'fix-paths
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "src/wish-communication.lisp"
- (("#-freebsd \"wish\"")
- (string-append "#-freebsd \""
+ (("\\(guess-wish-interpreter-path\\)")
+ (string-append "\""
(search-input-file inputs "/bin/wish")
"\""))))))))
(synopsis "Common Lisp bindings for the Tk GUI toolkit")

base-commit: 4a314f880be5c71b59b6d72a9b238b938c348563
--
2.46.0
C
(name . Guillaume Le Vaillant)(address . glv@posteo.net)(address . 74818@debbugs.gnu.org)
246d5f2b-02bb-474b-a710-1b12434ab8bb@twistfold.it
Hi!

Please consider checking my last patch, I think I was able to properly
get rid of the `propagated-inputs', while keeping the package working of
course! :)

Bye!
C.
G
G
Guillaume Le Vaillant wrote 6 days ago
Re: [PATCH] gnu: cl-nodgui: Update to 0.7.2.0-2.9a1b2c6.
(name . GNU Guix Live)(address . cage-dev@twistfold.it)(address . 74818-done@debbugs.gnu.org)
87v7vg3rcx.fsf@kitej
Patch applied as 91a347a99b852b45b659e53a72d63d32855daa8a.
Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCZ2Pzvg8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j+bGQD+Ic2PmSGK76gTOi0CUpluJYTWi6W4BhXuzVko
+EBPr7oA/iXjhwTYxukZdEKdJSiFPllDZ4CO8tPXy0tSIbvSq5mU
=iimz
-----END PGP SIGNATURE-----

Closed
C
C
cage wrote 6 days ago
(name . Guillaume Le Vaillant)(address . glv@posteo.net)(address . 74818-done@debbugs.gnu.org)
1fe8e986-2046-459b-8f66-d71e8a5ef2ba@twistfold.it
On 19/12/24 11:21, Guillaume Le Vaillant wrote:
Toggle quote (3 lines)
> Patch applied as 91a347a99b852b45b659e53a72d63d32855daa8a.
> Thanks.

Thank you for your suggestions!
C.
Closed
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 74818@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74818
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch