[PATCH] gnu: Add privacy-redirect-icecat.

  • Done
  • quality assurance status badge
Details
2 participants
  • Hilton Chain
  • Mark H Weaver
Owner
unassigned
Submitted by
Hilton Chain
Severity
normal
H
H
Hilton Chain wrote on 12 Dec 08:32 +0100
(address . guix-patches@gnu.org)(name . Hilton Chain)(address . hako@ultrarare.space)
4fb3448f88d9c36ce1cdecaf6d8f9f5cb0dbee88.1733987535.git.hako@ultrarare.space
* gnu/packages/browser-extensions.scm (privacy-redirect)
(privacy-redirect/icecat): New variables.

Change-Id: I92778c4b46a30f88f23758cc65837b4aecccbd09
---
gnu/packages/browser-extensions.scm | 32 +++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (54 lines)
diff --git a/gnu/packages/browser-extensions.scm b/gnu/packages/browser-extensions.scm
index 33d3caf34d..b0e4161312 100644
--- a/gnu/packages/browser-extensions.scm
+++ b/gnu/packages/browser-extensions.scm
@@ -333,3 +333,35 @@ (define noscript
(define-public noscript/icecat
(make-icecat-extension noscript))
+
+(define privacy-redirect
+ (package
+ (name "privacy-redirect")
+ (version "1.1.49")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/SimonBrazell/privacy-redirect")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "13j5i6vh4lq9hcqmqbmn8fnymnplwra5rm696h6magbjxnj3nkyz"))))
+ (build-system copy-build-system)
+ (arguments
+ (list
+ #:install-plan
+ #~'(("src" #$(assq-ref (package-properties this-package) 'addon-id)))))
+ (home-page "https://github.com/SimonBrazell/privacy-redirect")
+ (synopsis "Redirect to privacy friendly alternative frontends")
+ (description
+ "This package provides a browser extension that redirects sites to their
+privacy friendly alternative frontends. It's possible to toggle all redirects
+on and off and the extension will default to using random instances if none are
+selected.")
+ (license license:expat)
+ (properties '((addon-id . "{b7f9d2cd-d772-4302-8c3f-eb941af36f76}")))))
+
+(define-public privacy-redirect/icecat
+ (make-icecat-extension privacy-redirect))

base-commit: c2e2b0376b82a503e064fa826d1b153d94bf0b06
prerequisite-patch-id: f132b4af7b85df465998e4f459bf729f8b66f320
prerequisite-patch-id: ecd87e69b7aebebd64256db106ed96dc12f6c12d
prerequisite-patch-id: f27c33b6c7f5dcb37c36551ecde29f1f0c734935
prerequisite-patch-id: fc6ad5af54f75869a657c065c86b262d74a1efff
prerequisite-patch-id: 1665e62d1990a460bc5679bc89d600e94bab407a
prerequisite-patch-id: e1cd1fdc5036bbd74d338df158ae7c348b180cf4
prerequisite-patch-id: bea29848814b393ccd3619f0a744ee36632ac5df
prerequisite-patch-id: 41d13263266c55b695d0a28d173d795fca52e440
prerequisite-patch-id: 4ed8a51618fd43ffcbbbe458492aa8ca674da9b9
prerequisite-patch-id: 40a1f686ccb58ca654ebdd06de2a5369707bfd3e
--
2.46.0
H
H
Hilton Chain wrote on 12 Dec 08:42 +0100
[PATCH v2] gnu: Add privacy-redirect-icecat.
(address . 74812@debbugs.gnu.org)(name . Hilton Chain)(address . hako@ultrarare.space)
428941f84b99fb531c337aea514e832e4f01bec2.1733989242.git.hako@ultrarare.space
* gnu/packages/browser-extensions.scm (privacy-redirect)
(privacy-redirect/icecat): New variables.

Change-Id: I92778c4b46a30f88f23758cc65837b4aecccbd09
---

V1->V2: Correct license.

gnu/packages/browser-extensions.scm | 32 +++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (52 lines)
diff --git a/gnu/packages/browser-extensions.scm b/gnu/packages/browser-extensions.scm
index 33d3caf34d..1a073aea93 100644
--- a/gnu/packages/browser-extensions.scm
+++ b/gnu/packages/browser-extensions.scm
@@ -333,3 +333,35 @@ (define noscript

(define-public noscript/icecat
(make-icecat-extension noscript))
+
+(define privacy-redirect
+ (package
+ (name "privacy-redirect")
+ (version "1.1.49")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/SimonBrazell/privacy-redirect")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "13j5i6vh4lq9hcqmqbmn8fnymnplwra5rm696h6magbjxnj3nkyz"))))
+ (build-system copy-build-system)
+ (arguments
+ (list
+ #:install-plan
+ #~'(("src" #$(assq-ref (package-properties this-package) 'addon-id)))))
+ (home-page "https://github.com/SimonBrazell/privacy-redirect")
+ (synopsis "Redirect to privacy friendly alternative frontends")
+ (description
+ "This package provides a browser extension that redirects sites to their
+privacy friendly alternative frontends. It's possible to toggle all redirects
+on and off and the extension will default to using random instances if none are
+selected.")
+ (license license:gpl3)
+ (properties '((addon-id . "{b7f9d2cd-d772-4302-8c3f-eb941af36f76}")))))
+
+(define-public privacy-redirect/icecat
+ (make-icecat-extension privacy-redirect))

base-commit: c2e2b0376b82a503e064fa826d1b153d94bf0b06
prerequisite-patch-id: f132b4af7b85df465998e4f459bf729f8b66f320
prerequisite-patch-id: ecd87e69b7aebebd64256db106ed96dc12f6c12d
prerequisite-patch-id: f27c33b6c7f5dcb37c36551ecde29f1f0c734935
prerequisite-patch-id: fc6ad5af54f75869a657c065c86b262d74a1efff
prerequisite-patch-id: 1665e62d1990a460bc5679bc89d600e94bab407a
prerequisite-patch-id: e1cd1fdc5036bbd74d338df158ae7c348b180cf4
prerequisite-patch-id: bea29848814b393ccd3619f0a744ee36632ac5df
prerequisite-patch-id: 41d13263266c55b695d0a28d173d795fca52e440
prerequisite-patch-id: 4ed8a51618fd43ffcbbbe458492aa8ca674da9b9
prerequisite-patch-id: 40a1f686ccb58ca654ebdd06de2a5369707bfd3e
--
2.46.0
H
H
Hilton Chain wrote 7 days ago
Re: bug#74812: Acknowledgement ([PATCH] gnu: Add privacy-redirect-icecat.)
(address . 74812-done@debbugs.gnu.org)
87ikrhkn6c.wl-hako@ultrarare.space
Applied v2 as 573f47a2b06a76d1a74a370ad443178a7041ae34, closing.
Closed
M
M
Mark H Weaver wrote 4 days ago
Re: [bug#74812] [PATCH v2] gnu: Add privacy-redirect-icecat.
871py1d77j.fsf@netris.org
Hi,

Apologies for the late reply.

Hilton Chain <hako@ultrarare.space> writes:
Toggle quote (3 lines)
> * gnu/packages/browser-extensions.scm (privacy-redirect)
> (privacy-redirect/icecat): New variables.

[...]

Toggle quote (10 lines)
> +(define privacy-redirect
> + (package
> + (name "privacy-redirect")
> + (version "1.1.49")
> + (source
> + (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/SimonBrazell/privacy-redirect")

If you check the git repository above, I think you'll find that it has
not been updated in over 3 years, and that most (if not all) of the
sites that it redirects to no longer work. Therefore, I see no benefit
to adding this package in its current form.

There's also an additional problem: GNU IceCat comes bundled with a
modified and updated version of this extension. I have concerns about
how GNU IceCat might be affected if this extremely out-of-date extension
is installed in the user's profile.

What do you think?

Thanks,
Mark
H
H
Hilton Chain wrote 4 days ago
(name . Mark H Weaver)(address . mhw@netris.org)
875xndk1sj.wl-hako@ultrarare.space
Hi Mark,

On Sat, 21 Dec 2024 11:51:01 +0800,
Mark H Weaver wrote:
Toggle quote (31 lines)
>
> Hi,
>
> Apologies for the late reply.
>
> Hilton Chain <hako@ultrarare.space> writes:
> > * gnu/packages/browser-extensions.scm (privacy-redirect)
> > (privacy-redirect/icecat): New variables.
>
> [...]
>
> > +(define privacy-redirect
> > + (package
> > + (name "privacy-redirect")
> > + (version "1.1.49")
> > + (source
> > + (origin
> > + (method git-fetch)
> > + (uri (git-reference
> > + (url "https://github.com/SimonBrazell/privacy-redirect")
>
> If you check the git repository above, I think you'll find that it has
> not been updated in over 3 years, and that most (if not all) of the
> sites that it redirects to no longer work. Therefore, I see no benefit
> to adding this package in its current form.
>
> There's also an additional problem: GNU IceCat comes bundled with a
> modified and updated version of this extension. I have concerns about
> how GNU IceCat might be affected if this extremely out-of-date extension
> is installed in the user's profile.

Just tried 'guix shell icecat privacy-redirect-icecat', IceCat uses the bundled
one.

Toggle quote (2 lines)
> What do you think?

How about using the source from IceCat for this package?


Thanks
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 74812@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74812
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch