[PATCH] m4: guix: Fix detection of guile-ssh.

  • Done
  • quality assurance status badge
Details
One participant
  • Tomas Volf
Owner
unassigned
Submitted by
Tomas Volf
Severity
normal
T
T
Tomas Volf wrote on 11 Dec 23:09 +0100
(name . Tomas Volf)(address . ~@wolfsden.cz)
3b352e02fab8ad5ab52e3dfc23baf72c4b64802e.1733954997.git.~@wolfsden.cz
The check for make-session stopped working after update to 0.18.0. This
commit adds the additional `#:config #f' to skip reading the ssh
configuration, arguably we did not want to do that anyway.

* m4/guix.m4 (GUIX_CHECK_GUILE_SSH): Add `#:config #f' to make-session call.

Change-Id: Id6ea3860292159ac2e6cf2a77df5f720f66aa071
---
m4/guix.m4 | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/m4/guix.m4 b/m4/guix.m4
index 8c2757a8b7..376f40943c 100644
--- a/m4/guix.m4
+++ b/m4/guix.m4
@@ -143,7 +143,7 @@ AC_DEFUN([GUIX_CHECK_GUILE_SSH], [
(@ (ssh popen) open-remote-pipe)
(@ (ssh dist node) node-eval)
(@ (ssh auth) userauth-gssapi!)
- ((@ (ssh session) make-session) #:nodelay #t))])
+ ((@ (ssh session) make-session) #:nodelay #t #:config #f))])
if test "$retval" = 0; then
guix_cv_have_recent_guile_ssh="yes"
else
--
2.46.0
T
T
Tomas Volf wrote on 11 Dec 23:11 +0100
control message for bug #74802
(address . control@debbugs.gnu.org)
14c0a29fd15ed96ea4b05dcbad444ba0@wolfsden.cz
close 74802
quit
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 74802@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74802
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch