guix package lacks offloading capabilities (guile-ssh@0.18)

  • Open
  • quality assurance status badge
Details
2 participants
  • Dariqq
  • Tomas Volf
Owner
unassigned
Submitted by
Dariqq
Severity
normal
D
D
Dariqq wrote 6 hours ago
(address . bug-guix@gnu.org)
94127bd9-deb7-46ca-b5e8-8823f4b26845@posteo.net
Hello,

I was trying the patch for https://issues.guix.gnu.org/74787and was
wondering why it didnt work for me.

The default guix package is currently built without the offloading/ssh
support:

from the configure script:

checking whether Guile-SSH is available and recent enough... no


E.g. this recent build on ci.g.g.o:
D
D
Dariqq wrote 5 hours ago
(address . 74800@debbugs.gnu.org)
8b30cef0-5d5e-45c9-9846-3dc96b0f7627@posteo.net
Running what the GUIX_CHECK_GUILE_SSH macro expands to with
guile-ssh@0.18 yields


Toggle snippet (11 lines)
scheme@(guile-user)> (and (@ (ssh channel) channel-send-eof)
(@ (ssh popen) open-remote-pipe)
(@ (ssh dist node) node-eval)
(@ (ssh auth) userauth-gssapi!)
((@ (ssh session) make-session) #:nodelay #t))
ice-9/boot-9.scm:1685:16: In procedure raise-exception:
Throw to key `guile-ssh-error' with args `("'config' is specified, but
'host' option is missed.")'.


On 11.12.24 21:38, Dariqq wrote:
Toggle quote (15 lines)
> Hello,
>
> I was trying the patch for https://issues.guix.gnu.org/74787 and was
> wondering why it didnt work for me.
>
> The default guix package is currently built without the offloading/ssh
> support:
>
> from the configure script:
>
> checking whether Guile-SSH is available and recent enough... no
>
>
> E.g. this recent build on ci.g.g.o: https://ci.guix.gnu.org/
> build/6971850/details
T
T
Tomas Volf wrote 4 hours ago
[PATCH] m4: guix: Fix detection of guile-ssh.
(name . Tomas Volf)(address . ~@wolfsden.cz)
3b352e02fab8ad5ab52e3dfc23baf72c4b64802e.1733954997.git.~@wolfsden.cz
The check for make-session stopped working after update to 0.18.0. This
commit adds the additional `#:config #f' to skip reading the ssh
configuration, arguably we did not want to do that anyway.

* m4/guix.m4 (GUIX_CHECK_GUILE_SSH): Add `#:config #f' to make-session call.

Change-Id: Id6ea3860292159ac2e6cf2a77df5f720f66aa071
---
m4/guix.m4 | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/m4/guix.m4 b/m4/guix.m4
index 8c2757a8b7..376f40943c 100644
--- a/m4/guix.m4
+++ b/m4/guix.m4
@@ -143,7 +143,7 @@ AC_DEFUN([GUIX_CHECK_GUILE_SSH], [
(@ (ssh popen) open-remote-pipe)
(@ (ssh dist node) node-eval)
(@ (ssh auth) userauth-gssapi!)
- ((@ (ssh session) make-session) #:nodelay #t))])
+ ((@ (ssh session) make-session) #:nodelay #t #:config #f))])
if test "$retval" = 0; then
guix_cv_have_recent_guile_ssh="yes"
else
--
2.46.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 74800@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74800
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch