guix package lacks offloading capabilities (guile-ssh@0.18)

  • Done
  • quality assurance status badge
Details
3 participants
  • Dariqq
  • Ludovic Courtès
  • Tomas Volf
Owner
unassigned
Submitted by
Dariqq
Severity
normal

Debbugs page

Dariqq wrote 3 months ago
(address . bug-guix@gnu.org)
94127bd9-deb7-46ca-b5e8-8823f4b26845@posteo.net
Hello,

I was trying the patch for https://issues.guix.gnu.org/74787and was
wondering why it didnt work for me.

The default guix package is currently built without the offloading/ssh
support:

from the configure script:

checking whether Guile-SSH is available and recent enough... no


E.g. this recent build on ci.g.g.o:
Dariqq wrote 3 months ago
(address . 74800@debbugs.gnu.org)
8b30cef0-5d5e-45c9-9846-3dc96b0f7627@posteo.net
Running what the GUIX_CHECK_GUILE_SSH macro expands to with
guile-ssh@0.18 yields


Toggle snippet (11 lines)
scheme@(guile-user)> (and (@ (ssh channel) channel-send-eof)
(@ (ssh popen) open-remote-pipe)
(@ (ssh dist node) node-eval)
(@ (ssh auth) userauth-gssapi!)
((@ (ssh session) make-session) #:nodelay #t))
ice-9/boot-9.scm:1685:16: In procedure raise-exception:
Throw to key `guile-ssh-error' with args `("'config' is specified, but
'host' option is missed.")'.


On 11.12.24 21:38, Dariqq wrote:
Toggle quote (15 lines)
> Hello,
>
> I was trying the patch for https://issues.guix.gnu.org/74787 and was
> wondering why it didnt work for me.
>
> The default guix package is currently built without the offloading/ssh
> support:
>
> from the configure script:
>
> checking whether Guile-SSH is available and recent enough... no
>
>
> E.g. this recent build on ci.g.g.o: https://ci.guix.gnu.org/
> build/6971850/details
Tomas Volf wrote 3 months ago
[PATCH] m4: guix: Fix detection of guile-ssh.
(address . 74800@debbugs.gnu.org)(address . guix-patches@gnu.org)(name . Tomas Volf)(address . ~@wolfsden.cz)
3b352e02fab8ad5ab52e3dfc23baf72c4b64802e.1733954997.git.~@wolfsden.cz
The check for make-session stopped working after update to 0.18.0. This
commit adds the additional `#:config #f' to skip reading the ssh
configuration, arguably we did not want to do that anyway.

* m4/guix.m4 (GUIX_CHECK_GUILE_SSH): Add `#:config #f' to make-session call.

Change-Id: Id6ea3860292159ac2e6cf2a77df5f720f66aa071
---
m4/guix.m4 | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/m4/guix.m4 b/m4/guix.m4
index 8c2757a8b7..376f40943c 100644
--- a/m4/guix.m4
+++ b/m4/guix.m4
@@ -143,7 +143,7 @@ AC_DEFUN([GUIX_CHECK_GUILE_SSH], [
(@ (ssh popen) open-remote-pipe)
(@ (ssh dist node) node-eval)
(@ (ssh auth) userauth-gssapi!)
- ((@ (ssh session) make-session) #:nodelay #t))])
+ ((@ (ssh session) make-session) #:nodelay #t #:config #f))])
if test "$retval" = 0; then
guix_cv_have_recent_guile_ssh="yes"
else
--
2.46.0
Ludovic Courtès wrote 3 months ago
Re: bug#74800: guix package lacks offloading capabilities (guile-ssh@0.18)
(name . Tomas Volf)(address . ~@wolfsden.cz)(name . Dariqq)(address . dariqq@posteo.net)(address . 74800-done@debbugs.gnu.org)(address . guix-patches@gnu.org)
871pyc7iho.fsf_-_@gnu.org
Tomas Volf <~@wolfsden.cz> skribis:

Toggle quote (8 lines)
> The check for make-session stopped working after update to 0.18.0. This
> commit adds the additional `#:config #f' to skip reading the ssh
> configuration, arguably we did not want to do that anyway.
>
> * m4/guix.m4 (GUIX_CHECK_GUILE_SSH): Add `#:config #f' to make-session call.
>
> Change-Id: Id6ea3860292159ac2e6cf2a77df5f720f66aa071

Woow, good catch. Applied, thanks!

This Guile-SSH upgrade turned out to be trickier than expected. :-)

Ludo’.
Dariqq wrote 3 months ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(name . Tomas Volf)(address . ~@wolfsden.cz)(address . 74800@debbugs.gnu.org)
67f3024d-bb03-4a6c-a72c-8940054efcb8@posteo.net
Thanks,

On 12.12.24 21:29, Ludovic Courtès wrote:
Toggle quote (15 lines)
> Tomas Volf <~@wolfsden.cz> skribis:
>
>> The check for make-session stopped working after update to 0.18.0. This
>> commit adds the additional `#:config #f' to skip reading the ssh
>> configuration, arguably we did not want to do that anyway.
>>
>> * m4/guix.m4 (GUIX_CHECK_GUILE_SSH): Add `#:config #f' to make-session call.
>>
>> Change-Id: Id6ea3860292159ac2e6cf2a77df5f720f66aa071
>
> Woow, good catch. Applied, thanks!
>
> This Guile-SSH upgrade turned out to be trickier than expected. :-)
>

Could the guix package be updated as well s.t. the default daemon is
built with offloading again?

Toggle quote (1 lines)
> Ludo’.
?
Your comment

This issue is archived.

To comment on this conversation send an email to 74800@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74800
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help