linux-libre 6.11.11 fails to build on aarch64 (drivers/clk/meson/gxbb.c)

  • Done
  • quality assurance status badge
Details
4 participants
  • Leo Famulari
  • Maxim Cournoyer
  • Vagrant Cascadian
  • Vincent Legoll
Owner
unassigned
Submitted by
Vagrant Cascadian
Severity
normal
V
V
Vagrant Cascadian wrote on 11 Dec 19:36 +0100
(address . bug-guix@gnu.org)
87ed2et6c4.fsf@wireframe
linux-libre 6.11.11 fails to build on aarch64, while 6.11.10 built
fine.

The issue is specifically with the gxbb platform, so would not likely be
built on other architectures:

drivers/clk/meson/gxbb.c:2057:40: error: expected ')' before '|' token
2057 | .hw.init = &(struct clk_init_da|a) {
| ~ ^
| )
drivers/clk/meson/gxbb.c:2058:18: error: 'struct clk_init_da' has no member named 'name'
2058 | .name = "vclk_div12_en",
| ^~~~
drivers/clk/meson/gxbb.c:2058:25: warning: excess elements in struct initializer
2058 | .name = "vclk_div12_en",
| ^~~~~~~~~~~~~~~
drivers/clk/meson/gxbb.c:2058:25: note: (near initialization for '(anonymous)')
drivers/clk/meson/gxbb.c:2059:18: error: 'struct clk_init_da' has no member named 'ops'
2059 | .ops = &clk_regmap_gate_ops,
| ^~~
drivers/clk/meson/gxbb.c:2059:24: warning: excess elements in struct initializer
2059 | .ops = &clk_regmap_gate_ops,
| ^
drivers/clk/meson/gxbb.c:2059:24: note: (near initialization for '(anonymous)')
drivers/clk/meson/gxbb.c:2060:18: error: 'struct clk_init_da' has no member named 'parent_hws'
2060 | .parent_hws = (const struct clk_hw *[]) { &gxbb_vclk.hw },
| ^~~~~~~~~~
drivers/clk/meson/gxbb.c:2060:31: warning: excess elements in struct initializer
2060 | .parent_hws = (const struct clk_hw *[]) { &gxbb_vclk.hw },
| ^
drivers/clk/meson/gxbb.c:2060:31: note: (near initialization for '(anonymous)')
drivers/clk/meson/gxbb.c:2061:18: error: 'struct clk_init_da' has no member named 'num_parents'
2061 | .num_parents = 1,
| ^~~~~~~~~~~
drivers/clk/meson/gxbb.c:2061:32: warning: excess elements in struct initializer
2061 | .num_parents = 1,
| ^
drivers/clk/meson/gxbb.c:2061:32: note: (near initialization for '(anonymous)')
drivers/clk/meson/gxbb.c:2062:18: error: 'struct clk_init_da' has no member named 'flags'
2062 | .flags = CLK_SET_RATE_PARENT | CLK_IGNORE_UNUSED,
| ^~~~~
In file included from ./include/linux/bits.h:6,
from ./include/linux/bitops.h:6,
from ./include/linux/of.h:15,
from ./include/linux/clk-provider.h:9,
from drivers/clk/meson/gxbb.c:7:
./include/vdso/bits.h:7:33: warning: excess elements in struct initializer
7 | #define BIT(nr) (UL(1) << (nr))
| ^
./include/linux/clk-provider.h:21:33: note: in expansion of macro 'BIT'
21 | #define CLK_SET_RATE_PARENT BIT(2) /* propagate rate change up one level */
| ^~~
drivers/clk/meson/gxbb.c:2062:26: note: in expansion of macro 'CLK_SET_RATE_PARENT'
2062 | .flags = CLK_SET_RATE_PARENT | CLK_IGNORE_UNUSED,
| ^~~~~~~~~~~~~~~~~~~
./include/vdso/bits.h:7:33: note: (near initialization for '(anonymous)')
7 | #define BIT(nr) (UL(1) << (nr))
| ^
./include/linux/clk-provider.h:21:33: note: in expansion of macro 'BIT'
21 | #define CLK_SET_RATE_PARENT BIT(2) /* propagate rate change up one level */
| ^~~
drivers/clk/meson/gxbb.c:2062:26: note: in expansion of macro 'CLK_SET_RATE_PARENT'
2062 | .flags = CLK_SET_RATE_PARENT | CLK_IGNORE_UNUSED,
| ^~~~~~~~~~~~~~~~~~~
drivers/clk/meson/gxbb.c:2057:44: error: invalid use of undefined type 'struct clk_init_da'
2057 | .hw.init = &(struct clk_init_da|a) {
| ^
drivers/clk/meson/gxbb.c:2168:38: error: unknown type name 'str'
2168 | .parent_hws = (const str}ct clk_hw *[]) {
| ^~~
drivers/clk/meson/gxbb.c:2168:41: error: expected ')' before '}' token
2168 | .parent_hws = (const str}ct clk_hw *[]) {
| ~ ^
| )
drivers/clk/meson/gxbb.c:2168:41: error: expected expression before '}' token
drivers/clk/meson/gxbb.c:2168:55: error: expected ',' or ';' before ')' token
2168 | .parent_hws = (const str}ct clk_hw *[]) {
| ^
drivers/clk/meson/gxbb.c:2170:18: error: expected identifier or '(' before ',' token
2170 | },
| ^
drivers/clk/meson/gxbb.c:2172:10: error: expected identifier or '(' before ',' token
2172 | },
| ^
drivers/clk/meson/gxbb.c:2528:31: error: stray '\305' in program
2528 | .flags = CLK_SÅT_RATE_PARENT,
| ^
drivers/clk/meson/gxbb.c:2528:26: error: 'CLK_S' undeclared here (not in a function)
2528 | .flags = CLK_SÅT_RATE_PARENT,
| ^~~~~
drivers/clk/meson/gxbb.c:2528:32: error: expected '}' before 'T_RATE_PARENT'
2528 | .flags = CLK_SÅT_RATE_PARENT,
| ^~~~~~~~~~~~~
drivers/clk/meson/gxbb.c:2523:43: note: to match this '{'
2523 | .hw.init = &(struct clk_init_data){
| ^
In file included from drivers/clk/meson/gxbb.c:14:
drivers/clk/meson/gxbb.c:2711:38: error: stray '\317' in program
2711 | static MESON_GATE(gxbb_edp, HHI_GCLK_ÏTHER, 31);
| ^
drivers/clk/meson/clk-regmap.h:120:28: note: in definition of macro '__MESON_PCLK'
120 | .offset = (_reg), \
| ^~~~
drivers/clk/meson/gxbb.c:2637:9: note: in expansion of macro 'MESON_PCLK'
2637 | MESON_PCLK(_name, _reg, _bit, &gxbb_clk81.hw)
| ^~~~~~~~~~
drivers/clk/meson/gxbb.c:2711:8: note: in expansion of macro 'MESON_GATE'
2711 | static MESON_GATE(gxbb_edp, HHI_GCLK_ÏTHER, 31);
| ^~~~~~~~~~
drivers/clk/meson/gxbb.c:2711:29: error: 'HHI_GCLK_' undeclared here (not in a function); did you mean 'HHI_GCLK_AO'?
2711 | static MESON_GATE(gxbb_edp, HHI_GCLK_ÏTHER, 31);
| ^~~~~~~~~
drivers/clk/meson/clk-regmap.h:120:28: note: in definition of macro '__MESON_PCLK'
120 | .offset = (_reg), \
| ^~~~
drivers/clk/meson/gxbb.c:2637:9: note: in expansion of macro 'MESON_PCLK'
2637 | MESON_PCLK(_name, _reg, _bit, &gxbb_clk81.hw)
| ^~~~~~~~~~
drivers/clk/meson/gxbb.c:2711:8: note: in expansion of macro 'MESON_GATE'
2711 | static MESON_GATE(gxbb_edp, HHI_GCLK_ÏTHER, 31);
| ^~~~~~~~~~
drivers/clk/meson/gxbb.c:2711:39: error: expected ')' before 'THER'
2711 | static MESON_GATE(gxbb_edp, HHI_GCLK_ÏTHER, 31);
| ^~~~
drivers/clk/meson/clk-regmap.h:120:28: note: in definition of macro '__MESON_PCLK'
120 | .offset = (_reg), \
| ^~~~
drivers/clk/meson/gxbb.c:2637:9: note: in expansion of macro 'MESON_PCLK'
2637 | MESON_PCLK(_name, _reg, _bit, &gxbb_clk81.hw)
| ^~~~~~~~~~
drivers/clk/meson/gxbb.c:2711:8: note: in expansion of macro 'MESON_GATE'
2711 | static MESON_GATE(gxbb_edp, HHI_GCLK_ÏTHER, 31);
| ^~~~~~~~~~
drivers/clk/meson/clk-regmap.h:120:27: note: to match this '('
120 | .offset = (_reg), \
| ^
drivers/clk/meson/clk-regmap.h:133:9: note: in expansion of macro '__MESON_PCLK'
133 | __MESON_PCLK(_name, _reg, _bit, &clk_regmap_gate_ops, _pname)
| ^~~~~~~~~~~~
drivers/clk/meson/gxbb.c:2637:9: note: in expansion of macro 'MESON_PCLK'
2637 | MESON_PCLK(_name, _reg, _bit, &gxbb_clk81.hw)
| ^~~~~~~~~~
drivers/clk/meson/gxbb.c:2711:8: note: in expansion of macro 'MESON_GATE'
2711 | static MESON_GATE(gxbb_edp, HHI_GCLK_ÏTHER, 31);
| ^~~~~~~~~~
make[5]: *** [scripts/Makefile.build:244: drivers/clk/meson/gxbb.o] Error 1
make[4]: *** [scripts/Makefile.build:485: drivers/clk/meson] Error 2
make[3]: *** [scripts/Makefile.build:485: drivers/clk] Error 2
make[2]: *** [scripts/Makefile.build:485: drivers] Error 2
make[2]: *** Waiting for unfinished jobs....

Possibly due to changes in upstream linux, or maybe the linux-libre
patching...

I do have the full log if that would be useful, but I think the above is
the meaningful bits from it.

live well,
vagrant
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCZ1nbqwAKCRDcUY/If5cW
qgfCAPwKosZXVTZ2dmFDnB5xlBJycerQY3L2T4eKXFYADH+p8gD9FxY9uMYY5P5E
N28hcPfEsBO3E3E9icMu4GI1t8izxwA=
=LjrX
-----END PGP SIGNATURE-----

V
V
Vincent Legoll wrote on 12 Dec 09:37 +0100
(address . 74797@debbugs.gnu.org)
CAEwRq=pOMJxDhn=LZX5e3ss5=W9o7usS_8mTruMdRWn2H1NtRw@mail.gmail.com
Hello Vagrant,

that file looks corrupted

For example the first error:

2057 | .hw.init = &(struct clk_init_da|a) {

that should be "clk_init_data", see:

2168 | .parent_hws = (const str}ct clk_hw *[]) {

here it's "struct"

etc...

--
Vincent Legoll
Attachment: file
M
M
Maxim Cournoyer wrote on 14 Dec 08:15 +0100
Re: bug#74797: linux-libre 6.11.11 fails to build on aarch64 (drivers/clk/meson/gxbb.c)
(name . Vincent Legoll)(address . vincent.legoll@gmail.com)
87a5cy3fcv.fsf_-_@gmail.com
Hello,

Vincent Legoll <vincent.legoll@gmail.com> writes:

Toggle quote (15 lines)
> Hello Vagrant,
>
> that file looks corrupted
>
> For example the first error:
>
> 2057 | .hw.init = &(struct clk_init_da|a) {
>
> that should be "clk_init_data", see:
> https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/tree/drivers/clk/meson/gxbb.c#n2051
>
> 2168 | .parent_hws = (const str}ct clk_hw *[]) {
>
> here it's "struct"

Oh! Perhaps the Linux-libre deblob scripts caused it?

--
Thanks,
Maxim
V
V
Vagrant Cascadian wrote on 14 Dec 08:56 +0100
Re: bug#74797 - Re: linux-libre 6.11.11 fails to build on aarch64 (drivers/clk/meson/gxbb.c)
87a5cyu28c.fsf@wireframe
On 2024-12-12, Vincent Legoll wrote:
Toggle quote (13 lines)
> that file looks corrupted
>
> For example the first error:
>
> 2057 | .hw.init = &(struct clk_init_da|a) {
>
> that should be "clk_init_data", see:
> https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/tree/drivers/clk/meson/gxbb.c#n2051
>
> 2168 | .parent_hws = (const str}ct clk_hw *[]) {
>
> here it's "struct"

You are right! Somehow the source tarballs had gotten corrupted.

When I tried to untar one of the tarballs manually, it was so corrupted
that it failed to unpack it, which makes me wonder how it actually got
as far as trying to build the kernel...

I 'guix gc'ed them and was able to successfully build after a few tries
and freeing up more and more disk space.

The worried part of me wonders if there is bad hardware, ram, disk or
cpu...

But seems to be working for now!

live well,
vagrant
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCZ106MwAKCRDcUY/If5cW
qonWAQCWA51T4rF/ibHthwpTPF8j/OeHttqv81wiqBVfCEV0BQD/ZSfk37KOLJSU
1Y5Ex2wQO3T2oV2qAlHl5BB5cAZzCw4=
=qV83
-----END PGP SIGNATURE-----

Closed
V
V
Vincent Legoll wrote on 14 Dec 12:12 +0100
(name . Vagrant Cascadian)(address . vagrant@debian.org)
CAEwRq=qvYoJCgzChirYAzEmo6P=6vHm5xKm_LHjKOXEycFH3Wg@mail.gmail.com
Hello Vagrant & other guixers,

On Sat, Dec 14, 2024 at 7:56?AM Vagrant Cascadian <vagrant@debian.org>
wrote:

Toggle quote (18 lines)
> On 2024-12-12, Vincent Legoll wrote:
> > that file looks corrupted
> >
> > For example the first error:
> >
> > 2057 | .hw.init = &(struct clk_init_da|a) {
> >
> > that should be "clk_init_data", see:
> >
> https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/tree/drivers/clk/meson/gxbb.c#n2051
> >
> > 2168 | .parent_hws = (const str}ct clk_hw *[]) {
> >
> > here it's "struct"
>
> You are right! Somehow the source tarballs had gotten corrupted.
>

166 246 A6 10100110 ¦ &#166; Pipe
116 164 74 01110100 t &#116; Lowercase t

125 175 7D 01111101 } &#125; Closing brace
117 165 75 01110101 u &#117; Lowercase u

while the "u" -> "}" may be a single bit flip error,
the "t" -> "|" is more complicated than that...


Toggle quote (4 lines)
> The worried part of me wonders if there is bad hardware, ram, disk or
> cpu...
>

I hope for you that it's not, and for the rest of us that it is (and not a
hard to
track down SW bug)...


Toggle quote (3 lines)
> But seems to be working for now!
>

I'd be reluctant to trust that HW, from now on, I'd keep a close eye on
it...
Does it have ECC RAM ?

Regards

--
Vincent Legoll
Attachment: file
Closed
M
M
Maxim Cournoyer wrote on 15 Dec 02:03 +0100
(name . Vincent Legoll)(address . vincent.legoll@gmail.com)
87a5cx21vk.fsf@gmail.com
Hi,

Vincent Legoll <vincent.legoll@gmail.com> writes:

Toggle quote (49 lines)
> Hello Vagrant & other guixers,
>
> On Sat, Dec 14, 2024 at 7:56?AM Vagrant Cascadian <vagrant@debian.org>
> wrote:
>
>> On 2024-12-12, Vincent Legoll wrote:
>> > that file looks corrupted
>> >
>> > For example the first error:
>> >
>> > 2057 | .hw.init = &(struct clk_init_da|a) {
>> >
>> > that should be "clk_init_data", see:
>> >
>> https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/tree/drivers/clk/meson/gxbb.c#n2051
>> >
>> > 2168 | .parent_hws = (const str}ct clk_hw *[]) {
>> >
>> > here it's "struct"
>>
>> You are right! Somehow the source tarballs had gotten corrupted.
>>
>
> 166 246 A6 10100110 ¦ &#166; Pipe
> 116 164 74 01110100 t &#116; Lowercase t
>
> 125 175 7D 01111101 } &#125; Closing brace
> 117 165 75 01110101 u &#117; Lowercase u
>
> while the "u" -> "}" may be a single bit flip error,
> the "t" -> "|" is more complicated than that...
>
>
>> The worried part of me wonders if there is bad hardware, ram, disk or
>> cpu...
>>
>
> I hope for you that it's not, and for the rest of us that it is (and not a
> hard to
> track down SW bug)...
>
>
>> But seems to be working for now!
>>
>
> I'd be reluctant to trust that HW, from now on, I'd keep a close eye on
> it...
> Does it have ECC RAM ?

Also, a checksummed file system like Btrfs can help detect corruption on
disk (it won't help when the data was written corrupted already, which
is the part where ECC RAM would help).

--
Thanks,
Maxim
Closed
L
L
Leo Famulari wrote on 15 Dec 05:51 +0100
Re: linux-libre 6.11.11 fails to build on aarch64 (drivers/clk/meson/gxbb.c)
(name . Vagrant Cascadian)(address . vagrant@debian.org)(address . 74797@debbugs.gnu.org)
Z15gWPSk-WXYvNzc@jasmine.lan
On Wed, Dec 11, 2024 at 10:36:27AM -0800, Vagrant Cascadian wrote:
Toggle quote (3 lines)
> linux-libre 6.11.11 fails to build on aarch64, while 6.11.10 built
> fine.

What commit of Guix does it happen with?

Also, what's the derivation that fails to build? Do you know the name of
the store item of the seemingly corrupted tarball?
V
V
Vagrant Cascadian wrote on 15 Dec 07:21 +0100
(name . Leo Famulari)(address . leo@famulari.name)(address . 74797@debbugs.gnu.org)
87ed29bh66.fsf@contorta
On 2024-12-14, Leo Famulari wrote:
Toggle quote (9 lines)
> On Wed, Dec 11, 2024 at 10:36:27AM -0800, Vagrant Cascadian wrote:
>> linux-libre 6.11.11 fails to build on aarch64, while 6.11.10 built
>> fine.
>
> What commit of Guix does it happen with?
>
> Also, what's the derivation that fails to build? Do you know the name of
> the store item of the seemingly corrupted tarball?

Well, it only hgappened once, and with the same commit, it successfully
regenerated the tarball and everything was fine...

FWIW, the guix pull'ed commits where it happened were:

68d3c1adcb4d2667ad053aacf5b2ab6602377475
6f8c8a86d827627f503a803381bce7fbcf8f39a0

I cannot remember off the top of my head weather it was the upstream
tarball or:

/gnu/store/3aawi9saa92n35kknxv1m97lhjkx7j8g-linux-libre-6.11.11-guix.tar.zst

But I removed the tarballs with 'guix gc' and then everything was fine
on the next tries after it redownloaded and regenerated the new
tarballs. So, I daresay I have destroyed the evidence...

If i happens again, I can do more research.


live well,
vagrant
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCZ151UQAKCRDcUY/If5cW
qinLAP4mrX2RdbONU7BcnchSgcbwLyJIj5E7GsSOFR/X5RlUSwEAkjFIKkzNGoC5
U1LF9K7mgD7Xg19/lEovVRs+grgxYwY=
=zXu/
-----END PGP SIGNATURE-----

L
L
Leo Famulari wrote on 15 Dec 19:11 +0100
(name . Vagrant Cascadian)(address . vagrant@debian.org)(address . 74797@debbugs.gnu.org)
Z18b3ErZe6sX9eSh@jasmine.lan
On Sat, Dec 14, 2024 at 10:21:05PM -0800, Vagrant Cascadian wrote:
Toggle quote (3 lines)
> Well, it only hgappened once, and with the same commit, it successfully
> regenerated the tarball and everything was fine...

Understood. Unfortunately I think it suggests a hardware malfunction,
although it could be a software bug.

Toggle quote (10 lines)
> FWIW, the guix pull'ed commits where it happened were:
>
> 68d3c1adcb4d2667ad053aacf5b2ab6602377475
> 6f8c8a86d827627f503a803381bce7fbcf8f39a0
>
> I cannot remember off the top of my head weather it was the upstream
> tarball or:
>
> /gnu/store/3aawi9saa92n35kknxv1m97lhjkx7j8g-linux-libre-6.11.11-guix.tar.zst

Okay, thanks. I did check on ci.guix.gnu.org, and this file does not
exist in the store.

Toggle quote (6 lines)
> But I removed the tarballs with 'guix gc' and then everything was fine
> on the next tries after it redownloaded and regenerated the new
> tarballs. So, I daresay I have destroyed the evidence...
>
> If i happens again, I can do more research.

Thanks, I'd appreciate it!
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 74797@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74797
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch