[PATCH] remote: Do not double-quote the repl-command.

  • Done
  • quality assurance status badge
Details
One participant
  • Tomas Volf
Owner
unassigned
Submitted by
Tomas Volf
Severity
normal
T
T
Tomas Volf wrote on 11 Dec 17:27 +0100
(name . Tomas Volf)(address . ~@wolfsden.cz)
a70564a4793380970c1005a3813a432d98a2ef2c.1733934475.git.~@wolfsden.cz
In 0.18.0, the `open-remote-pipe*' now correctly quotes the arguments, so the
double quoting that was done by `shell-quote' is not harmful and breaks at
least offloading and deploy.

* guix/remote.scm (remote-pipe-for-gexp): Call object->string just once.

Change-Id: Id922d26d318bfdd4714e267687c1b27461196d90
---
I checked all places where the changed procedures are used and those look
correct. Nothing else in the NEWS file for 0.18.0 jumps out as a potential
issue.

guix/remote.scm | 5 +----
1 file changed, 1 insertion(+), 4 deletions(-)

Toggle diff (23 lines)
diff --git a/guix/remote.scm b/guix/remote.scm
index a58ec2103c..9423f9af12 100644
--- a/guix/remote.scm
+++ b/guix/remote.scm
@@ -48,9 +48,6 @@ (define-module (guix remote)
(define* (remote-pipe-for-gexp lowered session #:optional become-command)
"Return a remote pipe for the given SESSION to evaluate LOWERED. If
BECOME-COMMAND is given, use that to invoke the remote Guile REPL."
- (define shell-quote
- (compose object->string object->string))
-
(define repl-command
(append (or become-command '())
(list
@@ -65,7 +62,7 @@ (define* (remote-pipe-for-gexp lowered session #:optional become-command)
`("-C" ,directory))
(lowered-gexp-load-path lowered))
`("-c"
- ,(shell-quote (lowered-gexp-sexp lowered)))))
+ ,(object->string (lowered-gexp-sexp lowered)))))

(let ((pipe (apply open-remote-pipe* session OPEN_READ repl-command)))
(when (eof-object? (peek-char pipe))
--
2.46.0
T
T
Tomas Volf wrote on 11 Dec 21:25 +0100
control message for bug #74795
(address . control@debbugs.gnu.org)
05d9cc72fe44100c624c44823563dbcc@wolfsden.cz
close 74795
quit
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 74795@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74795
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch