(address . bug-guix@gnu.org)
Hello,
during debugging #74787, I noticed that when ran via pre-inst-env, guix
deploy does not use packages from the local git tree. I reverted the
commit da3c8a963f83c044568d99921480259eaa26a923 and applied the
following patch locally:
Toggle snippet (15 lines)
diff --git a/guix/remote.scm b/guix/remote.scm
index a58ec2103c..1d4442da4f 100644
--- a/guix/remote.scm
+++ b/guix/remote.scm
@@ -67,6 +67,8 @@ (define* (remote-pipe-for-gexp lowered session #:optional become-command)
`("-c"
,(shell-quote (lowered-gexp-sexp lowered)))))
+ (pk ((@ (ssh version) get-library-version)))
+
(let ((pipe (apply open-remote-pipe* session OPEN_READ repl-command)))
(when (eof-object? (peek-char pipe))
(let ((status (channel-get-exit-status pipe)))
Now building the package produces 0.17.0 as expected:
Toggle snippet (5 lines)
$ ./pre-inst-env guix build guile-ssh
/gnu/store/x3ikdxld27l1ikldwkijlv42qcgscw8w-guile-ssh-0.17.0-debug
/gnu/store/0hrwzamw41k1gl6ysnssfgzhfx3fx299-guile-ssh-0.17.0
But running guix deploy still uses 0.18.0:
Toggle snippet (5 lines)
$ ./pre-inst-env guix deploy ...
;;; ("0.18.0")
I am not sure whether this is intended, but I definitely did not expect
it and it makes local experimentation harder.
Have a nice day,
Tomas
--
There are only two hard things in Computer Science:
cache invalidation, naming things and off-by-one errors.
-----BEGIN PGP SIGNATURE-----
iQJCBAEBCgAsFiEEt4NJs4wUfTYpiGikL7/ufbZ/wakFAmdZu/sOHH5Ad29sZnNk
ZW4uY3oACgkQL7/ufbZ/wamvGA//dOZC0S8rxJuO4l311NKGIf/dS71xgqYekeYX
uG1KNYS96lWbJmzxEM7ZwmvMI1GWxa0N7CoX184banR4fxBoKRgLtCouoE4Ol+pf
czfuqWgPOTq3wFaTiqHWII79jxcWamrgR46bwgjNKh5B6+JLjwmb4g0+nnBZJZb/
Q+/AxKjPXhuy0OR7Eczfg4hre5pIf7BGu/4W64QyyCF+TRZoAQInENI+8ncfBtht
utKzepYCCGjiEnabCcYAMKsvdyERbJxriVYatIBciYifJ1yesR1vD6dpZhmlmlvB
Z3n9g0B2zZMvF+vj3VKm69T5UW8OuMUvXy4/yUDfabWI3UCWeFbk5OfIPLC1Om7b
lSB62iAGYl03SjhjowMsMojDs9cPeAFI3e07wfDaSkkA24/Uf0aOeV2xtDuE2OdS
4x34B9pyN4Ma5OClem20pHb5bJjONWJZX6KoZHopBttId7Go0m+9ZqLpII/dRcNI
riZTkb3s1cvAFAYlrmjUFg/4SbXeC2sJ8s4Gzo7CD0mUwwLa/od30ZRwMO6BUU6V
B7irYSl1ZLCxkMyO5fX2MJ/henEhLevgEgJYzc0DN22J8TPchNCroUrxVcNXFSVE
mNmLAMxSLYhqgU9kG01YwXE3i1adTaoMzzTuK7ouxMlIEF1YrrHfotldd9CHIfby
vmV2Mhg=
=NC4h
-----END PGP SIGNATURE-----