[PATCH] transformations: Add tuning wrapper for gfortran.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Romain GARBAGE
Owner
unassigned
Submitted by
Romain GARBAGE
Severity
normal
R
R
Romain GARBAGE wrote on 11 Dec 17:06 +0100
(address . guix-patches@gnu.org)
20241211160833.16079-1-romain.garbage@inria.fr
guix/transformations.scm (tuning-compiler): Add gfortran to the list
of wrapped compilers.

Change-Id: Ic7eaa07acbb5ea013af0d515686e961106a6bbbb
---
guix/transformations.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (17 lines)
diff --git a/guix/transformations.scm b/guix/transformations.scm
index 3f7d20beaa..131b8564f8 100644
--- a/guix/transformations.scm
+++ b/guix/transformations.scm
@@ -531,7 +531,7 @@ (define bin (string-append #$output "/bin"))
(symlink #$program
(string-append bin "/" program)))
'("cc" "gcc" "clang" "g++" "c++" "clang++"
- "go" "rustc" "zig")))))))
+ "gfortran" "go" "rustc" "zig")))))))
(define (build-system-with-tuning-compiler bs micro-architecture)
"Return a variant of BS, a build system, that ensures that the compiler that

base-commit: c2e2b0376b82a503e064fa826d1b153d94bf0b06
--
2.46.0
L
L
Ludovic Courtès wrote on 12 Dec 11:09 +0100
(name . Romain GARBAGE)(address . romain.garbage@inria.fr)(address . 74791-done@debbugs.gnu.org)
87cyhxfc08.fsf@inria.fr
Hello comrade,

Romain GARBAGE <romain.garbage@inria.fr> skribis:

Toggle quote (5 lines)
> guix/transformations.scm (tuning-compiler): Add gfortran to the list
> of wrapped compilers.
>
> Change-Id: Ic7eaa07acbb5ea013af0d515686e961106a6bbbb

I added the ‘tunable?’ property to ‘lapack’ and confirmed that this
works in a crude but reliable way:

Toggle snippet (6 lines)
$ pgrep -fa fortran |grep -e -march
26008 /gnu/store/piai5ba5fx901hr7pwnz2b9vysrrjmlh-gfortran-11.4.0/bin/gfortran -Dblas_EXPORTS -O2 -g -DNDEBUG -fPIC -c /tmp/guix-build-lapack-3.9.0.drv-0/lapack-3.9.0/BLAS/SRC/zher2.f -o CMakeFiles/blas.dir/zher2.f.o -march=skylake
26016 /gnu/store/piai5ba5fx901hr7pwnz2b9vysrrjmlh-gfortran-11.4.0/bin/gfortran -Dblas_EXPORTS -O2 -g -DNDEBUG -fPIC -c /tmp/guix-build-lapack-3.9.0.drv-0/lapack-3.9.0/BLAS/SRC/zhpr2.f -o CMakeFiles/blas.dir/zhpr2.f.o -march=skylake
26019 /gnu/store/piai5ba5fx901hr7pwnz2b9vysrrjmlh-gfortran-11.4.0/bin/gfortran -Dblas_EXPORTS -O2 -g -DNDEBUG -fPIC -c /tmp/guix-build-lapack-3.9.0.drv-0/lapack-3.9.0/BLAS/SRC/zgemm.f -o CMakeFiles/blas.dir/zgemm.f.o -march=skylake

Thanks!

Ludo’.
Closed
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 74791@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74791
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch