[PATCH mesa-updates 0/3] libdrm/wayland-protocols/mesa updates

  • Done
  • quality assurance status badge
Details
One participant
  • John Kehayias
Owner
unassigned
Submitted by
John Kehayias
Severity
normal

Debbugs page

John Kehayias wrote 3 months ago
(address . guix-patches@gnu.org)(name . John Kehayias)(address . john.kehayias@protonmail.com)
cover.1733898130.git.john.kehayias@protonmail.com
Hi Guix,

Here are 3 simple patches currently on mesa-updates, which looks to have built
fine. The wayland-protocols update includes a change from

Thanks!

John Kehayias (3):
gnu: libdrm: Update to 2.4.124.
gnu: wayland-protocols: Update to 1.38.
gnu: mesa: Update to 24.3.1.

gnu/packages/freedesktop.scm | 16 +++++++---------
gnu/packages/gl.scm | 7 +++++--
gnu/packages/xdisorg.scm | 6 +++---
3 files changed, 15 insertions(+), 14 deletions(-)


base-commit: 0c5d7b8480234f739448956f508307e64e8e45fa
--
2.46.0
John Kehayias wrote 3 months ago
[PATCH mesa-updates 1/3] gnu: libdrm: Update to 2.4.124.
(address . 74779@debbugs.gnu.org)(name . John Kehayias)(address . john.kehayias@protonmail.com)
5ca8e5d81e3df1c94b3cd04d733fc392106ac177.1733898130.git.john.kehayias@protonmail.com
* gnu/packages/xdisorg.scm (libdrm): Update to 2.4.124.

Change-Id: Idbc647ef24e97d682ec7d3cffd85b179ef1eacfb
---
gnu/packages/xdisorg.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (31 lines)
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index a75e9cd6ba..cfde9fea5f 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -52,7 +52,7 @@
;;; Copyright © 2021 ikasero <ahmed@ikasero.com>
;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
;;; Copyright © 2021 jgart <jgart@dismail.de>
-;;; Copyright © 2022 John Kehayias <john.kehayias@protonmail.com>
+;;; Copyright © 2022, 2024 John Kehayias <john.kehayias@protonmail.com>
;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
;;; Copyright © 2022 Derek Chuank <derekchuank@outlook.com>
;;; Copyright © 2022, 2023 Wamm K. D. <jaft.r@outlook.com>
@@ -791,7 +791,7 @@ (define-public pixman
(define-public libdrm
(package
(name "libdrm")
- (version "2.4.123")
+ (version "2.4.124")
(source (origin
(method url-fetch)
(uri (string-append
@@ -799,7 +799,7 @@ (define-public libdrm
version ".tar.xz"))
(sha256
(base32
- "17mpmp59icp8vaa47dz9gdpdh583kigq47p9a07lp9s9l5kqbfd2"))))
+ "0yd37j3c1qz9gmwvv7vwqgss8aiizypsg8hn9fpsyjnac4zjjdmc"))))
(build-system meson-build-system)
(arguments
(list #:configure-flags
--
2.46.0
John Kehayias wrote 3 months ago
[PATCH mesa-updates 2/3] gnu: wayland-protocols: Update to 1.38.
(address . 74779@debbugs.gnu.org)(name . John Kehayias)(address . john.kehayias@protonmail.com)(name . Zheng Junjie)(address . zhengjunjie@iscas.ac.cn)
691cd2bf5613e5984a94d65ad42214bcf2c44e17.1733898130.git.john.kehayias@protonmail.com
* gnu/packages/freedesktop.scm (wayland-protocols): Update to 1.38.
[source]: Switch to git-fetch.
[properties]: Remove release-monitoring-url.

Co-authored-by: Zheng Junjie <zhengjunjie@iscas.ac.cn>
Change-Id: Iaa4209eab3a467159a58d2fbedb564b1b0e5ca16
---
gnu/packages/freedesktop.scm | 16 +++++++---------
1 file changed, 7 insertions(+), 9 deletions(-)

Toggle diff (37 lines)
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index af35625c18..48d40c20a2 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -1393,15 +1393,16 @@ (define-public wayland
(define-public wayland-protocols
(package
(name "wayland-protocols")
- (version "1.37")
+ (version "1.38")
(source (origin
- (method url-fetch)
- (uri (string-append "https://gitlab.freedesktop.org/wayland/"
- name "/-/releases/" version "/downloads/"
- name "-" version ".tar.xz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.freedesktop.org/wayland/wayland-protocols")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "09pk3qhpc29x1a6srpqqw9dcvalg33vfmp14d276is7j4klrn3m7"))))
+ "1aik5zmpjwhxsfv9aa88sg95s0mg6yvy2cbqbd1xhigfbnq271zb"))))
(build-system meson-build-system)
(inputs
(list wayland))
@@ -1416,9 +1417,6 @@ (define-public wayland-protocols
add completely new functionality, or extend the functionality of some other
protocol either in Wayland core, or some other protocol in wayland-protocols.")
(home-page "https://wayland.freedesktop.org")
- (properties
- '((release-monitoring-url
- . "https://wayland.freedesktop.org/releases.html")))
(license license:expat)))

(define-public wayland-protocols-next
--
2.46.0
John Kehayias wrote 3 months ago
[PATCH mesa-updates 3/3] gnu: mesa: Update to 24.3.1.
(address . 74779@debbugs.gnu.org)(name . John Kehayias)(address . john.kehayias@protonmail.com)
d65f5c6f5ccb75d697989c5f4162b173a54a77ef.1733898130.git.john.kehayias@protonmail.com
* gnu/packages/gl.scm (mesa): Update to 24.3.1.
[arguments]: Add 'set-home-directory phase (build tries to use a
shader cache, though this without it won't fail to build).

Change-Id: I1fd7d1fe20109ccdd7386a82ecf7d415999c262a
---
gnu/packages/gl.scm | 7 +++++--
1 file changed, 5 insertions(+), 2 deletions(-)

Toggle diff (32 lines)
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index e1dfca7ca8..418970547e 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -303,7 +303,7 @@ (define libva-without-mesa
(define-public mesa
(package
(name "mesa")
- (version "24.2.5")
+ (version "24.3.1")
(source
(origin
(method url-fetch)
@@ -313,7 +313,7 @@ (define-public mesa
"mesa-" version ".tar.xz")))
(sha256
(base32
- "0vyrkmy8j5bygddi2bsssj9g1rrcg4vfhvw0bjxsbmif4km0ngbk"))))
+ "1bs310dw9jjzvvchszmb3jakqb5268ssp83ba9ybrrcw8h05jycw"))))
(build-system meson-build-system)
(propagated-inputs
;; The following are in the Requires.private field of gl.pc.
@@ -545,6 +545,9 @@ (define-public mesa
(from-crates-io 'rust-proc-macro2-1)
(from-crates-io 'rust-paste-1))))))))
#~())
+ (add-after 'unpack 'set-home-directory
+ ;; Build tries to use a shader cache (non-fatal error).
+ (lambda _ (setenv "HOME" "/tmp")))
(add-before 'configure 'fix-dlopen-libnames
(lambda* (#:key inputs #:allow-other-keys)
(let ((out #$output))
--
2.46.0
John Kehayias wrote 2 months ago
Re: [bug#74779] [PATCH mesa-updates 0/3] libdrm/wayland-protocols/mesa updates
(address . 74779-done@debbugs.gnu.org)
87bjwc2fjb.fsf@protonmail.com
On Wed, Dec 11, 2024 at 06:25 AM, John Kehayias wrote:

Toggle quote (23 lines)
> Hi Guix,
>
> Here are 3 simple patches currently on mesa-updates, which looks to have built
> fine. The wayland-protocols update includes a change from
> <https://issues.guix.gnu.org/73053> as well.
>
> Thanks!
>
> John Kehayias (3):
> gnu: libdrm: Update to 2.4.124.
> gnu: wayland-protocols: Update to 1.38.
> gnu: mesa: Update to 24.3.1.
>
> gnu/packages/freedesktop.scm | 16 +++++++---------
> gnu/packages/gl.scm | 7 +++++--
> gnu/packages/xdisorg.scm | 6 +++---
> 3 files changed, 15 insertions(+), 14 deletions(-)
>
>
> base-commit: 0c5d7b8480234f739448956f508307e64e8e45fa
> --
> 2.46.0

Closing, this was done on the mesa-updates branch and merged starting at 23231c296fb2c2af8c1c0a6ead1dd6f0833f7c45
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 74779@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74779
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help