* gnu/packages/freedesktop.scm (wayland-protocols): Update to 1.38.
[source]: Switch to git-fetch.
[properties]: Remove release-monitoring-url.
Co-authored-by: Zheng Junjie <zhengjunjie@iscas.ac.cn>
Change-Id: Iaa4209eab3a467159a58d2fbedb564b1b0e5ca16
---
gnu/packages/freedesktop.scm | 16 +++++++---------
1 file changed, 7 insertions(+), 9 deletions(-)
Toggle diff (37 lines)
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index af35625c18..48d40c20a2 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -1393,15 +1393,16 @@ (define-public wayland
(define-public wayland-protocols
(package
(name "wayland-protocols")
- (version "1.37")
+ (version "1.38")
(source (origin
- (method url-fetch)
- (uri (string-append "https://gitlab.freedesktop.org/wayland/"
- name "/-/releases/" version "/downloads/"
- name "-" version ".tar.xz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.freedesktop.org/wayland/wayland-protocols")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "09pk3qhpc29x1a6srpqqw9dcvalg33vfmp14d276is7j4klrn3m7"))))
+ "1aik5zmpjwhxsfv9aa88sg95s0mg6yvy2cbqbd1xhigfbnq271zb"))))
(build-system meson-build-system)
(inputs
(list wayland))
@@ -1416,9 +1417,6 @@ (define-public wayland-protocols
add completely new functionality, or extend the functionality of some other
protocol either in Wayland core, or some other protocol in wayland-protocols.")
(home-page "https://wayland.freedesktop.org")
- (properties
- '((release-monitoring-url
- . "https://wayland.freedesktop.org/releases.html")))
(license license:expat)))
(define-public wayland-protocols-next