[PATCH] gnu: linux-libre: Enable simpledrm driver.

  • Open
  • quality assurance status badge
Details
One participant
  • Homo
Owner
unassigned
Submitted by
Homo
Severity
normal
H
(address . guix-patches@gnu.org)(name . Homo)(address . gay@disroot.org)
20241211054916.1598-1-gay@disroot.org
Without it GDM and Wayland don't work on unsupported GPUs.

Change-Id: Id3bf1e890fee527ef8a24243a2f642271877b5c2
---
gnu/packages/linux.scm | 6 ++++++
1 file changed, 6 insertions(+)

Toggle diff (19 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 62d6f0adb9..7d374456bd 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -894,6 +894,12 @@ (define (default-extra-linux-options version)
("CONFIG_MEMCG_KMEM" . #t)
("CONFIG_CPUSETS" . #t)
("CONFIG_PROC_PID_CPUSET" . #t)
+ ;; Allow GDM and Wayland on unsupported GPUs.
+ ("CONFIG_DRM" . #t)
+ ("CONFIG_DRM_SIMPLEDRM" . #t)
+ ("CONFIG_SYSFB_SIMPLEFB" . #t)
+ ("CONFIG_FB_EFI" . #f)
+ ("CONFIG_FB_SIMPLE" . #f)
;; Allow disk encryption by default
("CONFIG_DM_CRYPT" . m)
;; Support zram on all kernel configs
--
2.46.0
H
[PATCH v2] gnu: linux-libre: Enable simpledrm driver.
(address . 74778@debbugs.gnu.org)(name . Homo)(address . gay@disroot.org)
20241216090458.18953-1-gay@disroot.org
Without it GDM and Wayland don't work on unsupported GPUs.


* gnu/packages/linux.scm (default-extra-linux-options): Enable
CONFIG_DRM, CONFIG_DRM_SIMPLEDRM and CONFIG_SYSFS_SIMPLEFB.
Disable CONFIG_FB_EFI and CONFIG_FB_SIMPLE.

Change-Id: Id4e8d595d56416581e1be5093a224a19cc2d3dfb
---
Changed commit log.

gnu/packages/linux.scm | 6 ++++++
1 file changed, 6 insertions(+)

Toggle diff (19 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 0fc2c4428a..67bcc5e6db 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -894,6 +894,12 @@ (define (default-extra-linux-options version)
("CONFIG_MEMCG_KMEM" . #t)
("CONFIG_CPUSETS" . #t)
("CONFIG_PROC_PID_CPUSET" . #t)
+ ;; Allow GDM and Wayland on unsupported GPUs.
+ ("CONFIG_DRM" . #t)
+ ("CONFIG_DRM_SIMPLEDRM" . #t)
+ ("CONFIG_SYSFB_SIMPLEFB" . #t)
+ ("CONFIG_FB_EFI" . #f)
+ ("CONFIG_FB_SIMPLE" . #f)
;; Allow disk encryption by default
("CONFIG_DM_CRYPT" . m)
;; Support zram on all kernel configs
--
2.46.0
H
[PATCH v3] gnu: linux-libre: Enable simpledrm driver.
(address . 74778@debbugs.gnu.org)(name . Homo)(address . gay@disroot.org)
20241217121550.2778-1-gay@disroot.org
Without it GDM and Wayland don't work on unsupported GPUs.


* gnu/packages/linux.scm (default-extra-linux-options): Enable
CONFIG_DRM, CONFIG_DRM_SIMPLEDRM and CONFIG_SYSFB_SIMPLEFB.
Disable CONFIG_FB_EFI and CONFIG_FB_SIMPLE.

Change-Id: I4e4adca508875e25faa09ef51d6cb325e27ce328
---
Corrected typo mistake in log message
s/CONFIG_SYSFS_SIMPLEFB/CONFIG_SYSFB_SIMPLEFB/

gnu/packages/linux.scm | 6 ++++++
1 file changed, 6 insertions(+)

Toggle diff (19 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 0fc2c4428a..67bcc5e6db 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -894,6 +894,12 @@ (define (default-extra-linux-options version)
("CONFIG_MEMCG_KMEM" . #t)
("CONFIG_CPUSETS" . #t)
("CONFIG_PROC_PID_CPUSET" . #t)
+ ;; Allow GDM and Wayland on unsupported GPUs.
+ ("CONFIG_DRM" . #t)
+ ("CONFIG_DRM_SIMPLEDRM" . #t)
+ ("CONFIG_SYSFB_SIMPLEFB" . #t)
+ ("CONFIG_FB_EFI" . #f)
+ ("CONFIG_FB_SIMPLE" . #f)
;; Allow disk encryption by default
("CONFIG_DM_CRYPT" . m)
;; Support zram on all kernel configs
--
2.46.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 74778@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74778
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch