(address . guix-patches@gnu.org)(name . Homo)(address . gay@disroot.org)
Without it GDM and Wayland don't work on unsupported GPUs.
Change-Id: Id3bf1e890fee527ef8a24243a2f642271877b5c2
---
gnu/packages/linux.scm | 6 ++++++
1 file changed, 6 insertions(+)
Toggle diff (19 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 62d6f0adb9..7d374456bd 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -894,6 +894,12 @@ (define (default-extra-linux-options version)
("CONFIG_MEMCG_KMEM" . #t)
("CONFIG_CPUSETS" . #t)
("CONFIG_PROC_PID_CPUSET" . #t)
+ ;; Allow GDM and Wayland on unsupported GPUs.
+ ("CONFIG_DRM" . #t)
+ ("CONFIG_DRM_SIMPLEDRM" . #t)
+ ("CONFIG_SYSFB_SIMPLEFB" . #t)
+ ("CONFIG_FB_EFI" . #f)
+ ("CONFIG_FB_SIMPLE" . #f)
;; Allow disk encryption by default
("CONFIG_DM_CRYPT" . m)
;; Support zram on all kernel configs
--
2.46.0