[PATCH] gnu: Add python-hdlmake.

  • Open
  • quality assurance status badge
Details
One participant
  • Cayetano Santos
Owner
unassigned
Submitted by
Cayetano Santos
Severity
normal
C
C
Cayetano Santos wrote on 10 Dec 11:41 +0100
(address . guix-patches@gnu.org)(name . Cayetano Santos)(address . csantosb@inventati.org)
0b1319ee05bc8e954cdefc620a88f2e879e58310.1733827268.git.csantosb@inventati.org
* gnu/packages/fpga.scm (python-hdlmake): New variable.

Change-Id: I4f19d2cceb7fe46bbc359f9bc5197ae3113bb3d7
---
gnu/packages/fpga.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/fpga.scm b/gnu/packages/fpga.scm
index e69169b980..234f19003f 100644
--- a/gnu/packages/fpga.scm
+++ b/gnu/packages/fpga.scm
@@ -635,3 +635,28 @@ (define-public openfpgaloader
to an FPGA.")
(home-page "https://trabucayre.github.io/openFPGALoader")
(license license:asl2.0)))
+
+(define-public python-hdlmake
+ (let ((commit "3cb248fdad601c579b59fd7c194402871209bc54")
+ (revision "0"))
+ (package
+ (name "python-hdlmake")
+ (version (git-version "3.3" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://ohwr.org/project/hdl-make")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "08ivnhxyp44agmifqb4pjbxj23p43qqcg73s2y2z1hqk2six3fdx"))))
+ (build-system pyproject-build-system)
+ (arguments
+ `(#:tests? #f))
+ (propagated-inputs (list python-six))
+ (home-page "https://ohwr.org/projects/hdl-make")
+ (synopsis "Generate multi-purpose makefiles for HDL projects")
+ (description
+ "Hdlmake helps to manage and share HDL code by automatically finding file dependencies, writing synthesis and simulation Makefiles.")
+ (license license:gpl3+))))

base-commit: 93e1586116f39a30ba1fcb67bd839a43533dfaf4
--
2.46.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 74763@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74763
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch