[PATCH] gnu: hyprlang: Fix cross-compilation.

  • Done
  • quality assurance status badge
Details
2 participants
  • Hilton Chain
  • Ludovic Courtès
Owner
unassigned
Submitted by
Hilton Chain
Severity
normal
H
H
Hilton Chain wrote on 9 Dec 17:56 +0100
(address . guix-patches@gnu.org)(name . Hilton Chain)(address . hako@ultrarare.space)
eee948621e12ca445d5a682efb6d9e53cdc144e4.1733763335.git.hako@ultrarare.space
* gnu/packages/cpp.scm (hyprlang)[arguments]<#:phases>: Set
PKG_CONFIG_EXECUTABLE in CMakeLists.txt.

Change-Id: Ied775ece2de83f6842bf405be76ce7f33fdce5fe
---
gnu/packages/cpp.scm | 11 +++++++++++
1 file changed, 11 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index a72f491fd0..4fd5f8fa00 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -678,6 +678,17 @@ (define-public hyprlang
(base32
"0yvfrz3hdyxzhngzhr0bgc5279ra5fv01hbfi6pdj84pz0lpaw02"))))
(build-system cmake-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-cross-compilation
+ (lambda _
+ (substitute* "CMakeLists.txt"
+ (("find_package.PkgConfig" all)
+ (string-append
+ "set(PKG_CONFIG_EXECUTABLE " #$(pkg-config-for-target) ")\n"
+ all))))))))
(native-inputs (list gcc-13 pkg-config))
(inputs (list hyprutils))
(home-page "https://wiki.hyprland.org/Hypr-Ecosystem/hyprlang/")

base-commit: 9d09b0cf841fb657a1aec12e9bab68e00c2b493c
prerequisite-patch-id: f132b4af7b85df465998e4f459bf729f8b66f320
prerequisite-patch-id: 71423f8b55ad6f04c3f3d647cbd9d42c6c332e06
prerequisite-patch-id: 1076bb75432f82f35d834ca4f97dffebd0ce98d5
prerequisite-patch-id: ecd87e69b7aebebd64256db106ed96dc12f6c12d
prerequisite-patch-id: e0e81738807e886ac5109a7d26f841204a35d8a7
prerequisite-patch-id: f27c33b6c7f5dcb37c36551ecde29f1f0c734935
prerequisite-patch-id: fc6ad5af54f75869a657c065c86b262d74a1efff
prerequisite-patch-id: 1665e62d1990a460bc5679bc89d600e94bab407a
--
2.46.0
L
L
Ludovic Courtès wrote on 12 Dec 12:49 +0100
(name . Hilton Chain)(address . hako@ultrarare.space)(address . 74753-done@debbugs.gnu.org)
87ldwl9l3t.fsf@gnu.org
Hilton Chain <hako@ultrarare.space> skribis:

Toggle quote (5 lines)
> * gnu/packages/cpp.scm (hyprlang)[arguments]<#:phases>: Set
> PKG_CONFIG_EXECUTABLE in CMakeLists.txt.
>
> Change-Id: Ied775ece2de83f6842bf405be76ce7f33fdce5fe

Applied, thanks!
Closed
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 74753@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74753
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch