Updating Docker to v27

  • Open
  • quality assurance status badge
Details
3 participants
  • Janneke Nieuwenhuizen
  • Josep Bigorra
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Josep Bigorra
Severity
normal
J
J
Josep Bigorra wrote on 9 Dec 15:55 +0100
(address . guix-patches@gnu.org)
CAM_04A02R+awxv1-4J1gkvpLybc6cCUMgf4yF7GxfGJeqzSaWQ@mail.gmail.com
Hi all, I am struggling to get new Docker versions working on Guix.
For the this is critical for day to day work and I start to have some
problems due to running on old version.
I attempted some changes to the Guix package for docker but no
success. See the patch attached and the error message.

Thanks
Joe
From 9ac032ab3228f461467b63a164b76b3545b1bcf2 Mon Sep 17 00:00:00 2001
Message-ID: <9ac032ab3228f461467b63a164b76b3545b1bcf2.1733755906.git.jjbigorra@gmail.com>
From: Josep Bigorra <jjbigorra@gmail.com>
Date: Mon, 9 Dec 2024 15:50:43 +0100
Subject: [PATCH] attempt to update docker to v27

---
gnu/packages/docker.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/docker.scm b/gnu/packages/docker.scm
index b49dc58bd0..0798fd7285 100644
--- a/gnu/packages/docker.scm
+++ b/gnu/packages/docker.scm
@@ -55,7 +55,7 @@ (define-module (gnu packages docker)
;; Note - when changing Docker versions it is important to update the versions
;; of several associated packages (docker-libnetwork and go-sctp).
-(define %docker-version "20.10.27")
+(define %docker-version "27.3.1")
(define-public python-docker
(package
@@ -350,7 +350,7 @@ (define-public docker
#~(modify-phases %standard-phases
(add-after 'unpack 'patch-paths
(lambda* (#:key inputs #:allow-other-keys)
- (substitute* "builder/builder-next/executor_unix.go"
+ (substitute* "builder/builder-next/executor_linux.go"
(("CommandCandidates:.*runc.*")
(string-append "CommandCandidates: []string{\""
(search-input-file inputs "/sbin/runc")
--
2.46.0
J
J
Janneke Nieuwenhuizen wrote on 9 Dec 16:21 +0100
(name . Josep Bigorra)(address . jjbigorra@gmail.com)(address . 74746@debbugs.gnu.org)
87zfl451bz.fsf@gnu.org
Josep Bigorra writes:

Toggle quote (27 lines)
> Hi all, I am struggling to get new Docker versions working on Guix.
> For the this is critical for day to day work and I start to have some
> problems due to running on old version.
> I attempted some changes to the Guix package for docker but no
> success. See the patch attached and the error message.

> starting phase `separate-from-pid1'

> Backtrace:
> 10 (primitive-load "/gnu/store/xgwamcagyz6lkf4hrwncdrxyc63…")
> In guix/build/gnu-build-system.scm:
> 966:2 9 (gnu-build #:source _ #:outputs _ #:inputs _ #:phases . #)
> In ice-9/boot-9.scm:
> 1752:10 8 (with-exception-handler _ _ #:unwind? _ # _)
> In srfi/srfi-1.scm:
> 634:9 7 (for-each #<procedure fffff413cd80 at guix/build/gnu-b…> …)
> In ice-9/boot-9.scm:
> 1752:10 6 (with-exception-handler _ _ #:unwind? _ # _)
> In guix/build/gnu-build-system.scm:
> 987:23 5 (_)
> In ice-9/eval.scm:
> 619:8 4 (_ #(#(#<directory (guile-user) fffff778ec80>) (# # …)))
> In guix/build/utils.scm:
> 903:19 3 (with-atomic-file-replacement "vendor/github.com/conta…" …)
> In unknown file:
> 2 (mkstemp! "vendor/github.com/containerd/containerd/run…" …)

So this file "vendor/github.com/containerd/containerd/run…" does not
exist, which is visible from the unpack log. You can just comment-out
that substitute line, or better yet, find out the new name of that
source file like you did with execution_unix.go-> execution_linux.go

It may be worth your while to check all the substitute* file names in
the "patch-paths" phase beforehand.

Greetings,
Janneke

--
Janneke Nieuwenhuizen <janneke@gnu.org> | GNU LilyPond https://LilyPond.org
Freelance IT https://www.JoyOfSource.com| Avatar® https://AvatarAcademy.com
J
J
Josep Bigorra wrote on 9 Dec 16:12 +0100
(address . 74746@debbugs.gnu.org)
CAM_04A1XLmZwzhH47wHvNrB_WSmRvAW+2Rxwngmxai=ojoy7Pg@mail.gmail.com
Thank you Janneke for the quick reply, I will continue pursuing a fix.
It seems like it will take me a while and I will need to be really at
my best, to understand the errors,
greetings
J
J
Josep Bigorra wrote on 9 Dec 16:51 +0100
(address . 74746@debbugs.gnu.org)
CAM_04A2ELdvKSYt8sWHZf8y5HSaF2p=mpo8AKsQ0cKMX4VYh3g@mail.gmail.com
I am afraid I am at my knowledge's end. I think also the initial patch
i submitted is not helping at all.
I face countless problems at build time, and even the application of a
patch (containerd-create-pid-file.patch) is failing at guix build time
(while locally and manually it works fine).
I am officially calling it a day on this one, I am unfamiliar with
advanced Guix builds, and even more unfamiliar with how Docker
internally should build.
I would really appreciate some help from more experienced people here,
J
S
S
Sharlatan Hellseher wrote on 11 Dec 19:52 +0100
Updating Docker to v27
(address . 74746@debbugs.gnu.org)
CAO+9K5pBABx6t=Cjdcedy-Nos6Qu4P-LnacE=qHLBoKnRxjHBg@mail.gmail.com
Hi,

Containerd package packed with all vendor preserved.
As the amount of missing packages are huge (the same case as
Kubo ipfs).

I'll take a look for solution as I'm in golang mod this week :-).

Thanks,
Oleg
Attachment: file
S
S
Sharlatan Hellseher wrote on 11 Dec 22:24 +0100
(address . 74746@debbugs.gnu.org)
87ikrp7w1n.fsf@gmail.com
Hi,

The initial attempt to update Docker has been failed.

I've madden a try to import containerd completely.

guix go import --recursive github.com/containerd/containerd/v2

Produced 353 new packages which are overlap with missing in kubo,
matterbridge, prometheus, restic, afero and some other.
It would be nice unbundle each of them properly.

Scheduled for go-team, any help in packaging are welcome.

--
Thanks,
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmdaAwQACgkQdtcnv/Ys
0rUFcA//UN0ZdMuNzRzH/j+WzOlnVvGa2P4Ki4QDbpGuMFYZ8zN8kErP7A2WCnx5
iZpF/JhQaUq5UBZ4sQhYK5aaCaYRqJzYluR0ucFAn1g4x1VLVgckgyUUMWO1sTCl
GIyPUabZBK/A5PMEmBX6VtK3ufRJwj09HKc+AGCF3QB4X5JfDktWlLOJiw5KandK
g1GY0Lneo3FFXeaLYAhbrnsyivtfUNlNYRqyxgyPJw/SyFsDq+UkYqorQMhrSH/S
f/wLS4knDyUVriNtlnJFhEn9Rls6KJsnG5rfw5AGySV/sDoi42MhTE2vbQ8q24Sv
AjsoSdt4MCgufWEHN9mrOmYDj+SMFbkmi2adCBAg+hGuVcpvVARDEuKlrXRSg9xi
vTl3cPpK2sf3Q8YakI4/NPotWL8lB137MSsikUfOtDXpKbQt7yfAJP4WGue8clS8
1atfb7tqQnXeNPxwJVBk6URw0VH4fnQHmCU1fVFOlU4PGu3SiyaQHJtAF0y8bGRH
GiSAwkr8hfHcPzgxrlzztGax4S+oy5drV4RjtmX+df6NlQslRwK3ykTnubihm5MJ
XFCWDAaqt7RgM/GHcBoDqZffeLES/FC7p0GJo9lWPH74JW3qg4eYJcsiobEGZx8g
Mo0/YMFIpOZjzyRAe46vC8vRVId+QK2T8cF8E1Ps2MXmubsHHq4=
=Bbc3
-----END PGP SIGNATURE-----

?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 74746@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74746
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch