[PATCH] gnu: add wideriver.

  • Done
  • quality assurance status badge
Details
2 participants
  • Hikari
  • Zheng Junjie
Owner
unassigned
Submitted by
Hikari
Severity
normal
H
H
Hikari wrote on 6 Dec 2024 10:38
(address . guix-patches@gnu.org)(name . Hikari)(address . Quelln@protonmail.com)
df2c3424590a24f964194df0f958a0b9855a2fb8.1733477885.git.Quelln@protonmail.com
Change-Id: Iab2a6bd8bd02098105848d240af0271df44b58bf
---
gnu/packages/wm.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 2ab6f88cd5..d1df1e85c0 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -3999,3 +3999,35 @@ (define-public scenefx
"A drop-in replacement for the wlroots scene API that allows wayland
compositors to render surfaces with eye-candy effects.")
(license license:expat)))
+
+(define-public wideriver
+ (package
+ (name "wideriver")
+ (version "1.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/alex-courtis/wideriver")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "16i0mzgxn32nrh5ajn0kb4xdwmsjg03amhasxhwyvspar5y4flhg"))))
+ (build-system gnu-build-system)
+
+ (arguments
+ (list
+ #:tests? #f
+ #:make-flags #~(list (string-append "PREFIX="
+ #$output)
+ (string-append "CC="
+ #$(cc-for-target)))
+ #:phases #~(modify-phases %standard-phases
+ (delete 'configure))))
+ (native-inputs (list pkg-config))
+ (inputs (list wayland wayland-protocols wlroots))
+ (home-page "https://github.com/alex-courtis/wideriver")
+ (synopsis "A set of riverWM layouts")
+ (description
+ "Tiling window manager for the river wayland compositor, inspired by dwm and xmonad.")
+ (license license:gpl3)))

base-commit: d75d1fe6ac7ded7e61322d18b07d347beb609aa0
--
2.46.0
H
H
Hikari wrote on 7 Dec 2024 11:22
[PATCH v2] gnu: add wideriver.
(address . 74708@debbugs.gnu.org)(name . Hikari)(address . Quelln@protonmail.com)
578054a6d6fc12e64f1329e720e38d3daf700892.1733566922.git.Quelln@protonmail.com
Change-Id: Iab2a6bd8bd02098105848d240af0271df44b58bf
---
gnu/packages/wm.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (46 lines)
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 2ab6f88cd5..4e90a94792 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -3949,6 +3949,37 @@ (define-public yambar-wayland
battery efficient---polling is only done when absolutely necessary.")
(license license:expat)))
+(define-public wideriver
+ (package
+ (name "wideriver")
+ (version "1.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/alex-courtis/wideriver")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "16i0mzgxn32nrh5ajn0kb4xdwmsjg03amhasxhwyvspar5y4flhg"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:tests? #f
+ #:make-flags #~(list (string-append "PREFIX="
+ #$output)
+ (string-append "CC="
+ #$(cc-for-target)))
+ #:phases #~(modify-phases %standard-phases
+ (delete 'configure))))
+ (native-inputs (list pkg-config))
+ (inputs (list wayland wayland-protocols wlroots))
+ (home-page "https://github.com/alex-courtis/wideriver")
+ (synopsis "A set of riverWM layouts")
+ (description
+ "Tiling window manager for the river wayland compositor, inspired by dwm and xmonad.")
+ (license license:gpl3)))
+
(define-public wf-config
(package
(name "wf-config")

base-commit: d75d1fe6ac7ded7e61322d18b07d347beb609aa0
--
2.46.0
Z
Z
Zheng Junjie wrote 29 hours ago
(name . Hikari via Guix-patches via)(address . guix-patches@gnu.org)
87a5bczbox.fsf@iscas.ac.cn
Hikari via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (31 lines)
> Change-Id: Iab2a6bd8bd02098105848d240af0271df44b58bf
> ---
> gnu/packages/wm.scm | 31 +++++++++++++++++++++++++++++++
> 1 file changed, 31 insertions(+)
>
> diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
> index 2ab6f88cd5..4e90a94792 100644
> --- a/gnu/packages/wm.scm
> +++ b/gnu/packages/wm.scm
> @@ -3949,6 +3949,37 @@ (define-public yambar-wayland
> battery efficient---polling is only done when absolutely necessary.")
> (license license:expat)))
>
> +(define-public wideriver
> + (package
> + (name "wideriver")
> + (version "1.2.0")
> + (source
> + (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/alex-courtis/wideriver")
> + (commit version)))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32 "16i0mzgxn32nrh5ajn0kb4xdwmsjg03amhasxhwyvspar5y4flhg"))))
> + (build-system gnu-build-system)
> + (arguments
> + (list
> + #:tests? #f

use #:test-target "test" to enable tests.

Toggle quote (7 lines)
> + #:make-flags #~(list (string-append "PREFIX="
> + #$output)
> + (string-append "CC="
> + #$(cc-for-target)))
> + #:phases #~(modify-phases %standard-phases
> + (delete 'configure))))

add ; no configure script

Toggle quote (2 lines)
> + (native-inputs (list pkg-config))

add cmocka

Toggle quote (6 lines)
> + (inputs (list wayland wayland-protocols wlroots))
> + (home-page "https://github.com/alex-courtis/wideriver")
> + (synopsis "A set of riverWM layouts")
> + (description
> + "Tiling window manager for the river wayland compositor, inspired by dwm and xmonad.")

Wrap lines to avoid being too long

Toggle quote (7 lines)
> + (license license:gpl3)))
> +
> (define-public wf-config
> (package
> (name "wf-config")
>
> base-commit: d75d1fe6ac7ded7e61322d18b07d347beb609aa0
and pushed, closing.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEfr6klGDOXiwIdX/bO1qpk+Gi3/AFAmeXew4ACgkQO1qpk+Gi
3/DCdw//UriP6k8Txi+uUy9T/lypvV/1xtZa06uQjx1uUY1guiVOvenjFW5b5jef
c+QVqDFk8yCTZevRFdJSnTM/+Fv2ALglM2z9m72PlPzrA0UriZpKXIkLElsVpW13
iq38oyXlri2NwE+CYG0p0t9UImcQ5OTmvKd0XdJjy9u7rXqSToCI/sbTmdLQ8fuE
zcMnGlG3E99jIhpU9FKBs0d6YGvd603u4p3Ry5OJ1exEY19VvZBTtRWRpkh8OxIx
3hPdEm+Q2QQ8yJM+mjnQkHFw8SjPcpNunUN9LA4Xn0V9uMBvNDPHSoc2YllDOARz
1uYAoHPqLq2MB+At4o21NaBUkrwLYr+V5A5LPGAnB/gNZ5sayVjgUMrAcO6MzkhC
2d4jqB/JgdGNRMbAEXq91tWeOUyZSP0+4VkH1Wwz7LrilWqMePdaqZa75ZMH8TYQ
9mO0hHQgATua0mpxy1i1lUlupbPozh8ODPDH3dfGUF/G325WirVayLDtCxs6jiTJ
/YAOfCMOMQv1nRn0Rff1aXXwo7f3Wx90SLQgxzF03JQvS2LVRJ7qoTob8PjKs0wD
ltMzCNC79ShvDLE/rdmdggExXNW5DvsFeHs2HYlpkciBJE0aUL8FsyVqYKgByfaE
TaIgIaAj2+7vCmHrFb1FxVf0GSs/iHEBYBFEhWDeqIjL2rylKdU=
=7LXJ
-----END PGP SIGNATURE-----

?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 74708@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74708
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch