[PATCH] gnu: squashfuse: Fix cross compiling.

  • Open
  • quality assurance status badge
Details
One participant
  • Brian Kubisiak
Owner
unassigned
Submitted by
Brian Kubisiak
Severity
normal
B
B
Brian Kubisiak wrote 23 hours ago
(address . guix-patches@gnu.org)
50ad8da346a0a35d4873de7c9ccd10a793c02bf7.1733282255.git.brian@kubisiak.com
* gnu/packages/file-systems.scm (squashfuse)[arguments]: Use
pkg-config-for-target.
(squashfuse-for-appimage)[arguments]: Use substitute-keyword-arguments
to modify inherited phases instead of %standard-phases.

Change-Id: I6e52a94e46c5a89ba215a7eaceb7f54a80c52429
---
gnu/packages/file-systems.scm | 26 ++++++++++++++++++--------
1 file changed, 18 insertions(+), 8 deletions(-)

Toggle diff (53 lines)
diff --git a/gnu/packages/file-systems.scm b/gnu/packages/file-systems.scm
index 46febebb0d..0d61277f98 100644
--- a/gnu/packages/file-systems.scm
+++ b/gnu/packages/file-systems.scm
@@ -2049,6 +2049,15 @@ (define-public squashfuse
(sha256
(base32 "03aw8pw8694jyrzpnbry05rk9718sqw66kiyq878bbb679gl7224"))))
(build-system gnu-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-cross-compile
+ (lambda _
+ (substitute* "autogen.sh"
+ (("pkg-config")
+ #$(pkg-config-for-target))))))))
(native-inputs (list autoconf automake libtool pkg-config))
(inputs (list attr fuse-2 xz zlib `(,zstd "lib")))
(home-page "https://github.com/vasi/squashfuse")
@@ -2063,17 +2072,18 @@ (define-public squashfuse-for-appimage
(package
(inherit squashfuse)
(arguments
- (list
+ (cons*
#:configure-flags
#~'("CFLAGS=-ffunction-sections -fdata-sections -Os -no-pie"
"LDFLAGS=-static")
- #:phases
- #~(modify-phases %standard-phases
- (add-after 'install 'install-private-headers
- (lambda _
- (install-file "fuseprivate.h"
- (string-append #$output
- "/include/squashfuse/")))))))
+ (substitute-keyword-arguments (package-arguments squashfuse)
+ ((#:phases phases)
+ #~(modify-phases #$phases
+ (add-after 'install 'install-private-headers
+ (lambda _
+ (install-file "fuseprivate.h"
+ (string-append #$output
+ "/include/squashfuse/")))))))))
(inputs (list fuse-for-appimage
`(,zstd "lib")
`(,zstd "static")

base-commit: 9001514e242ad15c190588439930b0fa4f6782e3
prerequisite-patch-id: cd0707c90e1d321f3f16f2f861313dd330e9f0b4
prerequisite-patch-id: d2efb4b89763c5df04dd6d980afd8756401ba24f
--
2.46.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 74682@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74682
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch