[PATCH] gnu: Add ustreamer.

  • Open
  • quality assurance status badge
Details
One participant
  • Vincent Legoll
Owner
unassigned
Submitted by
Vincent Legoll
Severity
normal

Debbugs page

Vincent Legoll wrote 3 months ago
(address . guix-patches@gnu.org)(name . Vincent Legoll)(address . vincent.legoll@gmail.com)
20241201162733.14580-1-vincent.legoll@gmail.com
* gnu/packages/video.scm (ustreamer): New variable.

Change-Id: I55436ab9f6877b88e4e463fbb20fbaed5f49678d
---

I have actually (lightly) tested this is working properly, on a
debian laptop with an integrated webcam, via a guix pack.

gnu/packages/video.scm | 40 +++++++++++++++++++++++++++++++++++++++-
1 file changed, 39 insertions(+), 1 deletion(-)

Toggle diff (68 lines)
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 03d44dc9a2..a3d5ee0b78 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -37,7 +37,7 @@
;;; Copyright © 2020, 2021, 2023, 2024 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2020 Josh Holland <josh@inv.alid.pw>
;;; Copyright © 2020, 2021 Brice Waegeneire <brice@waegenei.re>
-;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
+;;; Copyright © 2020, 2024 Vincent Legoll <vincent.legoll@gmail.com>
;;; Copyright © 2020, 2021 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2020 Alex McGrath <amk@amk.ie>
;;; Copyright © 2020, 2021, 2022 Michael Rohleder <mike@rohleder.de>
@@ -161,7 +161,9 @@ (define-module (gnu packages video)
#:use-module (gnu packages image)
#:use-module (gnu packages imagemagick)
#:use-module (gnu packages iso-codes)
+ #:use-module (gnu packages libbsd)
#:use-module (gnu packages libcanberra)
+ #:use-module (gnu packages libevent)
#:use-module (gnu packages libidn)
#:use-module (gnu packages libusb)
#:use-module (gnu packages linux)
@@ -563,6 +565,42 @@ (define-public libquicktime
(home-page "https://libquicktime.sourceforge.net/")
(license license:lgpl2.1+)))
+(define-public ustreamer
+ (package
+ (name "ustreamer")
+ (version "6.18")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pikvm/ustreamer")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0h8i5p045q3shjgpcrpi6yhlrd6lws68swf521qd5nvv7ja8qd7f"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no test suite
+ #:make-flags (list (string-append "CC=" ,(cc-for-target))
+ (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'do-not-check-for-pkg-config
+ (lambda _
+ (substitute* "Makefile" ; crude way to disable annoying check
+ (("error \"No pkg-config found in")
+ "true \""))))
+ (delete 'configure))))
+ (inputs (list libbsd libevent libjpeg-turbo))
+ (synopsis "Lightweight and fast MJPEG-HTTP streamer")
+ (description "Lightweight and very quick server to stream MJPEG video
+from any V4L2 device to the net. All new browsers have native support of
+this video format, as well as most video players such as mplayer, VLC etc.
+µStreamer is a part of the PiKVM project designed to stream VGA and
+HDMI screencast hardware data with the highest resolution and FPS possible.")
+ (home-page "https://pikvm.org")
+ (license license:gpl3)))
+
(define-public mjpg-streamer
(package
(name "mjpg-streamer")
--
2.47.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 74635@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74635
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help