[PATCH] gnu: ugrep: Update to 7.1.1.

  • Open
  • quality assurance status badge
Details
One participant
  • Ashish SHUKLA
Owner
unassigned
Submitted by
Ashish SHUKLA
Severity
normal
A
A
Ashish SHUKLA wrote on 30 Nov 00:13 +0100
(address . guix-patches@gnu.org)(name . Ashish SHUKLA)(address . ashish.is@lostca.se)
01914ee4fb95ab9df4b9f13c207c72b0f160e3b5.1732922038.git.ashish.is@lostca.se
* gnu/packages/search.scm (ugrep): Update to 7.1.1.

Change-Id: I3d380342eaaeef998bd6279f392fca27f22ef1c6
---
gnu/packages/search.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (25 lines)
diff --git a/gnu/packages/search.scm b/gnu/packages/search.scm
index bd24d98639..f6246b92d4 100644
--- a/gnu/packages/search.scm
+++ b/gnu/packages/search.scm
@@ -739,14 +739,14 @@ (define-public xapers
(define-public ugrep
(package
(name "ugrep")
- (version "7.1.0")
+ (version "7.1.1")
(source (origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/Genivia/ugrep")
(commit (string-append "v" version))))
(sha256
- (base32 "0py6yyjdabgxdlidiq30432b4drd2821d3k68zq373v0jwz3crqz"))
+ (base32 "0x162hf65fwx21ld3ac73sblj1vxvmaqicz3220bw8wb8fvhgw4p"))
(file-name (git-file-name name version))
(modules '((guix build utils)))
(snippet

base-commit: f129a6cc591817c5c51770d5b8712eeb344ba4e4
--
2.47.1
A
A
Ashish SHUKLA wrote on 30 Nov 13:33 +0100
[PATCH v2] gnu: ugrep: Update to 7.1.1.
(address . 74611@debbugs.gnu.org)(name . Ashish SHUKLA)(address . ashish.is@lostca.se)
e7431510fd1f0624aef8e57bfc2fac2031715037.1732969984.git.ashish.is@lostca.se
* gnu/packages/search.scm (ugrep): Update to 7.1.1.
[arguments]<phases>: Add fix-ug+ phase to wrap ugrep+,
and ug+ binaries.

Change-Id: I5292ace64c4d8457748018d852145324b981e9b0
---
Hi,

This revision also wraps the programs ug+, and ugrep+ which expect ugrep in the PATH.

Thanks!

gnu/packages/search.scm | 11 +++++++++--
1 file changed, 9 insertions(+), 2 deletions(-)

Toggle diff (39 lines)
diff --git a/gnu/packages/search.scm b/gnu/packages/search.scm
index bd24d98639..e1f498446a 100644
--- a/gnu/packages/search.scm
+++ b/gnu/packages/search.scm
@@ -739,14 +739,14 @@ (define-public xapers
(define-public ugrep
(package
(name "ugrep")
- (version "7.1.0")
+ (version "7.1.1")
(source (origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/Genivia/ugrep")
(commit (string-append "v" version))))
(sha256
- (base32 "0py6yyjdabgxdlidiq30432b4drd2821d3k68zq373v0jwz3crqz"))
+ (base32 "0x162hf65fwx21ld3ac73sblj1vxvmaqicz3220bw8wb8fvhgw4p"))
(file-name (git-file-name name version))
(modules '((guix build utils)))
(snippet
@@ -773,6 +773,13 @@ (define-public ugrep
#:test-target "test"
#:phases
#~(modify-phases %standard-phases
+ (add-after 'install 'fixup-ug+
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((bin (string-append (assoc-ref outputs "out") "/bin")))
+ (for-each (lambda (f)
+ (wrap-program (string-append bin "/" f)
+ `("PATH" ":" prefix (,bin))))
+ (list "ug+" "ugrep+")))))
(add-before 'check 'check-setup
(lambda _
;; Unpatch shebangs in tests.

base-commit: f129a6cc591817c5c51770d5b8712eeb344ba4e4
--
2.47.1
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 74611@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74611
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch