[PATCH] environment: Suppress all output with --verbosity=0

  • Open
  • quality assurance status badge
Details
One participant
  • Brian Kubisiak
Owner
unassigned
Submitted by
Brian Kubisiak
Severity
normal
B
B
Brian Kubisiak wrote on 29 Nov 16:08 +0100
(address . guix-patches@gnu.org)
12298fd80fdf6237e6b899e10c8a0d01948bf097.1732892565.git.brian@kubisiak.com
* guix/scripts/environment.scm (guix-environment*): Call
'with-status-verbosity' earlier.

Change-Id: I69c7dd1058b44d587312d957312a130a8703cfca
---
guix/scripts/environment.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (20 lines)
diff --git a/guix/scripts/environment.scm b/guix/scripts/environment.scm
index fc7fa84be7..648a497743 100644
--- a/guix/scripts/environment.scm
+++ b/guix/scripts/environment.scm
@@ -1140,8 +1140,8 @@ (define (guix-environment* opts)
(when (pair? symlinks)
(leave (G_ "'--symlink' cannot be used without '--container'~%"))))
- (with-store/maybe store
- (with-status-verbosity (assoc-ref opts 'verbosity)
+ (with-status-verbosity (assoc-ref opts 'verbosity)
+ (with-store/maybe store
(define manifest-from-opts
(options/resolve-packages store opts))

base-commit: 369d2698b0bfc3726f8e6d232d43d0dda832225f
prerequisite-patch-id: 196f5fb11760945290fabcf660e5c01b9a53de1a
--
2.46.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 74605@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74605
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch