(address . guix-patches@gnu.org)
* guix/scripts/environment.scm (guix-environment*): Call
'with-status-verbosity' earlier.
Change-Id: I69c7dd1058b44d587312d957312a130a8703cfca
---
guix/scripts/environment.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
Toggle diff (20 lines)
diff --git a/guix/scripts/environment.scm b/guix/scripts/environment.scm
index fc7fa84be7..648a497743 100644
--- a/guix/scripts/environment.scm
+++ b/guix/scripts/environment.scm
@@ -1140,8 +1140,8 @@ (define (guix-environment* opts)
(when (pair? symlinks)
(leave (G_ "'--symlink' cannot be used without '--container'~%"))))
- (with-store/maybe store
- (with-status-verbosity (assoc-ref opts 'verbosity)
+ (with-status-verbosity (assoc-ref opts 'verbosity)
+ (with-store/maybe store
(define manifest-from-opts
(options/resolve-packages store opts))
base-commit: 369d2698b0bfc3726f8e6d232d43d0dda832225f
prerequisite-patch-id: 196f5fb11760945290fabcf660e5c01b9a53de1a
--
2.46.0