[PATCH] gnu: ghc-xmobar: Update to 0.48.1.

  • Done
  • quality assurance status badge
Details
2 participants
  • hiecaq
  • Z572
Owner
unassigned
Submitted by
hiecaq
Severity
normal

Debbugs page

hiecaq wrote 3 months ago
(address . guix-patches@gnu.org)(name . hiecaq)(address . this@hiecaq.org)
20241128151414.6665-1-this@hiecaq.org
* gnu/packages/wm.scm (ghc-xmobar): Update to 0.48.1.
[inputs]: Add ghc-extra.
[home-page]: Point to the actual project home-page.

Change-Id: I4a43c774a00853eb15a0874d5228729867d0606e
---
gnu/packages/wm.scm | 7 ++++---
1 file changed, 4 insertions(+), 3 deletions(-)

Toggle diff (39 lines)
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 2c3a0911ac..a76d58105a 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -909,13 +909,13 @@ (define-public xmonad
(define-public ghc-xmobar
(package
(name "ghc-xmobar")
- (version "0.46")
+ (version "0.48.1")
(source (origin
(method url-fetch)
(uri (hackage-uri "xmobar" version))
(sha256
(base32
- "0glpiq7c0qwfcxnc2flgzj7afm5m1a9ghzwwcq7f8q27m21kddrd"))))
+ "1infcisv7l00a4z4byjwjisg4yndk0cymibfii1c7yzyzrlvavhl"))))
(build-system haskell-build-system)
(properties '((upstream-name . "xmobar")))
(native-inputs
@@ -924,6 +924,7 @@ (define-public ghc-xmobar
(list ghc-alsa-core
ghc-alsa-mixer
ghc-dbus
+ ghc-extra
ghc-hinotify
ghc-http-client-tls
ghc-http-conduit
@@ -957,7 +958,7 @@ (define-public ghc-xmobar
(lambda _
(substitute* "src/Xmobar/X11/CairoSurface.hsc"
(("cairo/cairo-xlib.h") "cairo-xlib.h")))))))
- (home-page "https://xmobar.org")
+ (home-page "https://codeberg.org/xmobar/xmobar")
(synopsis "Haskell library for minimalistic text based status bars")
(description
"@code{ghc-xmobar} is the haskell library that @code{xmobar} is based on.
--
2.46.0
hiecaq wrote 3 months ago
(address . 74592@debbugs.gnu.org)
871pyvs70g.fsf@hiecaq.org
Hi Guix,

I've just sent 3 separate patches, including this one, to update
xmonad,
ghc-xmonad-contrib and ghc-xmobar.

I've been using these 3 latest versions for the last week, and
they are
pretty stable as far as I can tell.

To ghc-xmobar there are notably 2 extra changes:

1. The home-page in the old version seems irrelevant, so I pointed
it to
the repository. Arch also points to this page.
2. ghc-extra is added as a new input, which in upstream was added
to
xmobar.cabal in the commit
7c778511f296c74f36c2b4967707c87ebf2fb808
Z572 wrote 2 months ago
Re: [bug#74592] [PATCH] gnu: ghc-xmobar: Update to 0.48.1.
(name . hiecaq)(address . this@hiecaq.org)(address . 74592-done@debbugs.gnu.org)
87sepj1fdm.fsf@iscas.ac.cn
hiecaq <this@hiecaq.org> writes:

Toggle quote (47 lines)
> * gnu/packages/wm.scm (ghc-xmobar): Update to 0.48.1.
> [inputs]: Add ghc-extra.
> [home-page]: Point to the actual project home-page.
>
> Change-Id: I4a43c774a00853eb15a0874d5228729867d0606e
> ---
> gnu/packages/wm.scm | 7 ++++---
> 1 file changed, 4 insertions(+), 3 deletions(-)
>
> diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
> index 2c3a0911ac..a76d58105a 100644
> --- a/gnu/packages/wm.scm
> +++ b/gnu/packages/wm.scm
> @@ -909,13 +909,13 @@ (define-public xmonad
> (define-public ghc-xmobar
> (package
> (name "ghc-xmobar")
> - (version "0.46")
> + (version "0.48.1")
> (source (origin
> (method url-fetch)
> (uri (hackage-uri "xmobar" version))
> (sha256
> (base32
> - "0glpiq7c0qwfcxnc2flgzj7afm5m1a9ghzwwcq7f8q27m21kddrd"))))
> + "1infcisv7l00a4z4byjwjisg4yndk0cymibfii1c7yzyzrlvavhl"))))
> (build-system haskell-build-system)
> (properties '((upstream-name . "xmobar")))
> (native-inputs
> @@ -924,6 +924,7 @@ (define-public ghc-xmobar
> (list ghc-alsa-core
> ghc-alsa-mixer
> ghc-dbus
> + ghc-extra
> ghc-hinotify
> ghc-http-client-tls
> ghc-http-conduit
> @@ -957,7 +958,7 @@ (define-public ghc-xmobar
> (lambda _
> (substitute* "src/Xmobar/X11/CairoSurface.hsc"
> (("cairo/cairo-xlib.h") "cairo-xlib.h")))))))
> - (home-page "https://xmobar.org")
> + (home-page "https://codeberg.org/xmobar/xmobar")
> (synopsis "Haskell library for minimalistic text based status bars")
> (description
> "@code{ghc-xmobar} is the haskell library that @code{xmobar} is based on.

pushed, closing.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEfr6klGDOXiwIdX/bO1qpk+Gi3/AFAmeInOUACgkQO1qpk+Gi
3/DB1A/+Ikw1GI+y1jZUm9/EbHAxYv4lDemSV1LcWAlI6AlCo6ix7vmMrWVouWXc
bq568UYgSNfuvdtEMyuZQN6sTdW0G3BRZZwZgvnJjX6wanrwJTBo+r+apbOzfG79
WfLsQOtKuwgKbFAAa/c/ZxO1jKlwNgQXjffEViDW4v/HpvptLqSLHWYO5FeV0CY4
E2/dr5AmlHsCDrisDMS4x6WAUJ9duUfwi5UcWNiScX2OicrkVTMVyq0ilLfiL/0n
3Avy4axTIAOuIlEAkQnzma2qF62MGKbI9CvATsZOOGnIBBSOqQIQee73Pu2Rq2KF
y8Kgvb/579A+XV9Nn9iKmjRQimkmXJMLO87DTPQFyOsMU/piiw+PZOo1//ZgzfrR
N4fxzWM3Upv+7ks3vTwxl6iD1gsl9uTSWWpFMGNZ7ex6H1C3GencrhEx7ecRE4IZ
Mf48Zxa6/iUecE/Bil4k3TmRz9SIji98OdoQ1MRJR+KVRd/2ZGMwvie1a7kidk/j
/tK+ygAB0IOCzqnf/ET66Zryr/Up9U/+AXhs3rxyLvujrigx4rb4fD/27uhkCTXr
mxdTRDmkWuh72E4YSKLrsc5UEA/E44Sjr245eBD00J1CILKBHMTKoJtvbvT3IxDS
uhoYzoex+qbvUdnAmo3YESvRTSnjqFTIMygBxq3vAj6h7zIk7Vk=
=wLLJ
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 74592@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74592
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help