hiecaq wrote 3 months ago
(address . guix-patches@gnu.org)(name . hiecaq)(address . this@hiecaq.org)
* gnu/packages/wm.scm (ghc-xmobar): Update to 0.48.1.
[inputs]: Add ghc-extra.
[home-page]: Point to the actual project home-page.
Change-Id: I4a43c774a00853eb15a0874d5228729867d0606e
---
gnu/packages/wm.scm | 7 ++++---
1 file changed, 4 insertions(+), 3 deletions(-)
Toggle diff (39 lines)
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 2c3a0911ac..a76d58105a 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -909,13 +909,13 @@ (define-public xmonad
(define-public ghc-xmobar
(package
(name "ghc-xmobar")
- (version "0.46")
+ (version "0.48.1")
(source (origin
(method url-fetch)
(uri (hackage-uri "xmobar" version))
(sha256
(base32
- "0glpiq7c0qwfcxnc2flgzj7afm5m1a9ghzwwcq7f8q27m21kddrd"))))
+ "1infcisv7l00a4z4byjwjisg4yndk0cymibfii1c7yzyzrlvavhl"))))
(build-system haskell-build-system)
(properties '((upstream-name . "xmobar")))
(native-inputs
@@ -924,6 +924,7 @@ (define-public ghc-xmobar
(list ghc-alsa-core
ghc-alsa-mixer
ghc-dbus
+ ghc-extra
ghc-hinotify
ghc-http-client-tls
ghc-http-conduit
@@ -957,7 +958,7 @@ (define-public ghc-xmobar
(lambda _
(substitute* "src/Xmobar/X11/CairoSurface.hsc"
(("cairo/cairo-xlib.h") "cairo-xlib.h")))))))
- (home-page "https://xmobar.org")
+ (home-page "https://codeberg.org/xmobar/xmobar")
(synopsis "Haskell library for minimalistic text based status bars")
(description
"@code{ghc-xmobar} is the haskell library that @code{xmobar} is based on.
--
2.46.0