[PATCH 0/2] Decouple pipewire from qtbase.

  • Open
  • quality assurance status badge
Details
One participant
  • Nicolas Graves
Owner
unassigned
Submitted by
Nicolas Graves
Severity
normal
N
N
Nicolas Graves wrote on 28 Nov 2024 13:58
(address . guix-patches@gnu.org)
20241128130056.6704-1-ngraves@ngraves.fr
In the spirit of 74517, we should need qtbase in the store to be able
to build pipewire, and the depencendy is there for an optional
graphical tool in libcamera.

Nicolas Graves (2):
gnu: Add libcamera-minimal.
gnu: pipewire: Replace libcamera by libcamera-minimal.

gnu/packages/linux.scm | 2 +-
gnu/packages/networking.scm | 7 +++++++
2 files changed, 8 insertions(+), 1 deletion(-)

--
2.46.0
N
N
Nicolas Graves wrote on 28 Nov 2024 14:41
[PATCH 1/2] gnu: Add libcamera-minimal.
(address . 74589@debbugs.gnu.org)(name . Nicolas Graves)(address . ngraves@ngraves.fr)
20241128134126.14801-1-ngraves@ngraves.fr
* gnu/packages/networking.scm (libcamera-minimal): New variable.
---
gnu/packages/networking.scm | 7 +++++++
1 file changed, 7 insertions(+)

Toggle diff (20 lines)
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index d78f4ca02f..cf90ffb1cd 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -470,6 +470,13 @@ (define-public libcamera
(home-page "https://libcamera.org/")
(license license:lgpl2.1+)))
+(define-public libcamera-minimal
+ (package
+ (inherit libcamera)
+ (name "libcamera-minimal")
+ (inputs (modify-inputs (package-inputs libcamera)
+ (delete "qtbase")))))
+
(define-public libnice
(package
(name "libnice")
--
2.46.0
N
N
Nicolas Graves wrote on 28 Nov 2024 14:41
[PATCH v2 1/2] gnu: Add libcamera-minimal.
(address . 74589@debbugs.gnu.org)(name . Nicolas Graves)(address . ngraves@ngraves.fr)
20241128134151.14959-1-ngraves@ngraves.fr
* gnu/packages/networking.scm (libcamera-minimal): New variable.
---
gnu/packages/networking.scm | 7 +++++++
1 file changed, 7 insertions(+)

Toggle diff (20 lines)
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index d78f4ca02f..cf90ffb1cd 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -470,6 +470,13 @@ (define-public libcamera
(home-page "https://libcamera.org/")
(license license:lgpl2.1+)))
+(define-public libcamera-minimal
+ (package
+ (inherit libcamera)
+ (name "libcamera-minimal")
+ (inputs (modify-inputs (package-inputs libcamera)
+ (delete "qtbase")))))
+
(define-public libnice
(package
(name "libnice")
--
2.46.0
N
N
Nicolas Graves wrote on 28 Nov 2024 14:41
[PATCH v2 2/2] gnu: pipewire: Replace libcamera by libcamera-minimal.
(address . 74589@debbugs.gnu.org)(name . Nicolas Graves)(address . ngraves@ngraves.fr)
20241128134151.14959-2-ngraves@ngraves.fr
* gnu/packages/linux.scm (pipewire)[inputs]: Replace libcamera by
libcamera-minimal.
---
gnu/packages/linux.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index f7e7126c3d..9faa8fcde1 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -10087,7 +10087,7 @@ (define-public pipewire
gstreamer
jack-2
ldacbt
- libcamera
+ libcamera-minimal
libfdk
libfreeaptx
libsndfile
--
2.46.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 74589@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74589
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch