[PATCH 00/14] [python-team]

  • Done
  • quality assurance status badge
Details
2 participants
  • Nicolas Graves
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Nicolas Graves
Severity
normal
N
N
Nicolas Graves wrote on 28 Nov 2024 08:44
(address . guix-patches@gnu.org)
20241128074643.17703-1-ngraves@ngraves.fr
Some patches for python-team which will trigger quite some
rebuilds. httpcore in particular was behind a lot of the current
failures.

Nicolas Graves (14):
gnu: python-prawcore: Update to 2.4.0.
gnu: python-praw: Update to 7.8.1.
gnu: giara: Update to 1.1.0.
gnu: cpplint: Add missing native inputs.
gnu: python-ads: Add missing native-inputs.
gnu: python-tqdm: Update to 4.67.1.
gnu: python-fsspec: Update to 2024.10.0.
gnu: python-coverage: Update to 7.6.8.
gnu: python-websockets: Update to 13.1.
gnu: python-pytest-httpx: Update to 0.34.0.
gnu: python-coveralls: Update to 4.0.1.
gnu: python-httpcore: Update to 1.0.7.
gnu: python-httpx: Update to 0.27.2.
gnu: python-joblib: Update to 1.4.2.

gnu/packages/astronomy.scm | 1 +
gnu/packages/check.scm | 45 ++++++++------
gnu/packages/cpp.scm | 5 +-
gnu/packages/python-check.scm | 33 ++++-------
gnu/packages/python-web.scm | 107 +++++++++++++++-------------------
gnu/packages/python-xyz.scm | 72 +++++++++++++----------
gnu/packages/syndication.scm | 9 ++-
7 files changed, 141 insertions(+), 131 deletions(-)

--
2.46.0
N
N
Nicolas Graves wrote on 28 Nov 2024 08:52
[PATCH 01/14] gnu: python-prawcore: Update to 2.4.0.
(address . 74580@debbugs.gnu.org)(name . Nicolas Graves)(address . ngraves@ngraves.fr)
20241128075235.20929-1-ngraves@ngraves.fr
* gnu/packages/python-web.scm (python-prawcore): Update to 2.4.0.
[source]<origin>: Fetch from git to download tests.
[build-system]: Move to pyproject-build-system.
[arguments]<#:test-flags>: Skip failing tests.
[native-inputs]: Add python-flit-core.
---
gnu/packages/python-web.scm | 23 ++++++++++++++++++-----
1 file changed, 18 insertions(+), 5 deletions(-)

Toggle diff (43 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 677f304e0c..422dc7e39d 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -347,18 +347,31 @@ (define-public python-portend
(define-public python-prawcore
(package
(name "python-prawcore")
- (version "2.3.0")
+ (version "2.4.0")
(source
(origin
- (method url-fetch)
- (uri (pypi-uri "prawcore" version))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/praw-dev/prawcore")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32 "0vgmhjddqxnz5vy70dyqvakak51fg1nk6j3xavkc83d8nzacrwfs"))))
- (build-system python-build-system)
+ (base32 "1y7gh7kk002b2h1ppkr1llb2gjfnby28zvx11j4ji0wm3r3rjh5l"))))
+ (build-system pyproject-build-system)
+ (arguments
+ ;; XXX: These tests fail with an incomplete request response.
+ (list #:test-flags
+ #~'("-k" #$(string-append
+ "not test_revoke__access_token_with_refresh_set"
+ " and not test_revoke__access_token_without_refresh_set"
+ " and not test_revoke__refresh_token_with_access_set"
+ " and not test_refresh__with_scopes"
+ " and not test_request__patch"))))
(native-inputs
(list python-betamax
python-betamax-matchers
python-betamax-serializers
+ python-flit-core
python-mock
python-pytest
python-testfixtures))
--
2.46.0
N
N
Nicolas Graves wrote on 28 Nov 2024 08:52
[PATCH 02/14] gnu: python-praw: Update to 7.8.1.
(address . 74580@debbugs.gnu.org)(name . Nicolas Graves)(address . ngraves@ngraves.fr)
20241128075235.20929-2-ngraves@ngraves.fr
* gnu/packages/python-web.scm (python-praw): Update to 7.8.1.
[source]<origin>: Fetch from git to download tests.
[build-system]: Move to pyproject-build-system.
[arguments]<#:test-flags>: Skip failing tests.
[native-inputs]: Add python-flit-core.
---
gnu/packages/python-web.scm | 40 ++++++++++++++++---------------------
1 file changed, 17 insertions(+), 23 deletions(-)

Toggle diff (58 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 422dc7e39d..c5ff14b4ee 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -385,34 +385,28 @@ (define-public python-prawcore
(define-public python-praw
(package
(name "python-praw")
- (version "7.6.1")
+ (version "7.8.1")
(source
(origin
- (method url-fetch)
- (uri (pypi-uri "praw" version))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/praw-dev/praw")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32 "17pvdlcasr08p5hb1x7shjh8yvn621lzm0bvnwd3b1r1qpzrbz07"))))
- (build-system python-build-system)
+ (base32 "05qq43l4334cq8r8k731qnb45nq12vvfdxwbr6q84a1hafp7n4cg"))))
+ (build-system pyproject-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'disable-failing-tests
- (lambda _
- (with-directory-excursion "tests"
- ;; Integration tests depend on files that are not included.
- (for-each delete-file-recursively
- '("integration/models" "unit/models"))
- ;; The configuration file does not seem to exist.
- (delete-file "unit/test_config.py"))))
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "pytest" "-k"
- ;; These tests depend on test files that don't exist.
- (string-append "not test_bad_request_without_json_text_plain_response"
- " and not test_bad_request_without_json_text_html_response"))))))))
+ (list #:test-flags
+ #~(list "--ignore=tests/units/models"
+ "--ignore=tests/integration/models"
+ "--ignore=tests/unit/test_config.py"
+ "--ignore=tests/integration/test_reddit.py")))
(native-inputs
- (list python-betamax python-betamax-matchers python-pytest))
+ (list python-betamax
+ python-betamax-matchers
+ python-flit-core
+ python-pytest))
(propagated-inputs
(list python-prawcore python-update-checker python-websocket-client))
(synopsis "Python Reddit API Wrapper")
--
2.46.0
N
N
Nicolas Graves wrote on 28 Nov 2024 08:52
[PATCH 03/14] gnu: giara: Update to 1.1.0.
(address . 74580@debbugs.gnu.org)(name . Nicolas Graves)(address . ngraves@ngraves.fr)
20241128075235.20929-3-ngraves@ngraves.fr
* gnu/packages/syndication.scm (giara): Update to 1.1.0.
[arguments]<#:phases>: Add phase 'skip-validate-metainfo-file-test.
---
gnu/packages/syndication.scm | 9 +++++++--
1 file changed, 7 insertions(+), 2 deletions(-)

Toggle diff (36 lines)
diff --git a/gnu/packages/syndication.scm b/gnu/packages/syndication.scm
index e262426e28..fc3e904710 100644
--- a/gnu/packages/syndication.scm
+++ b/gnu/packages/syndication.scm
@@ -169,7 +169,7 @@ (define-public cawbird
(define-public giara
(package
(name "giara")
- (version "1.0.1")
+ (version "1.1.0")
(source
(origin
(method git-fetch)
@@ -178,7 +178,7 @@ (define-public giara
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "00vmfghp9g8yzn2d1xjawz5a8bdwn1jl1k24mjaf4vlvdy4sg9l4"))))
+ (base32 "1s2lr7s2sqzvphl84zcf68l6lzhp5faycz75yp36ak18aw9b8g0m"))))
(build-system meson-build-system)
(arguments
`(#:glib-or-gtk? #t
@@ -188,6 +188,11 @@ (define-public giara
(lambda _
(substitute* "meson_post_install.py"
(("gtk-update-icon-cache") "true"))))
+ (add-after 'unpack 'skip-validate-metainfo-file-test
+ (lambda _
+ (substitute* "data/meson.build"
+ (("if ascli_exe\\.found\\(\\)")
+ "if false"))))
(add-after 'glib-or-gtk-wrap 'wrap-paths
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
--
2.46.0
N
N
Nicolas Graves wrote on 28 Nov 2024 08:52
[PATCH 04/14] gnu: cpplint: Add missing native inputs.
(address . 74580@debbugs.gnu.org)(name . Nicolas Graves)(address . ngraves@ngraves.fr)
20241128075235.20929-4-ngraves@ngraves.fr
* gnu/packages/cpp.scm (cpplint)[native-inputs]: Add python-setuptools
and python-wheel.
---
gnu/packages/cpp.scm | 5 ++++-
1 file changed, 4 insertions(+), 1 deletion(-)

Toggle diff (25 lines)
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index eacc6e46ab..95c7340087 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -106,6 +106,7 @@ (define-module (gnu packages cpp)
#:use-module (gnu packages onc-rpc)
#:use-module (gnu packages perl)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-build)
#:use-module (gnu packages python-check)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages popt)
@@ -1250,7 +1251,9 @@ (define-public cpplint
python-pytest
python-pytest-cov
python-pytest-runner
- python-testfixtures))
+ python-setuptools
+ python-testfixtures
+ python-wheel))
(home-page "https://github.com/cpplint/cpplint")
(synopsis "Static code checker for C++")
(description "@code{cpplint} is a command-line tool to check C/C++ files
--
2.46.0
N
N
Nicolas Graves wrote on 28 Nov 2024 08:52
[PATCH 05/14] gnu: python-ads: Add missing native-inputs.
(address . 74580@debbugs.gnu.org)(name . Nicolas Graves)(address . ngraves@ngraves.fr)
20241128075235.20929-5-ngraves@ngraves.fr
* gnu/packages/astronomy.scm (python-ads)[native-inputs]: Add python-pytest.
---
gnu/packages/astronomy.scm | 1 +
1 file changed, 1 insertion(+)

Toggle diff (14 lines)
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index dc0b82bbf4..0cd2a85b8b 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -1510,6 +1510,7 @@ (define-public python-ads
(native-inputs
(list nss-certs-for-test
python-httpretty
+ python-pytest
python-setuptools
python-wheel))
(propagated-inputs
--
2.46.0
N
N
Nicolas Graves wrote on 28 Nov 2024 08:52
[PATCH 06/14] gnu: python-tqdm: Update to 4.67.1.
(address . 74580@debbugs.gnu.org)(name . Nicolas Graves)(address . ngraves@ngraves.fr)
20241128075235.20929-6-ngraves@ngraves.fr
* gnu/packages/python-xyz.scm (python-tqdm): Update to 4.67.1.
[build-system]: Switch to pyproject-build-system.
[arguments]: Use <#:test-flags> instead of <#:phases> to set
tests. Ignore failing test_rlock_creation.
[native-inputs]: Add python-setuptools, python-wheel.
---
gnu/packages/python-xyz.scm | 25 +++++++++++++------------
1 file changed, 13 insertions(+), 12 deletions(-)

Toggle diff (45 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 55571a810f..03c62ff26b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -26527,25 +26527,26 @@ (define-public python-pydub
(define-public python-tqdm
(package
(name "python-tqdm")
- (version "4.64.1")
+ (version "4.67.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "tqdm" version))
(sha256
- (base32
- "1r7i9kswpnrx4ppfvzz6discb04j1rqkqxdwa2sc2la900m6hksz"))))
- (build-system python-build-system)
+ (base32 "1wi7cql2fc76b5z9v1sr96ix2gxcb974z8qfydjkmh885k2zkbpq"))))
+ (build-system pyproject-build-system)
(arguments
- '(#:phases (modify-phases %standard-phases
- (replace 'check
- (lambda _
- (invoke "pytest" "-vv"
- "-o" "asyncio_mode=auto"
- "-k" "not perf"))))))
+ (list #:test-flags
+ '(list "-o" "asyncio_mode=auto"
+ "-k" "not perf and not test_rlock_creation")))
(native-inputs
- (list python-pytest python-pytest-asyncio python-pytest-timeout
- python-setuptools-scm python-toml))
+ (list python-pytest
+ python-pytest-asyncio
+ python-pytest-timeout
+ python-setuptools
+ python-setuptools-scm
+ python-toml
+ python-wheel))
(home-page "https://github.com/tqdm/tqdm")
(synopsis "Fast, extensible progress meter")
(description
--
2.46.0
N
N
Nicolas Graves wrote on 28 Nov 2024 08:52
[PATCH 09/14] gnu: python-websockets: Update to 13.1.
(address . 74580@debbugs.gnu.org)(name . Nicolas Graves)(address . ngraves@ngraves.fr)
20241128075235.20929-9-ngraves@ngraves.fr
* gnu/packages/python-web.scm (python-websockets): Update to 13.1.
---
gnu/packages/python-web.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index c5ff14b4ee..4a409f535a 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -7126,7 +7126,7 @@ (define-public python-warcio
(define-public python-websockets
(package
(name "python-websockets")
- (version "13.0")
+ (version "13.1")
(source
(origin
(method git-fetch)
@@ -7136,7 +7136,7 @@ (define-public python-websockets
(file-name (git-file-name name version))
(sha256
(base32
- "1brnaf1c4r9377p2npxpkik9ggqzmymvnnazdhw6s2wzfhlln8vv"))))
+ "1dx3rf6fmg4ir9cfcn1fil446qz879cwrjq2rcz5zvl71xkw6hb3"))))
(build-system pyproject-build-system)
(arguments
(list #:phases
--
2.46.0
N
N
Nicolas Graves wrote on 28 Nov 2024 08:52
[PATCH 08/14] gnu: python-coverage: Update to 7.6.8.
(address . 74580@debbugs.gnu.org)(name . Nicolas Graves)(address . ngraves@ngraves.fr)
20241128075235.20929-8-ngraves@ngraves.fr
* gnu/packages/check.scm (python-coverage): Update to 7.6.8.
[arguments]<#:test-flags>: Describe why tests fail.
---
gnu/packages/check.scm | 45 +++++++++++++++++++++++++-----------------
1 file changed, 27 insertions(+), 18 deletions(-)

Toggle diff (68 lines)
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 7e0efabc8f..9b1df2fb3d 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -2441,34 +2441,43 @@ (define-public python-testrepository
(define-public python-coverage
(package
(name "python-coverage")
- (version "7.6.7")
+ (version "7.6.8")
(source
(origin
(method url-fetch)
(uri (pypi-uri "coverage" version))
(sha256
(base32
- "094x8fsqfp7blrz3wh823p5vvzdrri5mw17z32hwjh8lwhk4i7fp"))))
+ "1z3wycig8hy7iq9nxwiiiyxn01yblnj69yl2dp424s5hxl1qaawb"))))
(build-system pyproject-build-system)
(arguments
(list
#:test-flags
- #~(list "--numprocesses=auto"
- ;; XXX: Tests fail for multiple assertion reasons or missing
- ;; fake modules.
- "--ignore=tests/test_venv.py"
- "--ignore=tests/test_report.py"
- "--ignore=tests/test_plugins.py"
- "--ignore=tests/test_debug.py"
- "--ignore=tests/test_xml.py"
- "--ignore=tests/test_python.py"
- "--ignore=tests/test_concurrency.py"
- "--ignore=tests/test_process.py"
- "--deselect=tests/test_annotate.py::AnnotationGoldTest::test_multi"
- "--deselect=tests/test_cmdline.py::CmdLineStdoutTest::test_version"
- "--deselect=tests/test_api.py::RelativePathTest::test_files_up_one_level"
- "--deselect=tests/test_filereporter.py::FileReporterTest::test_zipfile"
- "--deselect=tests/test_oddball.py::DoctestTest::test_doctest")
+ #~(list
+ "--numprocesses" (number->string (parallel-job-count))
+ ;; XXX: Unable to properly compare reports.
+ "--ignore=tests/test_report.py"
+ ;; XXX: PyTracer or missing dependencies.
+ "--ignore=tests/test_venv.py"
+ "--ignore=tests/test_plugins.py"
+ "--ignore=tests/test_debug.py"
+ ;; XXX: Unclear why these fail.
+ "--ignore=tests/test_python.py"
+ "--deselect=tests/test_concurrency.py\
+::SigtermTest::test_sigterm_multiprocessing_saves_data"
+ ;; XXX: Unexpected paths order.
+ "--ignore=tests/test_process.py"
+ ;; XXX: PermissionError
+ "--deselect=tests/test_annotate.py::AnnotationGoldTest::test_multi"
+ ;; XXX: Needs C extension
+ "--deselect=tests/test_cmdline.py::CmdLineStdoutTest::test_version"
+ ;; XXX: Finds more files at toplevel
+ "--deselect=tests/test_api.py::RelativePathTest::test_files_up_one_level"
+ "--deselect=tests/test_xml.py::XmlReportTest::test_no_duplicate_packages"
+ ;; XXX: zip1 module missing.
+ "--deselect=tests/test_filereporter.py::FileReporterTest::test_zipfile"
+ ;; XXX: Checking coverage for too much files, not only the target one.
+ "--deselect=tests/test_oddball.py::DoctestTest::test_doctest")
#:phases
#~(modify-phases %standard-phases
(add-after 'unpack 'patch-pyproject
--
2.46.0
N
N
Nicolas Graves wrote on 28 Nov 2024 08:52
[PATCH 07/14] gnu: python-fsspec: Update to 2024.10.0.
(address . 74580@debbugs.gnu.org)(name . Nicolas Graves)(address . ngraves@ngraves.fr)
20241128075235.20929-7-ngraves@ngraves.fr
* gnu/packages/python-xyz.scm (python-fsspec): Update to 2024.10.0.
[arguments]<#:phases>: Rewrite phase 'fix-version. Add phase
'install-version.
<#:test-flags>: Ignore the sole failing test.
[native-inputs]: Add python-hatchling. Remove python-setuptools and
python-wheel.
---
gnu/packages/python-xyz.scm | 35 ++++++++++++++++++++++-------------
1 file changed, 22 insertions(+), 13 deletions(-)

Toggle diff (67 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 03c62ff26b..cf0d423a95 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -29367,7 +29367,7 @@ (define-public python-partd
(define-public python-fsspec
(package
(name "python-fsspec")
- (version "2023.5.0")
+ (version "2024.10.0")
(source
(origin
(method git-fetch)
@@ -29376,8 +29376,7 @@ (define-public python-fsspec
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32
- "0c0brw5s4330rj0yjcrqi56hanvaahn43854jai70qzqg1qvyl88"))))
+ (base32 "0fba2wsf0z80y2x60rag5h393vn0ln7s0fbmvvl1cwjw30pgl9qb"))))
(build-system pyproject-build-system)
(arguments
(list
@@ -29385,21 +29384,31 @@ (define-public python-fsspec
#~(modify-phases %standard-phases
(add-after 'unpack 'fix-version
(lambda _
- (substitute* "fsspec/__init__.py"
- (("__version__ = .*")
- (string-append "__version__ = \"" #$version "\"")))
- (substitute* "setup.py"
- (("versioneer.get_version\\(\\)")
- (string-append "\"" #$version "\""))))))
+ (call-with-output-file "fsspec/_version.py"
+ (lambda (port)
+ (display (string-append "__version__ = \"" #$version "\"")
+ port)))
+ (substitute* "pyproject.toml"
+ (("\\[tool\\.hatch\\.build\\.hooks\\.vcs\\]")
+ "")
+ (("^dynamic = \\[\"version\"\\]")
+ (string-append "version = \"" #$version "\"\n")))))
+ (add-after 'install 'install-version
+ (lambda _
+ (install-file
+ "fsspec/_version.py"
+ (dirname (car (find-files #$output "gui\\.py")))))))
#:test-flags
'(list
- ;; requires internet access
- "--ignore=fsspec/implementations/tests/test_dbfs.py")))
+ ;; XXX: Unclear why this test fail.
+ "-k" "not test_processes")))
(propagated-inputs
(list python-aiohttp python-libarchive-c python-requests python-tqdm))
(native-inputs
- (list python-pytest python-pytest-mock python-numpy python-setuptools
- python-wheel))
+ (list python-hatchling
+ python-pytest
+ python-pytest-mock
+ python-numpy))
(home-page "https://github.com/intake/filesystem_spec")
(synopsis "File-system specification")
(description "The purpose of this package is to produce a template or
--
2.46.0
N
N
Nicolas Graves wrote on 28 Nov 2024 08:52
[PATCH 10/14] gnu: python-pytest-httpx: Update to 0.34.0.
(address . 74580@debbugs.gnu.org)(name . Nicolas Graves)(address . ngraves@ngraves.fr)
20241128075235.20929-10-ngraves@ngraves.fr
* gnu/packages/python-check.scm (python-pytest-httpx): Update to 0.34.0.
---
gnu/packages/python-check.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index df0a490eae..2af10ed7f3 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -3077,7 +3077,7 @@ (define-public python-pytest-parawtf
(define-public python-pytest-httpx
(package
(name "python-pytest-httpx")
- (version "0.22.0")
+ (version "0.34.0")
(source
(origin
;; pypi package doesn't include the tests
@@ -3087,7 +3087,7 @@ (define-public python-pytest-httpx
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1ncpd74hmsz4sadvjg99fnfscxpgh3mc2siini0dhxzwgwdkk5i7"))))
+ (base32 "0dk1z9zy483nffbmn883mcjrlwkn79c3sqlxf6qnwcgrvdw1w9zz"))))
(build-system pyproject-build-system)
(native-inputs
(list python-pytest
--
2.46.0
N
N
Nicolas Graves wrote on 28 Nov 2024 08:52
[PATCH 11/14] gnu: python-coveralls: Update to 4.0.1.
(address . 74580@debbugs.gnu.org)(name . Nicolas Graves)(address . ngraves@ngraves.fr)
20241128075235.20929-11-ngraves@ngraves.fr
* gnu/packages/python-check.scm (python-coveralls): Update to 4.0.1.
[source]<origin>: Remove uneeded modules and snippet fields.
[build-system]: Switch to pyproject-build-system.
[arguments]<#:phases>: Move functionality to...
<#:test-flags>: ...here. Add failing tests.
[native-inputs]: Add poetry.
---
gnu/packages/python-check.scm | 29 ++++++++++-------------------
1 file changed, 10 insertions(+), 19 deletions(-)

Toggle diff (53 lines)
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 2af10ed7f3..0e23f78a17 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -343,7 +343,7 @@ (define-public python-cucumber-tag-expressions
(define-public python-coveralls
(package
(name "python-coveralls")
- (version "3.2.0")
+ (version "4.0.1")
(home-page "https://github.com/coveralls-clients/coveralls-python")
(source
(origin
@@ -352,28 +352,19 @@ (define-public python-coveralls
(uri (git-reference (url home-page) (commit version)))
(file-name (git-file-name name version))
(sha256
- (base32
- "1915ab77nfb1rfw4i2ps0zy19wpf20lwxn81qxxbwyd2gy7m0fn8"))
- (modules '((guix build utils)))
- (snippet '(substitute* "setup.py"
- (("'coverage>=4.1,<6.0',") "'coverage',")))))
- (build-system python-build-system)
+ (base32 "1411h7rwxgp9ag26bmlpy7g7sdh39f56dc1mrd1n74bjsgvwzj6l"))))
+ (build-system pyproject-build-system)
(arguments
- '(#:phases (modify-phases %standard-phases
- (add-before 'check 'disable-git-test
- (lambda _
- ;; Remove test that requires 'git' and the full checkout.
- (delete-file "tests/git_test.py")))
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (if tests?
- ;; Test fails for unknown reasons. No fix available.
- (invoke "pytest" "-vv" "-k" "not test_reporter_with_branches")
- (format #t "test suite not run~%")))))))
+ (list #:test-flags '(list
+ ;; XXX: Avoid git dependency.
+ "--ignore=tests/git_test.py"
+ ;; XXX: Unable to find coverage package.
+ "--ignore=tests/api/reporter_test.py"
+ "--ignore=tests/integration_test.py")))
(propagated-inputs
(list python-coverage python-docopt python-pyyaml python-requests))
(native-inputs
- (list python-mock python-pytest python-responses))
+ (list poetry python-mock python-pytest python-responses))
(synopsis "Show coverage stats online via coveralls.io")
(description
"Coveralls.io is a service for publishing code coverage statistics online.
--
2.46.0
N
N
Nicolas Graves wrote on 28 Nov 2024 08:52
[PATCH 12/14] gnu: python-httpcore: Update to 1.0.7.
(address . 74580@debbugs.gnu.org)(name . Nicolas Graves)(address . ngraves@ngraves.fr)
20241128075235.20929-12-ngraves@ngraves.fr
* gnu/packages/python-web.scm (python-httpcore): Update to 1.0.7.
[arguments]<#:test-flags>: Remove uneeded field.
[native-inputs]: Remove python-setuptools and python-wheel. Add
python-hatch-fancy-pypi-readme, and python-hatchling.
---
gnu/packages/python-web.scm | 33 +++++++--------------------------
1 file changed, 7 insertions(+), 26 deletions(-)

Toggle diff (69 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 4a409f535a..350ecad848 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -6860,7 +6860,7 @@ (define-public python-vf-1
(define-public python-httpcore
(package
(name "python-httpcore")
- (version "0.17.0")
+ (version "1.0.7")
(source
(origin
;; PyPI tarball does not contain tests.
@@ -6870,39 +6870,19 @@ (define-public python-httpcore
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0qf2w6sgn51jd41a4k230jincrk6rchgc0k1bclxhyyzv44q4q8c"))))
+ (base32 "1wz54snks59m1mz2mv0i4p37zz2rrzd99gpg8sh3qkpck5h8lhc4"))))
(build-system pyproject-build-system)
- (arguments
- (list
- #:test-flags
- '(list "--override-ini=asyncio_mode=auto"
- "-k"
- (string-join '("not test_ssl_request"
- ;; PytestUnraisableExceptionWarning
- "test_authenticated_socks5_request"
- "test_socks5_request"
- "test_socks5_request_connect_failed"
- "test_socks5_request_failed_to_provide_auth"
- "test_socks5_request_incorrect_auth"
- ;; marked with @pytest.mark.asyncio but it is not an async function
- "test_connection_pool_concurrency"
- "test_connection_pool_concurrency_same_domain_keepalive"
- "test_response_async_read"
- "test_response_async_streaming"
- ;; SSL connection has been closed
- "test_extra_info")
- " and not "))))
(native-inputs
(list nss-certs-for-test
+ python-hatch-fancy-pypi-readme
+ python-hatchling
python-pytest
python-pytest-asyncio
python-pytest-cov
python-pytest-httpbin
python-pytest-trio
python-uvicorn
- python-setuptools
- python-trustme
- python-wheel))
+ python-trustme))
(propagated-inputs
(list python-anyio
python-certifi
@@ -6936,7 +6916,8 @@ (define-public python-httpcore-bootstrap
(package/inherit python-httpcore
(name "python-httpcore-bootstrap")
(arguments (list #:tests? #f))
- (native-inputs (list python-setuptools python-wheel)))))
+ (native-inputs (list python-hatchling
+ python-hatch-fancy-pypi-readme)))))
(define-public python-httpx
(package
--
2.46.0
N
N
Nicolas Graves wrote on 28 Nov 2024 08:52
[PATCH 13/14] gnu: python-httpx: Update to 0.27.2.
(address . 74580@debbugs.gnu.org)(name . Nicolas Graves)(address . ngraves@ngraves.fr)
20241128075235.20929-13-ngraves@ngraves.fr
* gnu/packages/python-web.scm (python-httpx): Update to 0.27.2.
[native-inputs]: Add python-zstandard.
---
gnu/packages/python-web.scm | 7 ++++---
1 file changed, 4 insertions(+), 3 deletions(-)

Toggle diff (34 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 350ecad848..d44cdbbeed 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -6922,7 +6922,7 @@ (define-public python-httpcore-bootstrap
(define-public python-httpx
(package
(name "python-httpx")
- (version "0.24.1")
+ (version "0.27.2")
(source
(origin
;; PyPI tarball does not contain tests.
@@ -6932,7 +6932,7 @@ (define-public python-httpx
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "121cnzp5jq638wrvfmxa9q0rwank7q6v5fi1lnih50fd5219yvm8"))))
+ (base32 "1jd5w3nhpvrbj66nk2njvfnk0g1mkxivwa52j2yyhcna1xafsk1p"))))
(build-system pyproject-build-system)
(arguments
(list
@@ -6964,7 +6964,8 @@ (define-public python-httpx
python-trustme
python-uvicorn
python-setuptools
- python-wheel))
+ python-wheel
+ python-zstandard))
(propagated-inputs
(list python-charset-normalizer
python-brotli
--
2.46.0
N
N
Nicolas Graves wrote on 28 Nov 2024 08:52
[PATCH 14/14] gnu: python-joblib: Update to 1.4.2.
(address . 74580@debbugs.gnu.org)(name . Nicolas Graves)(address . ngraves@ngraves.fr)
20241128075235.20929-14-ngraves@ngraves.fr
* gnu/packages/python-xyz.scm (python-joblib): Update to 1.4.2.
[arguments]<#:test-flags>: Add --numprocesses flag.
[native-inputs]: Add python-pytest-xdist.
---
gnu/packages/python-xyz.scm | 12 +++++++-----
1 file changed, 7 insertions(+), 5 deletions(-)

Toggle diff (41 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index cf0d423a95..322fb902d5 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -6889,19 +6889,22 @@ (define-public python-pystitcher
(define-public python-joblib
(package
(name "python-joblib")
- (version "1.3.2")
+ (version "1.4.2")
(source (origin
(method url-fetch)
(uri (pypi-uri "joblib" version))
(sha256
(base32
- "1cbjjzsh9hzaqr2cqja95673p7j88b8bd02hjpkq8xz147k6by4j"))))
+ "03izdcvc3fa355cclzgvzmjnfwylvblz9q091b9gndi6df0wb0i3"))))
(build-system pyproject-build-system)
(arguments
(list
#:test-flags ; disabled to avoid having to depend on ipython/jupyter
- #~(list "-k" "not test_parallel_call_cached_function_defined_in_jupyter")))
- (native-inputs (list python-pytest python-setuptools python-wheel))
+ #~(list
+ "--numprocesses" (number->string (parallel-job-count))
+ "-k" "not test_parallel_call_cached_function_defined_in_jupyter")))
+ (native-inputs
+ (list python-pytest python-pytest-xdist python-setuptools python-wheel))
(propagated-inputs (list python-psutil))
(home-page "https://joblib.readthedocs.io/")
(synopsis "Using Python functions as pipeline jobs")
@@ -6912,7 +6915,6 @@ (define-public python-joblib
logging and tracing of the execution.")
(license license:bsd-3)))
-
(define-public python-daemon
(package
(name "python-daemon")
--
2.46.0
S
S
Sharlatan Hellseher wrote on 28 Nov 2024 17:01
[PATCH 00/14] [python-team]
(address . 74580@debbugs.gnu.org)(name . Nicolas Graves)(address . ngraves@ngraves.fr)
87iks7mjom.fsf@gmail.com
Hi Nicolas,

Thanks for the patches.

They looks good from the first glance nice to more and more packages
migrating to pyproject-buid-system.

I've applied it locally and initiate the build on my machine, will let
you know when it's finished.

--
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmdIk9kACgkQdtcnv/Ys
0rVmLxAAxtp01sSk41Y1RZ9FuyyGZW/PKJHQnLBIOA9fmENx9oWIJh7c6wSB27Tp
2vFJ+xRKSafqd+/N/B9m6s8/RsxVDiXAfpMmJRlb3FDgib0/z89kureZa6EGPAhu
uo+rSbQZwp82JWqxEb3UXXIiOiOhxawGvcFhq5XkxHuzeuXYDGyzIASXgts4RRPR
Fw0UUvZTjXKH6nh75dSR1BFX6O/yWGWStYaFcBmaaXG9YAB2NYeqDZy4h6dtW0l7
VP77+FZTwMSOHfSDxQVBFWModhhyPQfnhRihxwGbxGB4U8V+XUazx1Qk+yoZKLRo
icTsdSO44VIcqQK4Ja8q7CQdrMy1wNY8WFaDej1h79d+4FTooklOeo6+AQNyVUqY
edsA459sn2pJ2gnvUzkxPf5vpazvvI5fAyKycEFPBtuBimxsq6eaquq9gXi7+8Yw
riZPUd875/0WWzYAh2RXqhlxQmu/QILw4CuFDtQtv91Uigob23TY3jAs23vbS6fu
Tn1yhI5TgMEJqjXLYzYJ6MHsWVbw33yer534G+osVwlfpTnDIjBLrdSv+Ss+wl58
m6/1bLLu70vqi1hIsAOIpykUGxkd1urJG+JruLenUyOBfUBo1zg1iJuqlZyXzoF1
bQfUzseF8FQqf2LlEU3kWwlZ2xmwVHJ8XNBGgbFd6C453t/+Yuo=
=soow
-----END PGP SIGNATURE-----

S
S
Sharlatan Hellseher wrote on 28 Nov 2024 19:23
(address . 74580@debbugs.gnu.org)
87frnbmd3t.fsf@gmail.com
Hi,

The whole set has been build successfully! I did not check dependent
packages.

Toggle snippet (16 lines)
/gnu/store/93qf5wpxlqzpj0b6k0xmnm2hbx3ny1dq-python-prawcore-2.4.0
/gnu/store/k1y38iwn5cpqxh6gv52k1r0m36nqnmnp-python-praw-7.8.1
/gnu/store/n40ji4ip7d9jrq4nb7cazpj4qkmi8r1z-giara-1.1.0
/gnu/store/6ks3cpzfpv6wp1lk127zl04ww8qsj4yz-cpplint-1.5.5
/gnu/store/gkpy0pnj94b2xqzsciwhnqqx450mpdi9-python-ads-0.12.6
/gnu/store/06ri4k2c9454pj19yaypbsbh4jlm401w-python-tqdm-4.67.1
/gnu/store/wrh9kj48afrg5ci6378g3s7gy0j6pdg0-python-fsspec-2024.10.0
/gnu/store/8xymn7sq7yq18cn5jz1kkqfxsr6359kn-python-coverage-7.6.8
/gnu/store/ych6kgvpinb32i3yy5v0cngkf920j6af-python-websockets-13.1
/gnu/store/09v5bggg62w4xib86kbr0gpfsxfc2wmh-python-pytest-httpx-0.34.0
/gnu/store/x5hpi1ggr3ls8gmbwv7ig1z75kl6npaf-python-coveralls-4.0.1
/gnu/store/q8jlf1s3y6bcaway9d9kf427lmv3ksxc-python-httpcore-1.0.7
/gnu/store/bh3g91gq382mxa9314dgl2s2fj2f4nsm-python-httpx-0.27.2
/gnu/store/8ha54qxi3vphrx2bd0wdzkgsj01bn60v-python-joblib-1.4.2

I can push the patch set to python-team branch tonight or tomorrow,
maybe anyone would like to check them as well.

--
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmdItSYACgkQdtcnv/Ys
0rWhiA/+IwnO0Canfcg8q/KjTZFmpTHZj4jLK3uXUln4c41lQ95jzHb01r6Ldmkv
vm8OAqkOZxwKUru1Izvz3kZrOw23Yx6ZjPZT75tjhojFv5y85qtq/X8pX/WHMw42
nbVGpzHuEv1dPV9AbMohfoLxNECaAGx8ZH1ncR1ksinGTHbQKHn4EeED7lhx7xqn
rtZ3NPQm3RuK0646EJWeTgCpSs2HegToV5//TM82kOMTnDXgH/beev12WWUtr/GL
j1L72cSytlV4VtQlDJC+omqOWoEaZhBgP41rToeiqwIvR8yguWD2W/F8lEWy5SKq
C4P4lZFVGRj0h3jhIYJzBXE0uGEvY+2OXJDAGQg3+SvaMgEptg+H4DNMNUv18duS
CKd0gOtVSEGhEm9HHWjQ+y3dqCQs4qMmOsCXo4oLdbXjPeaJGI0sSc3Yc/nBmNYr
Pp8czCbDsthTy7uT27Fa8M/qYh8jdp52WxqsoEAhVbDoSeTnGPnsEZQR6ejy50Kp
OZJ/vDKF8FQBP0mKc6CK3apc/SMoVUJvM/aSeIXn1L37s5zIQRwBccCnrougpf6L
G3BMh7FNNTiErMPgzBr/hX2vbE4YgyF9k78/RXHLlCGMc13iiVTzcgxl3E9Y0ozR
fmuWiJx/g83rOaaIFyhCwF1DxehaZd+C2GiUCuvwwGC06FG8HQI=
=LO0D
-----END PGP SIGNATURE-----

S
S
Sharlatan Hellseher wrote on 7 Dec 2024 00:02
(address . 74580-done@debbugs.gnu.org)
874j3g8lex.fsf@gmail.com
Hi,

The patch set pushed to python-team after successful local build.

--
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmdTgpYACgkQdtcnv/Ys
0rXW0Q/8DlGLw+g8/1A/GDl0AvsyksTzTzwSB8TNuS2SrHqwyWRXhS1pwgUaM9ay
OJRty4Y0XiA5+POIlE1bbZUmHwXMKB8aEsl1MMTQOyMKr9+Z1gSJlioqsLbREXme
j//DL4QnNlavhOP00epimXGGhqbNMmrwjcLojzHY0KfSRstpbNwN2qqHsGWXj/zh
D+FsX+y41qGjO3dHZrTDuNRP9lZ/axdgoUlqB6r8TkL7SMGZK7Xwyjc75V0UZiR8
re1jiWThiWE+mrKhdC5zhMcLnFiT7/DrWkAmj87zUDtPx5WcFVmCjuXRXMIZH8EW
HZTz8V7jJeqMPiQnIYhsb08jGYIoBjXyhKP8t+cUyrMt4Qw8oA8OgGQz2m0CDehL
cQSrzNfXWMj3IpC3e6gwYjq76Nr266Ik9kDclJ5TDGCDaP9A9/FiW8hTEljafy7B
ct3bBpjdItxs+xJZJD+Aqi+6+63ZRwEo1szvPz+d1oNNYcXeluGZo9BaC5hgxnFf
UlCTEgcc7FPxk4rd4YeHzViae/qCOMNpWYFgsT3mxa3CufZHEy22MXooxIysbpu8
/67bKxA8ouKl3mIWgHhAr0ahrAmA6eFD+Crgpwn0wkIrQePBuKj375ExxWQjquH8
6B6A7mlQ8eyWEb3AaDH3s2coy3ZWa8/6ttbXd0gtgAjhA5r0AQ4=
=z3AV
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 74580@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74580
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch