SwayFX update to 0.4

  • Done
  • quality assurance status badge
Details
2 participants
  • Josep Bigorra
  • John Kehayias
Owner
unassigned
Submitted by
Josep Bigorra
Severity
normal

Debbugs page

Josep Bigorra wrote 3 months ago
(address . guix-patches@gnu.org)
CAM_04A3kqkAxcZQPiKhVHP621APvRzSsVxycSRgNc9UHd9DBjg@mail.gmail.com
Hi all!
I have managed to get SwayFX 0.4 working nicely. This required adding a new
package.
I look forward to contributing upstream, but need some handholding in how
to do that.

Here some code, showing how i managed:

```
(define-public scenefx
(package
(name "scenefx")
(version "0.1")
(source (origin
(method git-fetch)
(uri (git-reference
(commit version)))
(file-name (git-file-name name version))
(sha256
(base32
"1r7f8bprsn0mwlkmc8d14nr3iibljfyxypb4i06v66ghlngaw6dw"))))
(build-system meson-build-system)
(inputs (map (lambda (x) (specification->package x))
`("basu"
"cairo"
"gdk-pixbuf"
"json-c"
"cmake"
"pango"
"libevdev"
"libinput-minimal"
"libxkbcommon"
"pango"
"pcre2"
"pkg-config"
"pcre2"
"wayland"
"wayland-protocols"
"wlr-protocols"
"libdrm"
"wlroots@0.17.4")))
(synopsis "SceneFX")
(description
"SceneFX")
(license license:expat)))

(define-public sss-swayfx
(package
(inherit sway)
(name "swayfx")
(version "0.4")
(source (origin
(method git-fetch)
(uri (git-reference
(commit version)))
(file-name (git-file-name name version))
(sha256
(base32
"0651gbkszc8wwkiiw983m3815cfyk4c9v4mpd1nqf27a0f6qjgsm"))))
(build-system meson-build-system)
(inputs (append
(map (lambda(x) (specification->package x))
`("basu"
"cairo"
"gdk-pixbuf"
"json-c"
"cmake"
"pango"
"libevdev"
"libinput-minimal"
"libxkbcommon"
"pcre2"
"pkg-config"
"swaybg"
"wayland"
"wayland-protocols"
"wlr-protocols"
"libdrm"
"wlroots@0.17.4"
))
(list scenefx pango)
))
(synopsis "Sway Fork with extra options and effects")
(description
"Fork of Sway, a Wayland compositor compatible with i3. SwayFX
adds extra options and effects to the original Sway, such as blur, rounded
corners, shadows, inactive window dimming, etc.")
(license license:expat)))
```
Attachment: file
John Kehayias wrote 2 months ago
(name . Josep Bigorra)(address . jjbigorra@gmail.com)
878qrg2fh8.fsf@protonmail.com
On Wed, Nov 27, 2024 at 08:08 PM, Josep Bigorra wrote:

Toggle quote (5 lines)
> Hi all!
> I have managed to get SwayFX 0.4 working nicely. This required adding a new package.
> I look forward to contributing upstream, but need some handholding in how to do that.
>

Looks like you managed (or someone helped you out) as this was done in
commit e24adc3bdf7cfeacc6aa7788d4a8292df425f6b2.

Closing, thank you!

Toggle quote (87 lines)
> Here some code, showing how i managed:
>
> ```
> (define-public scenefx
> (package
> (name "scenefx")
> (version "0.1")
> (source (origin
> (method git-fetch)
> (uri (git-reference
> (url "https://github.com/wlrfx/scenefx.git")
> (commit version)))
> (file-name (git-file-name name version))
> (sha256
> (base32
> "1r7f8bprsn0mwlkmc8d14nr3iibljfyxypb4i06v66ghlngaw6dw"))))
> (build-system meson-build-system)
> (inputs (map (lambda (x) (specification->package x))
> `("basu"
> "cairo"
> "gdk-pixbuf"
> "json-c"
> "cmake"
> "pango"
> "libevdev"
> "libinput-minimal"
> "libxkbcommon"
> "pango"
> "pcre2"
> "pkg-config"
> "pcre2"
> "wayland"
> "wayland-protocols"
> "wlr-protocols"
> "libdrm"
> "wlroots@0.17.4")))
> (home-page "https://github.com/wlrfx/scenefx.git")
> (synopsis "SceneFX")
> (description
> "SceneFX")
> (license license:expat)))
>
> (define-public sss-swayfx
> (package
> (inherit sway)
> (name "swayfx")
> (version "0.4")
> (source (origin
> (method git-fetch)
> (uri (git-reference
> (url "https://github.com/WillPower3309/swayfx")
> (commit version)))
> (file-name (git-file-name name version))
> (sha256
> (base32
> "0651gbkszc8wwkiiw983m3815cfyk4c9v4mpd1nqf27a0f6qjgsm"))))
> (build-system meson-build-system)
> (inputs (append
> (map (lambda(x) (specification->package x))
> `("basu"
> "cairo"
> "gdk-pixbuf"
> "json-c"
> "cmake"
> "pango"
> "libevdev"
> "libinput-minimal"
> "libxkbcommon"
> "pcre2"
> "pkg-config"
> "swaybg"
> "wayland"
> "wayland-protocols"
> "wlr-protocols"
> "libdrm"
> "wlroots@0.17.4"
> ))
> (list scenefx pango)
> ))
> (home-page "https://github.com/WillPower3309/swayfx")
> (synopsis "Sway Fork with extra options and effects")
> (description
> "Fork of Sway, a Wayland compositor compatible with i3. SwayFX
> adds extra options and effects to the original Sway, such as blur, rounded
> corners, shadows, inactive window dimming, etc.")
> (license license:expat)))
> ```
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 74567@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74567
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help