[PATCH] gnu: umockdev: Update to 0.18.4.

  • Open
  • quality assurance status badge
Details
One participant
  • Zheng Junjie
Owner
unassigned
Submitted by
Zheng Junjie
Severity
normal
Z
Z
Zheng Junjie wrote on 27 Nov 2024 15:39
(address . guix-patches@gnu.org)
4f5759791ada206a02bd3a9c66c262459680e299.1732718389.git.zhengjunjie@iscas.ac.cn
* gnu/packages/check.scm (umockdev): Update to 0.18.4.
[source]: Switch to git-fetch.
[arguments]<#:phases>: Add create-version-file phase.

Change-Id: I1716623527a3a6ce5c87ba821fbd0de4099e3b29
---
gnu/packages/check.scm | 18 ++++++++++++------
1 file changed, 12 insertions(+), 6 deletions(-)

Toggle diff (43 lines)
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index ef1c08f8f38..e6788fcfc7c 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -3895,19 +3895,25 @@ (define-public rapidcheck
(define-public umockdev
(package
(name "umockdev")
- (version "0.17.13")
+ (version "0.18.4")
(source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/martinpitt/umockdev/"
- "releases/download/" version "/"
- "umockdev-" version ".tar.xz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/martinpitt/umockdev")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1kqkraag5v1jl5qfv0mb3ckm8yq2im21mng08sbs9dh9c9pbyvkc"))))
+ "06zfd30la5j32yi0zamldiyylwwvnm6l48fbhzvsb8r2l31yq3jk"))))
(build-system meson-build-system)
(arguments
(list #:phases
#~(modify-phases %standard-phases
+ (add-after 'unpack 'create-version-file
+ (lambda _
+ (call-with-output-file ".version"
+ (lambda (port)
+ (format port #$version)))))
(add-after 'unpack 'skip-test-umockdev.c
;; This test depends on /sys being available, among other
;; things.

base-commit: c6d15cf27a137051ccd8f301330a70dd0eecc3d4
prerequisite-patch-id: 0509905c24bb0a4a1a1d4c947af00ab44ef0be95
prerequisite-patch-id: 7faf0fdfc6da89cc3e541e58de24de3f9efe47c0
prerequisite-patch-id: f1a19f643d1177f3c5bac509ebc44964a5ee6871
--
2.46.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 74559@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74559
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch