[PATCH 0/3] Updating Open MPI and its dependencies

  • Done
  • quality assurance status badge
Details
One participant
  • Ludovic Courtès
Owner
unassigned
Submitted by
Ludovic Courtès
Severity
normal
L
L
Ludovic Courtès wrote 5 days ago
(address . guix-patches@gnu.org)(name . Ludovic Courtès)(address . ludo@gnu.org)
cover.1732643955.git.ludo@gnu.org
Hello!

This upgrades Open MPI and its direct dependencies.

Interestingly, while most of it was built and tested
the ucx upgrade was not tested as such: the manifest there
uses the ‘with-latest’ transformation, which dismisses patches
(and the patch needed to be rebased anyway).

So when checking openmpi@4 and openmpi@5 with these changes,
I had to rebuild a bit.

Ludo’.

Ludovic Courtès (3):
gnu: ucx: Update to 1.17.0.
gnu: rdma-core: Update to 54.0.
gnu: openmpi@5: Update to 5.0.6.

gnu/packages/fabric-management.scm | 4 ++--
gnu/packages/linux.scm | 4 ++--
gnu/packages/mpi.scm | 4 ++--
.../patches/ucx-tcp-iface-ioctl.patch | 22 +++++++++----------
4 files changed, 17 insertions(+), 17 deletions(-)


base-commit: f8979b4bcc8772d02640f6f665b4195380d57df9
--
2.46.0
L
L
Ludovic Courtès wrote 5 days ago
[PATCH 1/3] gnu: ucx: Update to 1.17.0.
(address . 74546@debbugs.gnu.org)(name . Ludovic Courtès)(address . ludovic.courtes@inria.fr)
5c2c0bc8b674b3ef9aaf59e8ef50b14725525042.1732643955.git.ludo@gnu.org
From: Ludovic Courtès <ludovic.courtes@inria.fr>

* gnu/packages/fabric-management.scm (ucx): Update to 1.17.0.
* gnu/packages/patches/ucx-tcp-iface-ioctl.patch: Rebase.

Change-Id: I2089de93da88f4f81c4b233eb03abae1f41dfe7f
---
gnu/packages/fabric-management.scm | 4 ++--
.../patches/ucx-tcp-iface-ioctl.patch | 22 +++++++++----------
2 files changed, 13 insertions(+), 13 deletions(-)

Toggle diff (80 lines)
diff --git a/gnu/packages/fabric-management.scm b/gnu/packages/fabric-management.scm
index 7e539406db..6bf0387cef 100644
--- a/gnu/packages/fabric-management.scm
+++ b/gnu/packages/fabric-management.scm
@@ -185,7 +185,7 @@ (define-public ibutils
(define-public ucx
(package
(name "ucx")
- (version "1.15.0")
+ (version "1.17.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -195,7 +195,7 @@ (define-public ucx
(patches (search-patches "ucx-tcp-iface-ioctl.patch"))
(sha256
(base32
- "1mk46vyfp8hsivk88s8gv0nf458jfs59fczpf66wwa3a9yp324jp"))))
+ "09182kx60kq7iyjyz3mpcrgp1mm0lnpc0f4hd4hlw5yyabkxrpa1"))))
(build-system gnu-build-system)
(arguments
(list
diff --git a/gnu/packages/patches/ucx-tcp-iface-ioctl.patch b/gnu/packages/patches/ucx-tcp-iface-ioctl.patch
index 2a0e4ce138..49038b90f6 100644
--- a/gnu/packages/patches/ucx-tcp-iface-ioctl.patch
+++ b/gnu/packages/patches/ucx-tcp-iface-ioctl.patch
@@ -6,7 +6,7 @@ names of the available TCP network interfaces.
Initially submitted at <https://github.com/openucx/ucx/pull/4462>.
diff --git a/src/uct/tcp/tcp_iface.c b/src/uct/tcp/tcp_iface.c
-index 6a6cd34fa..af32bb2e9 100644
+index f90d54fef..a2f74dc32 100644
--- a/src/uct/tcp/tcp_iface.c
+++ b/src/uct/tcp/tcp_iface.c
@@ -18,6 +18,8 @@
@@ -18,9 +18,9 @@ index 6a6cd34fa..af32bb2e9 100644
#define UCT_TCP_IFACE_NETDEV_DIR "/sys/class/net"
-@@ -875,6 +877,85 @@ static UCS_CLASS_DEFINE_NEW_FUNC(uct_tcp_iface_t, uct_iface_t, uct_md_h,
- uct_worker_h, const uct_iface_params_t*,
- const uct_iface_config_t*);
+@@ -873,6 +875,85 @@ static int uct_tcp_is_bridge(const char *if_name)
+ return (stat(path, &st) == 0) && S_ISDIR(st.st_mode);
+ }
+/* Fetch information about available network devices through an ioctl. */
+static ucs_status_t uct_tcp_query_devices_ioctl(uct_md_h md,
@@ -104,11 +104,11 @@ index 6a6cd34fa..af32bb2e9 100644
ucs_status_t uct_tcp_query_devices(uct_md_h md,
uct_tl_device_resource_t **devices_p,
unsigned *num_devices_p)
-@@ -893,9 +974,9 @@ ucs_status_t uct_tcp_query_devices(uct_md_h md,
+@@ -890,9 +971,9 @@ ucs_status_t uct_tcp_query_devices(uct_md_h md,
- dir = opendir(UCT_TCP_IFACE_NETDEV_DIR);
- if (dir == NULL) {
-- ucs_error("opendir(%s) failed: %m", UCT_TCP_IFACE_NETDEV_DIR);
+ n = scandir(UCT_TCP_IFACE_NETDEV_DIR, &entries, NULL, alphasort);
+ if (n == -1) {
+- ucs_error("scandir(%s) failed: %m", UCT_TCP_IFACE_NETDEV_DIR);
- status = UCS_ERR_IO_ERROR;
- goto out;
+ /* When /sys is unavailable, as can be the case in a container,
@@ -117,10 +117,10 @@ index 6a6cd34fa..af32bb2e9 100644
}
devices = NULL;
-@@ -963,7 +1044,6 @@ ucs_status_t uct_tcp_query_devices(uct_md_h md,
+@@ -959,7 +1040,6 @@ out_release:
+ }
- out_closedir:
- closedir(dir);
+ free(entries);
-out:
return status;
}
--
2.46.0
L
L
Ludovic Courtès wrote 5 days ago
[PATCH 2/3] gnu: rdma-core: Update to 54.0.
(address . 74546@debbugs.gnu.org)(name . Ludovic Courtès)(address . ludo@gnu.org)
fa069dad924f355e164bc3a4f6ce51ab393288f0.1732643955.git.ludo@gnu.org
* gnu/packages/linux.scm (rdma-core): Update to 54.0.

Change-Id: I7f10ec57a1cad585abb08bdc30bd9e2aaafe7624
---
gnu/packages/linux.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 1b7b98f241..71d0b31683 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -7062,7 +7062,7 @@ (define-public ntfsfix/static
(define-public rdma-core
(package
(name "rdma-core")
- (version "48.0")
+ (version "54.0")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/linux-rdma/rdma-core"
@@ -7070,7 +7070,7 @@ (define-public rdma-core
version ".tar.gz"))
(sha256
(base32
- "0h281dw2yph8pzfsr1wblqy6pb8nd9yj1pdf5c62zwc1l9b2fa3q"))))
+ "0q1gd4wrn7sb1l6qj6mqqlf8k4pk865b96cfnbgfxbgfs9q4jjm5"))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f ;no tests
--
2.46.0
L
L
Ludovic Courtès wrote 5 days ago
[PATCH 3/3] gnu: openmpi@5: Update to 5.0.6.
(address . 74546@debbugs.gnu.org)(name . Ludovic Courtès)(address . ludovic.courtes@inria.fr)
278895703cbff85f315c48f3ec776c9321b07ec1.1732643955.git.ludo@gnu.org
From: Ludovic Courtès <ludovic.courtes@inria.fr>

* gnu/packages/mpi.scm (openmpi-5): Update to 5.0.6.

Change-Id: I1aed5f0e76d64a215c4a13f445628ec206e31acf
---
gnu/packages/mpi.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/mpi.scm b/gnu/packages/mpi.scm
index 20497242e5..41e57c3012 100644
--- a/gnu/packages/mpi.scm
+++ b/gnu/packages/mpi.scm
@@ -318,7 +318,7 @@ (define-public openmpi openmpi-4)
(define-public openmpi-5
(package
(inherit openmpi)
- (version "5.0.3")
+ (version "5.0.6")
(source
(origin
(method url-fetch)
@@ -326,7 +326,7 @@ (define-public openmpi-5
(version-major+minor version)
"/downloads/openmpi-" version ".tar.bz2"))
(sha256
- (base32 "02x9xmpggw77mdpikjjx83j6i4v3gkqbncda73lk5axk0vr841cr"))))
+ (base32 "0mw1z4ppnlvxngwd58kl5q26qmvf3bgjkd4r8wjpqis3pky86hdx"))))
(inputs (modify-inputs (package-inputs openmpi)
;; As of Open MPI 5.0.X, PMIx is used to communicate
--
2.46.0
L
L
Ludovic Courtès wrote 13 hours ago
Re: [bug#74546] [PATCH 0/3] Updating Open MPI and its dependencies
(address . 74546-done@debbugs.gnu.org)(name . Efraim Flashner)(address . efraim@flashner.co.il)
87r06rqqwj.fsf@gnu.org
Ludovic Courtès <ludo@gnu.org> skribis:

Toggle quote (4 lines)
> gnu: ucx: Update to 1.17.0.
> gnu: rdma-core: Update to 54.0.
> gnu: openmpi@5: Update to 5.0.6.

Pushed as 15647355e5e7a67a7d4b372cf34b20e3710fe25d following a
discussion with Efraim on IRC.

Ludo’.
Closed
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 74546@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74546
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch