(address . guix-patches@gnu.org)(name . Markku Korkeala)(address . markku.korkeala@iki.fi)
* gnu/packages/python-xyz.scm (python-jsonpath-ng): New variable.
Change-Id: Ie7835850bc137f3bbaea19f01d42b01ba0f5458e
---
gnu/packages/python-xyz.scm | 36 ++++++++++++++++++++++++++++++++++++
1 file changed, 36 insertions(+)
Toggle diff (58 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 3872b511a1..831c1d44bd 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -158,6 +158,7 @@
;;; Copyright © 2024 Peter Kannewitz <petre-vps@posteo.net>
;;; Copyright © 2024 Aaron Covrig <aaron.covrig.us@ieee.org>
;;; Copyright © 2024 Evgeny Pisemsky <mail@pisemsky.site>
+;;; Copyright © 2024 Markku Korkeala <markku.korkeala@iki.fi>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -4682,6 +4683,41 @@ (define-public python-jsonargparse
variables.")
(license license:expat)))
+(define-public python-jsonpath-ng
+ (package
+ (name "python-jsonpath-ng")
+ (version "1.7.0" )
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/h2non/jsonpath-ng")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0z0qm5sgzal0qzml2fmc9h5nim8m3x6sz55gqhcd9c2jrq8jmwmi"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ (list python-ply
+ python-decorator
+ python-six))
+ (native-inputs
+ (list
+ python-oslotest
+ python-pytest
+ python-flake8
+ python-coverage
+ python-pytest-cov
+ python-coveralls
+ python-testscenarios))
+ (home-page "https://github.com/h2non/jsonpath-ng")
+ (synopsis "Python JSONPath Next-Generation")
+ (description "A final implementation of @code{JSONPath} for Python
+that aims to be standard compliant, including arithmetic and binary
+comparison operators, as defined in the original @code{JSONPath}
+proposal.")
+ (license license:asl2.0)))
+
(define-public python-pymarshal
(package
(name "python-pymarshal")
base-commit: 2bda81fadc82aa0aba1da2476192be0cd0c4ed4d
--
2.46.0