[PATCH] Packaged this tool for Guix proper with chnaged to the definition of the package.

  • Done
  • quality assurance status badge
Details
2 participants
  • Navid Afkhami
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Navid Afkhami
Severity
normal

Debbugs page

Navid Afkhami wrote 3 months ago
(address . guix-patches@gnu.org)(name . Navid Afkhami)(address . navid.afkhami@mdc-berlin.de)
4f4ba29ceba204da1c4ffa69fcb85b6a68866ea0.1732627863.git.navid.afkhami@mdc-berlin.de
Change-Id: I181f036f5df65a7e1ec6fc1a6646da22686d5895
---
gnu/packages/cran.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (54 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 599238d0d8..a1e0213565 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -68,12 +68,15 @@ (define-module (gnu packages cran)
#:use-module (gnu packages algebra)
#:use-module (gnu packages autotools)
#:use-module (gnu packages base)
+ #:use-module (gnu packages bash)
#:use-module (gnu packages bioinformatics)
#:use-module (gnu packages c)
+ #:use-module (gnu packages cmake)
#:use-module (gnu packages compression)
#:use-module (gnu packages crypto)
#:use-module (gnu packages curl)
#:use-module (gnu packages databases)
+ #:use-module (gnu packages debian)
#:use-module (gnu packages fontutils)
#:use-module (gnu packages fribidi)
#:use-module (gnu packages gcc)
@@ -39757,6 +39760,29 @@ (define-public r-highlight
chunks.")
(license license:gpl3+)))
+(define-public r-highs
+ (package
+ (name "r-highs")
+ (version "0.1-10")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "highs" version))
+ (sha256
+ (base32 "1vjmzbfydlm434fa1mkwwfcdhmn6sq4ppib26nxfa9zakr7h7q2c"))))
+ (properties `((upstream-name . "highs")))
+ (build-system r-build-system)
+ (inputs (list bash-minimal))
+ (propagated-inputs (list r-checkmate r-pkgconfig r-rcpp))
+ (native-inputs (list cmake-minimal debianutils gfortran))
+ (home-page "https://gitlab.com/roigrp/solver/highs")
+ (synopsis "'HiGHS' Optimization Solver")
+ (description
+ "R interface to @code{HiGHS}, an optimization solver.
+It is designed for solving mixed-integer optimization problems
+with quadratic or linear objectives and linear constraints.")
+ (license license:gpl2+)))
+
(define-public r-clustree
(package
(name "r-clustree")

base-commit: 9b1fb12978482ffb6d37c456343f05609b28b3e8
--
2.43.0
Ricardo Wurmus wrote 3 months ago
(address . 74543-done@debbugs.gnu.org)(name . Navid Afkhami)(address . navid.afkhami@mdc-berlin.de)
874j3uf592.fsf@mdc-berlin.de
Hi,

thanks for the patch. I made a couple of changes. We didn't need
bash-minimal or debianutils as inputs, but did need "which". I also
modified the description and the commit message.

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 74543@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74543
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help