[PATCH] Packaged r-highs for Guix proper.

  • Done
  • quality assurance status badge
Details
2 participants
  • Navid.Afkhami@mdc-berlin.de
  • Navid Afkhami
Owner
unassigned
Submitted by
Navid Afkhami
Severity
normal
N
N
Navid Afkhami wrote on 25 Nov 15:52 +0100
(address . guix-patches@gnu.org)(name . Navid Afkhami)(address . navid.afkhami@mdc-berlin.de)
8b0089cc531812c2822b9a59a10bd54669156bcf.1732546367.git.navid.afkhami@mdc-berlin.de
Modified gnu/packages/cran.scm

Added:

#:use-module (gnu packages bash)
#:use-module (gnu packages cmake)
#:use-module (gnu packages debian)

And made chnages to the definition of the package:

(define-public r-highs
(package
(name "r-highs")
(version "0.1-10")
(source
(origin
(method url-fetch)
(uri (cran-uri "highs" version))
(sha256
(base32 "1vjmzbfydlm434fa1mkwwfcdhmn6sq4ppib26nxfa9zakr7h7q2c"))))
(properties `((upstream-name . "highs")))
(build-system r-build-system)
(inputs (list bash-minimal))
(propagated-inputs (list r-checkmate r-pkgconfig r-rcpp))
(native-inputs (list cmake-minimal debianutils gfortran))
(synopsis "'HiGHS' Optimization Solver")
(description
"R interface to @code{HiGHS}, an optimization solver.
It is designed for solving mixed-integer optimization problems
with quadratic or linear objectives and linear constraints.")
(license license:gpl2+)))

Change-Id: Ibbf2214820e90d9e78a8c78577ec4de4ea1eb411
---
gnu/packages/cran.scm | 3 +++
1 file changed, 3 insertions(+)

Toggle diff (25 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index b2ac3893db..a5273f9e4e 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -68,12 +68,15 @@ (define-module (gnu packages cran)
#:use-module (gnu packages algebra)
#:use-module (gnu packages autotools)
#:use-module (gnu packages base)
+ #:use-module (gnu packages bash)
#:use-module (gnu packages bioinformatics)
#:use-module (gnu packages c)
+ #:use-module (gnu packages cmake)
#:use-module (gnu packages compression)
#:use-module (gnu packages crypto)
#:use-module (gnu packages curl)
#:use-module (gnu packages databases)
+ #:use-module (gnu packages debian)
#:use-module (gnu packages fontutils)
#:use-module (gnu packages fribidi)
#:use-module (gnu packages gcc)

base-commit: 9b1fb12978482ffb6d37c456343f05609b28b3e8
prerequisite-patch-id: e28e9621d28c7af767ea42c2c828d4d6b31359e1
--
2.43.0
N
N
Navid.Afkhami@mdc-berlin.de wrote on 25 Nov 16:25 +0100
Closing this issue
(name . 74528-done@debbugs.gnu.org)(address . 74528-done@debbugs.gnu.org)
c7fabaf6d53d490f89e636a75e709607@mdc-berlin.de
Hi,
I will close this issue as the commit message is wrong.
Attachment: file
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 74528@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74528
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch