[PATCH] gramps: Update to 5.2.3.

  • Done
  • quality assurance status badge
Details
3 participants
  • Guillaume Le Vaillant
  • Julien Lepiller
  • Ludovic Courtès
Owner
unassigned
Submitted by
Julien Lepiller
Severity
normal
J
J
Julien Lepiller wrote on 23 Nov 19:06 +0100
(address . guix-patches@gnu.org)
6440c30fe2ff69ae75c3423fa748aab03f33e430.1732385023.git.julien@lepiller.eu
* gnu/packages/genealogy.scm (gramps): Update to 5.2.3.

Change-Id: Icfd3470989da905d50233564b894887305e9de1e
---
gnu/packages/genealogy.scm | 24 ++++++++++++++++++------
1 file changed, 18 insertions(+), 6 deletions(-)

Toggle diff (74 lines)
diff --git a/gnu/packages/genealogy.scm b/gnu/packages/genealogy.scm
index 36c05fff28..668505a71a 100644
--- a/gnu/packages/genealogy.scm
+++ b/gnu/packages/genealogy.scm
@@ -22,6 +22,7 @@ (define-module (gnu packages genealogy)
#:use-module (guix git-download)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
+ #:use-module (gnu packages base)
#:use-module (gnu packages bash)
#:use-module (gnu packages fonts)
#:use-module (gnu packages freedesktop)
@@ -35,12 +36,13 @@ (define-module (gnu packages genealogy)
#:use-module (gnu packages python)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages sqlite)
- #:use-module (gnu packages version-control))
+ #:use-module (gnu packages version-control)
+ #:use-module (gnu packages xml))
(define-public gramps
(package
(name "gramps")
- (version "5.1.4")
+ (version "5.2.3")
(source
(origin
(method git-fetch)
@@ -49,11 +51,12 @@ (define-public gramps
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "00358nzyw686ypqv45imc5k9frcqnhla0hpx9ynna3iy6iz5006x"))))
+ (base32 "1gzhi5hxpgc6pxs40xsxf67hndjifnfhm89s3ly68c70x83qmwhd"))))
(build-system python-build-system)
(native-inputs
`(("gettext" ,gettext-minimal)
- ("intltool" ,intltool)))
+ ("intltool" ,intltool)
+ ("glibc-utf8-locales" ,glibc-utf8-locales))) ;; for one test
(inputs
(list bash-minimal
cairo
@@ -69,6 +72,8 @@ (define-public gramps
osm-gps-map
pango
python-bsddb3
+ python-jsonschema
+ python-lxml
python-pillow
python-pycairo
python-pygobject
@@ -87,8 +92,15 @@ (define-public gramps
(modify-phases %standard-phases
(add-before 'check 'set-home-for-tests
(lambda _
- (setenv "HOME" (getenv "TMPDIR"))
- #t))
+ (setenv "HOME" (getenv "TMPDIR"))))
+ (add-before 'check 'prepare-tests
+ (lambda _
+ ;; Presence of .git directory is used to determine whether this
+ ;; is a final installation. Without it, tests fail to determine
+ ;; resource path.
+ (mkdir ".git")
+ ;; Test is failing
+ (delete-file "gramps/gen/utils/test/file_test.py")))
(add-before 'wrap 'wrap-with-GI_TYPELIB_PATH
(lambda* (#:key inputs outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out"))

base-commit: 36f516bfcdf64185f5d70c21a908283be22a34fd
--
2.46.0
G
G
Guillaume Le Vaillant wrote on 26 Nov 14:24 +0100
(name . Julien Lepiller)(address . julien@lepiller.eu)(address . 74494@debbugs.gnu.org)
874j3ub01n.fsf@kitej
Julien Lepiller <julien@lepiller.eu> skribis:

Toggle quote (9 lines)
> * gnu/packages/genealogy.scm (gramps): Update to 5.2.3.
>
> [...]
> (native-inputs
> `(("gettext" ,gettext-minimal)
> - ("intltool" ,intltool)))
> + ("intltool" ,intltool)
> + ("glibc-utf8-locales" ,glibc-utf8-locales))) ;; for one test

Hi.
You could remove the labels for native inputs.
Otherwise the patch looks good to me.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCZ0XMBA8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j/EdgEAl1udIzrojQjRAp1S2xUIDAU5D00sjSTTN0UG
Q8KjxqwA/04gDL9O2zvKAWuiI/Jlap8OTD/I4hqkmdc0+yYTQ+5Z
=nj4O
-----END PGP SIGNATURE-----

L
L
Ludovic Courtès wrote 7 days ago
(name . Guillaume Le Vaillant)(address . glv@posteo.net)
871py5nvos.fsf@gnu.org
Hey Julien,

Kind reminder. :-)

Ludo’.

Guillaume Le Vaillant <glv@posteo.net> skribis:

Toggle quote (14 lines)
> Julien Lepiller <julien@lepiller.eu> skribis:
>
>> * gnu/packages/genealogy.scm (gramps): Update to 5.2.3.
>>
>> [...]
>> (native-inputs
>> `(("gettext" ,gettext-minimal)
>> - ("intltool" ,intltool)))
>> + ("intltool" ,intltool)
>> + ("glibc-utf8-locales" ,glibc-utf8-locales))) ;; for one test
>
> Hi.
> You could remove the labels for native inputs.
> Otherwise the patch looks good to me.
J
J
Julien Lepiller wrote 7 days ago
(name . Ludovic Courtès)(address . ludo@gnu.org)
20241218183304.671000b9@lepiller.eu
Pushed to master as 478b9ccea854ec4407643a44d40ee61584fbc73d, thanks!

Le Wed, 18 Dec 2024 11:15:47 +0100,
Ludovic Courtès <ludo@gnu.org> a écrit :

Toggle quote (23 lines)
> Hey Julien,
>
> Kind reminder. :-)
>
> Ludo’.
>
> Guillaume Le Vaillant <glv@posteo.net> skribis:
>
> > Julien Lepiller <julien@lepiller.eu> skribis:
> >
> >> * gnu/packages/genealogy.scm (gramps): Update to 5.2.3.
> >>
> >> [...]
> >> (native-inputs
> >> `(("gettext" ,gettext-minimal)
> >> - ("intltool" ,intltool)))
> >> + ("intltool" ,intltool)
> >> + ("glibc-utf8-locales" ,glibc-utf8-locales))) ;; for one
> >> test
> >
> > Hi.
> > You could remove the labels for native inputs.
> > Otherwise the patch looks good to me.
Closed
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 74494@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74494
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch