[PATCH] gnu: geoclue: Update to 2.7.2.

  • Open
  • quality assurance status badge
Details
2 participants
  • Maxim Cournoyer
  • Sergey Trofimov
Owner
unassigned
Submitted by
Sergey Trofimov
Severity
normal
S
S
Sergey Trofimov wrote on 23 Nov 2024 15:08
(address . guix-patches@gnu.org)(name . Sergey Trofimov)(address . sarg@sarg.org.ru)
4a5f38bd6fd9c4c4a9610067e84675b11120be21.1732370909.git.sarg@sarg.org.ru
* gnu/packages/gnome.scm (geoclue): Update to 2.7.2.
* gnu/packages/patches/geoclue-config.patch: Adjust.
---
gnu/packages/gnome.scm | 6 +-
gnu/packages/patches/geoclue-config.patch | 76 ++++++++++++++++-------
2 files changed, 57 insertions(+), 25 deletions(-)

Toggle diff (119 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index b8accb737d..5fb98ff568 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5760,7 +5760,7 @@ (define-public colord
(define-public geoclue
(package
(name "geoclue")
- (version "2.6.0")
+ (version "2.7.2")
(source
(origin
(method url-fetch)
@@ -5768,7 +5768,7 @@ (define-public geoclue
(string-append "https://gitlab.freedesktop.org/geoclue/geoclue/-/archive/"
version "/geoclue-" version ".tar.bz2"))
(sha256
- (base32 "1854i8lih1jkks5w38xv8k5gs7s8629qjg3cg96ji0ffk35yzjfd"))
+ (base32 "1ljn4k1zlfx0ymmdz8ycfb976vx8r61sx68q854r0xinl124mlh1"))
(patches (search-patches "geoclue-config.patch"))))
(build-system meson-build-system)
(arguments
@@ -5786,7 +5786,7 @@ (define-public geoclue
`(,glib "bin")
glib-networking
json-glib
- libsoup-minimal-2))
+ libsoup-minimal))
(home-page "https://gitlab.freedesktop.org/geoclue/geoclue/-/wikis/home")
(synopsis "Geolocation service")
(description "Geoclue is a D-Bus service that provides location
diff --git a/gnu/packages/patches/geoclue-config.patch b/gnu/packages/patches/geoclue-config.patch
index e4ef6f2d33..fed7782171 100644
--- a/gnu/packages/patches/geoclue-config.patch
+++ b/gnu/packages/patches/geoclue-config.patch
@@ -1,27 +1,59 @@
-Allow the configuration file to be specified via an environment variable.
+From 45e310482350cfab628f359f2b0efebf06fb7c77 Mon Sep 17 00:00:00 2001
+From: Sergey Trofimov <sarg@sarg.org.ru>
+Date: Sat, 23 Nov 2024 14:12:21 +0100
+Subject: [PATCH] Allow the configuration file to be specified via an
+ environment variable.
+
+---
+ src/gclue-config.c | 13 ++++++++++---
+ src/gclue-static-source.c | 2 +-
+ 2 files changed, 11 insertions(+), 4 deletions(-)
diff --git a/src/gclue-config.c b/src/gclue-config.c
-index 7ab2a67..e41f3df 100644
+index acd6009..3045571 100644
--- a/src/gclue-config.c
+++ b/src/gclue-config.c
-@@ -332,6 +332,11 @@ static void
- gclue_config_init (GClueConfig *config)
- {
- GError *error = NULL;
-+ const char *config_file_path;
+@@ -26,8 +26,8 @@
+
+ #include "gclue-config.h"
+
+-#define CONFIG_FILE_PATH SYSCONFDIR "/geoclue/geoclue.conf"
+-#define CONFIG_D_DIRECTORY SYSCONFDIR "/geoclue/conf.d/"
++#define CONFIG_FILE_PATH "/etc/geoclue/geoclue.conf"
++#define CONFIG_D_DIRECTORY "/etc/geoclue/conf.d/"
+
+ /* This class will be responsible for fetching configuration. */
+
+@@ -546,8 +546,15 @@ gclue_config_init (GClueConfig *config)
+ priv->wifi_submit_url = g_strdup (DEFAULT_WIFI_SUBMIT_URL);
+ priv->wifi_submit_nick = g_strdup (DEFAULT_WIFI_SUBMIT_NICK);
+
+- /* Load config file from default path, log all missing parameters */
+ priv->key_file = g_key_file_new ();
+
-+ config_file_path = g_getenv ("GEOCLUE_CONFIG_FILE");
-+ if (!config_file_path)
-+ config_file_path = CONFIG_FILE_PATH;
-
- config->priv = gclue_config_get_instance_private(config);
- config->priv->key_file = g_key_file_new ();
-@@ -341,7 +346,7 @@ gclue_config_init (GClueConfig *config)
- &error);
- if (error != NULL) {
- g_critical ("Failed to load configuration file '%s': %s",
-- CONFIG_FILE_PATH, error->message);
-+ config_file_path, error->message);
- g_error_free (error);
-
- return;
++ char *env_config_file = g_getenv ("GEOCLUE_CONFIG_FILE");
++ if (env_config_file) {
++ load_config_file (config, env_config_file);
++ goto out; // don't load conf.d
++ }
++
++ /* Load config file from default path, log all missing parameters */
+ load_config_file (config, CONFIG_FILE_PATH);
+
+ /*
+diff --git a/src/gclue-static-source.c b/src/gclue-static-source.c
+index 1c35cea..7957797 100644
+--- a/src/gclue-static-source.c
++++ b/src/gclue-static-source.c
+@@ -26,7 +26,7 @@
+ #include "gclue-enum-types.h"
+
+ #define GEO_FILE_NAME "geolocation"
+-#define GEO_FILE_PATH SYSCONFDIR "/" GEO_FILE_NAME
++#define GEO_FILE_PATH "/etc/" GEO_FILE_NAME
+
+ /* Rate limit of geolocation file monitoring.
+ * In milliseconds.
+--
+2.46.0
+

base-commit: 1eead56e2f763e3a1a371f9ea00e89337867d397
--
2.46.0
M
M
Maxim Cournoyer wrote on 24 Nov 2024 13:37
(name . Sergey Trofimov)(address . sarg@sarg.org.ru)
87o724q02m.fsf@gmail.com
Hi,

Sergey Trofimov <sarg@sarg.org.ru> writes:

Toggle quote (36 lines)
> * gnu/packages/gnome.scm (geoclue): Update to 2.7.2.
> * gnu/packages/patches/geoclue-config.patch: Adjust.
> ---
> gnu/packages/gnome.scm | 6 +-
> gnu/packages/patches/geoclue-config.patch | 76 ++++++++++++++++-------
> 2 files changed, 57 insertions(+), 25 deletions(-)
>
> diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
> index b8accb737d..5fb98ff568 100644
> --- a/gnu/packages/gnome.scm
> +++ b/gnu/packages/gnome.scm
> @@ -5760,7 +5760,7 @@ (define-public colord
> (define-public geoclue
> (package
> (name "geoclue")
> - (version "2.6.0")
> + (version "2.7.2")
> (source
> (origin
> (method url-fetch)
> @@ -5768,7 +5768,7 @@ (define-public geoclue
> (string-append "https://gitlab.freedesktop.org/geoclue/geoclue/-/archive/"
> version "/geoclue-" version ".tar.bz2"))
> (sha256
> - (base32 "1854i8lih1jkks5w38xv8k5gs7s8629qjg3cg96ji0ffk35yzjfd"))
> + (base32 "1ljn4k1zlfx0ymmdz8ycfb976vx8r61sx68q854r0xinl124mlh1"))
> (patches (search-patches "geoclue-config.patch"))))
> (build-system meson-build-system)
> (arguments
> @@ -5786,7 +5786,7 @@ (define-public geoclue
> `(,glib "bin")
> glib-networking
> json-glib
> - libsoup-minimal-2))
> + libsoup-minimal))

LGTM so far.

Toggle quote (15 lines)
> (synopsis "Geolocation service")
> (description "Geoclue is a D-Bus service that provides location
> diff --git a/gnu/packages/patches/geoclue-config.patch b/gnu/packages/patches/geoclue-config.patch
> index e4ef6f2d33..fed7782171 100644
> --- a/gnu/packages/patches/geoclue-config.patch
> +++ b/gnu/packages/patches/geoclue-config.patch
> @@ -1,27 +1,59 @@
> -Allow the configuration file to be specified via an environment variable.
> +From 45e310482350cfab628f359f2b0efebf06fb7c77 Mon Sep 17 00:00:00 2001
> +From: Sergey Trofimov <sarg@sarg.org.ru>
> +Date: Sat, 23 Nov 2024 14:12:21 +0100
> +Subject: [PATCH] Allow the configuration file to be specified via an
> + environment variable.

Please drop the git metadata; as it isn't useful (e.g. you are not the
original author of this patch, which this would seem to claim).

I typically only keep the git metadata if it came from the original
author (e.g. I wrote it from scratch and submitted it for inclusion
upstream).

If you use Emacs with magit it has a means to save a commit diff to a
file (W-s on the diff if I recall), in case that helps.

With this small adjustment, feel free to push to master.

--
Thanks,
Maxim
S
S
Sergey Trofimov wrote on 24 Nov 2024 14:50
[PATCH v1] gnu: geoclue: Update to 2.7.2.
(address . 74493@debbugs.gnu.org)(name . Sergey Trofimov)(address . sarg@sarg.org.ru)
40019347f4621bb68afbf6c4ed7883fdce5fdbea.1732456072.git.sarg@sarg.org.ru
* gnu/packages/gnome.scm (geoclue): Update to 2.7.2.
* gnu/packages/patches/geoclue-config.patch: Adjust.
---
gnu/packages/gnome.scm | 6 +-
gnu/packages/patches/geoclue-config.patch | 70 ++++++++++++++++-------
2 files changed, 52 insertions(+), 24 deletions(-)

Toggle diff (118 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index b8accb737d..5fb98ff568 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5760,7 +5760,7 @@ (define-public colord
(define-public geoclue
(package
(name "geoclue")
- (version "2.6.0")
+ (version "2.7.2")
(source
(origin
(method url-fetch)
@@ -5768,7 +5768,7 @@ (define-public geoclue
(string-append "https://gitlab.freedesktop.org/geoclue/geoclue/-/archive/"
version "/geoclue-" version ".tar.bz2"))
(sha256
- (base32 "1854i8lih1jkks5w38xv8k5gs7s8629qjg3cg96ji0ffk35yzjfd"))
+ (base32 "1ljn4k1zlfx0ymmdz8ycfb976vx8r61sx68q854r0xinl124mlh1"))
(patches (search-patches "geoclue-config.patch"))))
(build-system meson-build-system)
(arguments
@@ -5786,7 +5786,7 @@ (define-public geoclue
`(,glib "bin")
glib-networking
json-glib
- libsoup-minimal-2))
+ libsoup-minimal))
(home-page "https://gitlab.freedesktop.org/geoclue/geoclue/-/wikis/home")
(synopsis "Geolocation service")
(description "Geoclue is a D-Bus service that provides location
diff --git a/gnu/packages/patches/geoclue-config.patch b/gnu/packages/patches/geoclue-config.patch
index e4ef6f2d33..8d65dfee5a 100644
--- a/gnu/packages/patches/geoclue-config.patch
+++ b/gnu/packages/patches/geoclue-config.patch
@@ -1,27 +1,55 @@
Allow the configuration file to be specified via an environment variable.
+---
+ src/gclue-config.c | 13 ++++++++++---
+ src/gclue-static-source.c | 2 +-
+ 2 files changed, 11 insertions(+), 4 deletions(-)
+
diff --git a/src/gclue-config.c b/src/gclue-config.c
-index 7ab2a67..e41f3df 100644
+index acd6009..3045571 100644
--- a/src/gclue-config.c
+++ b/src/gclue-config.c
-@@ -332,6 +332,11 @@ static void
- gclue_config_init (GClueConfig *config)
- {
- GError *error = NULL;
-+ const char *config_file_path;
+@@ -26,8 +26,8 @@
+
+ #include "gclue-config.h"
+
+-#define CONFIG_FILE_PATH SYSCONFDIR "/geoclue/geoclue.conf"
+-#define CONFIG_D_DIRECTORY SYSCONFDIR "/geoclue/conf.d/"
++#define CONFIG_FILE_PATH "/etc/geoclue/geoclue.conf"
++#define CONFIG_D_DIRECTORY "/etc/geoclue/conf.d/"
+
+ /* This class will be responsible for fetching configuration. */
+
+@@ -546,8 +546,15 @@ gclue_config_init (GClueConfig *config)
+ priv->wifi_submit_url = g_strdup (DEFAULT_WIFI_SUBMIT_URL);
+ priv->wifi_submit_nick = g_strdup (DEFAULT_WIFI_SUBMIT_NICK);
+
+- /* Load config file from default path, log all missing parameters */
+ priv->key_file = g_key_file_new ();
+
-+ config_file_path = g_getenv ("GEOCLUE_CONFIG_FILE");
-+ if (!config_file_path)
-+ config_file_path = CONFIG_FILE_PATH;
-
- config->priv = gclue_config_get_instance_private(config);
- config->priv->key_file = g_key_file_new ();
-@@ -341,7 +346,7 @@ gclue_config_init (GClueConfig *config)
- &error);
- if (error != NULL) {
- g_critical ("Failed to load configuration file '%s': %s",
-- CONFIG_FILE_PATH, error->message);
-+ config_file_path, error->message);
- g_error_free (error);
-
- return;
++ char *env_config_file = g_getenv ("GEOCLUE_CONFIG_FILE");
++ if (env_config_file) {
++ load_config_file (config, env_config_file);
++ goto out; // don't load conf.d
++ }
++
++ /* Load config file from default path, log all missing parameters */
+ load_config_file (config, CONFIG_FILE_PATH);
+
+ /*
+diff --git a/src/gclue-static-source.c b/src/gclue-static-source.c
+index 1c35cea..7957797 100644
+--- a/src/gclue-static-source.c
++++ b/src/gclue-static-source.c
+@@ -26,7 +26,7 @@
+ #include "gclue-enum-types.h"
+
+ #define GEO_FILE_NAME "geolocation"
+-#define GEO_FILE_PATH SYSCONFDIR "/" GEO_FILE_NAME
++#define GEO_FILE_PATH "/etc/" GEO_FILE_NAME
+
+ /* Rate limit of geolocation file monitoring.
+ * In milliseconds.
+--
+2.46.0
+

base-commit: 36831c2624dffe70307db737c09bae324d6b6b61
prerequisite-patch-id: f9cc903b8048c8c6fde576fbf38ab110263020e3
prerequisite-patch-id: d09c064d38df73405d505b90d222dccfd7be09b9
--
2.46.0
M
M
Maxim Cournoyer wrote on 25 Nov 2024 02:01
(name . Sergey Trofimov)(address . sarg@sarg.org.ru)
87v7wcnn27.fsf@gmail.com
Hello!

Sergey Trofimov <sarg@sarg.org.ru> writes:

Toggle quote (3 lines)
> * gnu/packages/gnome.scm (geoclue): Update to 2.7.2.
> * gnu/packages/patches/geoclue-config.patch: Adjust.

Reviewed-by: Maxim Cournoyer <maxim.cournoyer@gmail>

--
Thanks,
Maxim
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 74493@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74493
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch