[PATCH] gnu: Add the-powder-toy.

  • Done
  • quality assurance status badge
Details
3 participants
  • Efraim Flashner
  • Noé Lopez
  • Ron Nazarov
Owner
unassigned
Submitted by
Ron Nazarov
Severity
normal
R
R
Ron Nazarov wrote on 23 Nov 00:00 +0100
(address . guix-patches@gnu.org)(name . Ron Nazarov)(address . ron@noisytoot.org)
20241122230003.16577-1-ron@noisytoot.org
* gnu/packages/games.scm (the-powder-toy): New variable.

Change-Id: I140d21cab40a522a5079de51980874dae93b4304
---
gnu/packages/games.scm | 71 +++++++++++++++++++++++++++++++++++++++++-
1 file changed, 70 insertions(+), 1 deletion(-)

Toggle diff (91 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 39e3b6dc0b..686a1e48e7 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -63,7 +63,7 @@
;;; Copyright © 2021, 2024 David Pflug <david@pflug.io>
;;; Copyright © 2021, 2022 Felix Gruber <felgru@posteo.net>
;;; Copyright © 2021 Solene Rapenne <solene@perso.pw>
-;;; Copyright © 2021, 2022 Noisytoot <ron@noisytoot.org>
+;;; Copyright © 2021, 2022, 2024 Noisytoot <ron@noisytoot.org>
;;; Copyright © 2021 Petr Hodina <phodina@protonmail.com>
;;; Copyright © 2021, 2022 Brendan Tildesley <mail@brendan.scot>
;;; Copyright © 2021 Christopher Baines <mail@cbaines.net>
@@ -8163,6 +8163,75 @@ (define-public the-butterfly-effect
(license (list license:gpl2 license:public-domain license:expat
license:cc-by-sa3.0 license:gpl3+ license:wtfpl2))))
+(define-public the-powder-toy
+ (package
+ (name "the-powder-toy")
+ (version "98.2.365")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/The-Powder-Toy/The-Powder-Toy")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "06l39w3ggrzn8799dqll606by4f88kjr60r879w8j26csx1py76g"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:configure-flags (list (string-append
+ "-Dworkaround_elusive_bzip2_include_dir="
+ (assoc-ref %build-inputs "bzip2")))
+ ;; No install target
+ #:phases (modify-phases %standard-phases
+ (replace 'install
+ (lambda _
+ (let* ((output (assoc-ref %outputs "out"))
+ (bin (string-append output "/bin"))
+ (share (string-append output "/share"))
+ (apps (string-append share "/applications")))
+ (mkdir-p bin)
+ (mkdir-p apps)
+ (install-file "powder" bin)
+ (install-file "resources/powder.desktop" apps)
+ (for-each (lambda (size)
+ (let ((dir (string-append share
+ "/icons/hicolor/"
+ size
+ "x"
+ size
+ "/apps")))
+ (mkdir-p dir)
+ (copy-file (string-append (assoc-ref
+ %build-inputs
+ "source")
+ "/resources/generated_icons/icon_exe_"
+ size ".png")
+ (string-append dir
+ "/powdertoy-powder.png"))))
+ '("16" "32" "48"))))))))
+ (native-inputs (list pkg-config))
+ (inputs (list luajit
+ jsoncpp
+ libpng
+ zlib
+ fftwf
+ bzip2
+ curl
+ sdl2))
+ (synopsis "Free physics sandbox game")
+ (description
+ "The Powder Toy is a free physics sandbox game, which simulates air
+pressure and velocity, heat, gravity and a countless number of interactions
+between different substances! The game provides you with various building
+materials, liquids, gases and electronic components which can be used to
+construct complex machines, guns, bombs, realistic terrains and almost
+anything else. You can then mine them and watch cool explosions, add
+intricate wirings, play with little stickmen or operate your machine.")
+ (home-page "https://powdertoy.co.uk/")
+ ;; The few files that have a license header specify GPLv3+, but most don't
+ ;; and it's not otherwise specified anywhere.
+ (license license:gpl3)))
+
(define-public pioneer
(package
(name "pioneer")
--
2.46.0
N
N
Noé Lopez wrote on 23 Nov 19:21 +0100
QA review for 74487
(address . 74487@debbugs.gnu.org)(name . Ron Nazarov)(address . ron@noisytoot.org)
87serh3j61.fsf@xn--no-cja.eu
Thanks for the patch! It works well on my end :)

Make sure to end your code comments with dots. Also IIRC quasiquotes in arguments should be replaced with the new g-exp style.

Items marked as checked: Lint warnings, Package builds, Commit messages, New package licenses, New package tests
E
E
Efraim Flashner wrote on 26 Nov 10:16 +0100
Re: [bug#74487] [PATCH] gnu: Add the-powder-toy.
(name . Ron Nazarov)(address . ron@noisytoot.org)(address . 74487-done@debbugs.gnu.org)
Z0WR6e2NxdTzyJCf@3900XT
Thanks for the patch. I followed up with a second patch adding support
for building on riscv64 and powerpc64le using lua-5.2.

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmdFkekACgkQQarn3Mo9
g1HD1hAAtORkSRgoEoLj+ovr6t9d5ed2imDaAbAd445OGtTSajXJeMh1wcXSsmGP
8PsesrxdSKl7qu7KkiyU1T6LWRmwWerTaPxYB1CGFUG0f3fAPGxSqLBLxcU5G8k1
q37yH1HEYLL5JUEfOugrkDAT/GwWeSa7N2bJailt3n/G+KpPJ9zESKPr4RA+WjbF
3UtdoC8Zcd3wRQeevhu7U9yHi/fyXBuzxyqni6ESeRmAWozM+hdMxJs+FbtdTxLc
IM6s87VVx0+82lTnqE6YnLUceM3MLOUcRa7c79ftzHok5/KdkFvZkMptzcIyOZ5l
ZXPimo7fPJAH8frA6e1WXPmoPneHQG98mVvMCOYogkCRwxAIXC1V67d+WPotx0uZ
1zZjeTBFW/zK43txt6hK8WujYe+sR+ceZxbeXy8dADYkH/HasfDXbXOc/FppCNcv
+H1zgnZ9x2ykihnJQvFq8EbEV6HwPPyeWdK4pILlJyzoV8Z0pIDX5x3EU1vc0EpO
AutxMp2nSezrdwwQW64XZ1ugglaI4ed8npYtJ4uzCjYyDJC5bl5gOTJZjcWq+TUq
UMl2N8pc2+rSuAsKUn2nWzLq3ELoHdctiOC0WpXj69p7GaJtqni/hUMWTMqcQG/5
t2WgQ7B5XItrvmKE/7BEZBQEz1YKEwmuxdSYlsRvoZJ2EI5+P3U=
=6bh1
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 74487@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74487
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch