[PATCH] gnu: welle-io: Update to 2.5.

  • Done
  • quality assurance status badge
Details
2 participants
  • Guillaume Le Vaillant
  • Ron Nazarov
Owner
unassigned
Submitted by
Ron Nazarov
Severity
normal
R
R
Ron Nazarov wrote on 22 Nov 23:23 +0100
(address . guix-patches@gnu.org)(name . Ron Nazarov)(address . ron@noisytoot.org)
20241122222402.7071-1-ron@noisytoot.org
* gnu/packages/radio.scm (welle-io): Update to 2.5.
[arguments]: Set #:qtbase to qtbase.
[inputs]: Remove qtbase-5, qtquickcontrols-5, and qtquickcontrols2-5. Replace
qtdeclarative-5 with qtdeclarative, qtcharts-5 with qtcharts, and
qtmultimedia-5 with qtmultimedia. Add qt5compat.

Change-Id: I5d97d3b10d3502e7b6c110b46a18d407f624f9d1
---
gnu/packages/radio.scm | 19 +++++++++----------
1 file changed, 9 insertions(+), 10 deletions(-)

Toggle diff (55 lines)
diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index 2951f17a03..a8d2f2e4e9 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -15,6 +15,7 @@
;;; Copyright © 2023 Sharlatan Hellseher <sharlatanus@gmail.com>
;;; Copyright © 2023 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2024 Andy Tai <atai@atai.org>
+;;; Copyright © 2024 Noisytoot <ron@noisytoot.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2388,7 +2389,7 @@ (define-public dream
(define-public welle-io
(package
(name "welle-io")
- (version "2.4")
+ (version "2.5")
(source
(origin
(method git-fetch)
@@ -2397,7 +2398,7 @@ (define-public welle-io
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0vl98pciw6xzcxyprcb4613rxn0i202f104lmy900jrny0pq4y65"))))
+ (base32 "1c3pcn2apc7sf68scwnij6xr00x25650387gr05z7xw3k36jfadi"))))
(build-system qt-build-system)
(native-inputs
(list pkg-config))
@@ -2410,16 +2411,14 @@ (define-public welle-io
libusb
mpg123
rtl-sdr
- qtbase-5
- qtcharts-5
- qtdeclarative-5
- qtgraphicaleffects
- qtmultimedia-5
- qtquickcontrols-5
- qtquickcontrols2-5
+ qtdeclarative
+ qtcharts
+ qt5compat
+ qtmultimedia
soapysdr))
(arguments
- (list #:configure-flags #~(list "-DAIRSPY=ON"
+ (list #:qtbase qtbase
+ #:configure-flags #~(list "-DAIRSPY=ON"
"-DRTLSDR=ON"
"-DSOAPYSDR=ON")
#:tests? #f))
--
2.46.0
G
G
Guillaume Le Vaillant wrote on 23 Nov 10:19 +0100
(name . Ron Nazarov)(address . ron@noisytoot.org)(address . 74486-done@debbugs.gnu.org)
87y11ai9xv.fsf@kitej
Patch applied as 1eead56e2f763e3a1a371f9ea00e89337867d397.
Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCZ0GeLA8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j/pPgEAiueny7Sr9rlqIC0YKjxjRKSpgJu/Bz88cSlr
SGKtSSsA/izjcCnCaF/JsgMwyFQ35ypV3hjJhJG0KT9e5FP4XYnd
=vq/g
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 74486@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74486
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch