Hi Noé,
Noé Lopez <noe@noé.eu> writes:
Toggle quote (4 lines)
> From: Noé Lopez <noelopez@free.fr>
>
> * gnu/packages/emulators.scm (libretro-beetle-gba): New variable.
Toggle quote (35 lines)
> Change-Id: I3f58972ae9065e7e59b2d9fd5b31d528f7690da2
> ---
> gnu/packages/emulators.scm | 37 +++++++++++++++++++++++++++++++++++++
> 1 file changed, 37 insertions(+)
>
> diff --git a/gnu/packages/emulators.scm b/gnu/packages/emulators.scm
> index 948e588c4c..4d757048a4 100644
> --- a/gnu/packages/emulators.scm
> +++ b/gnu/packages/emulators.scm
> @@ -743,6 +743,43 @@ (define-public mednafen
> ;; Main license is GPL2+. Some parts are BSD-3.
> (license (list license:gpl2+ license:bsd-3))))
>
> +(define-public libretro-beetle-gba
> + ;; There are no releases. Use the latest commit.
> + (let ((commit "6cee80685f735ea6c2373db2622a1f1ee9f39d39")
> + (revision "0"))
> + (package
> + (name "libretro-beetle-gba")
> + ;; Use Mednafen core version as base. Defined in libretro.cpp:73.
> + (version (git-version "0.9.36" revision commit))
> + (source
> + (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/libretro/beetle-gba-libretro")
> + (commit commit)))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32 "14fm2g3hrsvvd57d6m9apzc30ypa4m0m5hk2viq422fm2l9y0xbb"))))
> + (build-system gnu-build-system)
> + (arguments
> + (list
> + #:make-flags #~(list "CC=gcc"
You should prefer to use (string-append "CC=" #$(cc-for-target)), which
gives the right gcc command name when cross-compiling.
Toggle quote (15 lines)
> + (string-append "GIT_VERSION="
> + #$commit)
> + (string-append "DESTDIR="
> + #$output) "prefix=/")
> + ;; No tests.
> + #:tests? #f
> + #:phases #~(modify-phases %standard-phases
> + (delete 'configure))))
> + (home-page "https://github.com/libretro/beetle-gba-libretro")
> + (synopsis "Standalone port of Mednafen GBA to libretro")
> + (description
> + "A standalone port of Mednafen’s GameBoy Advance emulator called
> +Beetle GBA to libretro. Beetle GBA is based on VBA-M, itself a fork of Visual Boy
> +Advance. This is an old fork, and is not recommended over newer alternatives.")
Is the last sentence about VBA-M, or Visual Boy Advance? I'm guessing
the later, but it could confuse so I'd drop it.
I've done the two above modifications myself:
Toggle snippet (35 lines)
modified gnu/packages/emulators.scm
@@ -762,22 +762,18 @@ (define-public libretro-beetle-gba
(base32 "14fm2g3hrsvvd57d6m9apzc30ypa4m0m5hk2viq422fm2l9y0xbb"))))
(build-system gnu-build-system)
(arguments
- (list
- #:make-flags #~(list "CC=gcc"
- (string-append "GIT_VERSION="
- #$commit)
- (string-append "DESTDIR="
- #$output) "prefix=/")
- ;; No tests.
- #:tests? #f
- #:phases #~(modify-phases %standard-phases
- (delete 'configure))))
+ (list #:make-flags #~(list (string-append "CC=" #$(cc-for-target))
+ (string-append "GIT_VERSION=" #$commit)
+ (string-append "prefix=" #$output))
+ #:tests? #f ;no tests
+ #:phases #~(modify-phases %standard-phases
+ (delete 'configure))))
(home-page "https://github.com/libretro/beetle-gba-libretro")
(synopsis "Standalone port of Mednafen GBA to libretro")
(description
- "A standalone port of Mednafen’s GameBoy Advance emulator called
-Beetle GBA to libretro. Beetle GBA is based on VBA-M, itself a fork of Visual Boy
-Advance. This is an old fork, and is not recommended over newer alternatives.")
+ "A standalone port of Mednafen’s GameBoy Advance emulator called Beetle
+GBA to libretro. Beetle GBA is based on VBA-M, itself a fork of Visual Boy
+Advance.")
(license license:gpl2+))))
(define-public mgba
I've also ordered this package before libretro-bsnes-jg (it's nice to
keep packages sorted in alphabetic order, as much as possible).
Pushed as commit f73588e3b0.
--
Thanks,
Maxim