[PATCH] gnu: josm: Update to 19253.

  • Done
  • quality assurance status badge
Details
2 participants
  • Eric Bavier
  • Julien Lepiller
Owner
unassigned
Submitted by
Julien Lepiller
Severity
normal
J
J
Julien Lepiller wrote on 21 Nov 21:21 +0100
(address . guix-patches@gnu.org)
20241121212151.093294b2@lepiller.eu
Hi Guix!

This small patch series updates JOSM. For some reason svn complains the
certificate is expired, but this is not the case. We don't expose
nss-certs in svn-fetch, so it cannot check it anyway. We used a now
deprecated option to disable certificate checking. The first patch
updates this option to the new one, and excludes more failure causes.
The remaining two patches are trivial version updates.
J
J
Julien Lepiller wrote on 21 Nov 21:24 +0100
[PATCH 1/3] guix: svn: Trust server certificate in any case.
(address . 74466@debbugs.gnu.org)
c7cdd2d1a75d0bf20ef23d7c32e9792938647907.1732220622.git.julien@lepiller.eu
* guix/build/svn.scm (svn-fetch): Replace deprecated trast-server-cert
option.

Change-Id: I1b0c55b8ef0e5adf46b90a242b329a12a2574b27
---
guix/build/svn.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

Toggle diff (18 lines)
diff --git a/guix/build/svn.scm b/guix/build/svn.scm
index 875d3c50ca..ea01e7ee65 100644
--- a/guix/build/svn.scm
+++ b/guix/build/svn.scm
@@ -46,7 +46,8 @@ (define* (svn-fetch url revision directory
;; Trust the server certificate. This is OK as we
;; verify the checksum later. This can be removed when
;; ca-certificates package is added.
- "--trust-server-cert" "-r" (number->string revision)
+ "--trust-server-cert-failures=unknown-ca,cn-mismatch,expired,not-yet-valid,other"
+ "-r" (number->string revision)
;; Disable keyword substitutions (keywords are CVS-like strings
;; like "$Date$", "$Id$", and so on) for two reasons: (1) some

base-commit: b2bd56f8fe297ecc5dbd91e5d4f7bd210ff591f1
--
2.46.0
J
J
Julien Lepiller wrote on 21 Nov 21:24 +0100
[PATCH 2/3] gnu: java-jmapviewer: Update to 2.22.
(address . 74466@debbugs.gnu.org)
ff5980dc1ac7e51d6d836a9649f5fc0842d5b625.1732220622.git.julien@lepiller.eu
* gnu/packages/geo.scm (java-jmapviewer): Update to 2.22.

Change-Id: Ifbe2bd718fbf999e7900fb629be634d1a3351931
---
gnu/packages/geo.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index affa50c515..e5c97d86da 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -2121,7 +2121,7 @@ (define-public python-rtree
(define-public java-jmapviewer
(package
(name "java-jmapviewer")
- (version "2.20")
+ (version "2.22")
(source (origin
(method url-fetch)
(uri (string-append "https://josm.openstreetmap.de/osmsvn/"
@@ -2129,7 +2129,7 @@ (define-public java-jmapviewer
version "/JMapViewer-" version "-Source.zip"))
(sha256
(base32
- "02cvmmvvlqpbwn022w3m60xkq4gh4jh9lajs6yjgvjf2hnwxll31"))))
+ "0lq82yyancaswjb9fammjl1jicvdbijjz86bz94dy2v9zm62zq5b"))))
(build-system ant-build-system)
(native-inputs
(list unzip))
--
2.46.0
J
J
Julien Lepiller wrote on 21 Nov 21:24 +0100
[PATCH 3/3] gnu: josm: Update to 19253.
(address . 74466@debbugs.gnu.org)
28f7a66b243830b1928ff92ded610a30f3753033.1732220622.git.julien@lepiller.eu
* gnu/packages/geo.scm (josm): Update to 19253.

Change-Id: I903f78eede31d944643de31bac728445fadd629f
---
gnu/packages/geo.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index e5c97d86da..a9a9e1c945 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -2200,7 +2200,7 @@ (define-public java-opening-hours-parser
(define-public josm
(package
(name "josm")
- (version "19160")
+ (version "19253")
(source (origin
(method svn-fetch)
(uri (svn-reference
@@ -2209,7 +2209,7 @@ (define-public josm
(recursive? #f)))
(sha256
(base32
- "06m6rg9czs7mhkh0byd3c8n8y1gbzqqw2iy7qyn4084al4mdrw2z"))
+ "1k5v591mkh0xkyfj66qmv1mamqsqw347nhax5hlwyg8hgfk7a6xr"))
(file-name (string-append name "-" version "-checkout"))
(modules '((guix build utils)))
(snippet
--
2.46.0
E
E
Eric Bavier wrote on 22 Nov 23:30 +0100
7353D70A-949F-44E0-9BF0-F99A41B291C6@posteo.net
LGTM. Applied and pushed.

On November 21, 2024 8:24:35 PM UTC, Julien Lepiller <julien@lepiller.eu> wrote:
Toggle quote (35 lines)
>* gnu/packages/geo.scm (josm): Update to 19253.
>
>Change-Id: I903f78eede31d944643de31bac728445fadd629f
>---
> gnu/packages/geo.scm | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
>diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
>index e5c97d86da..a9a9e1c945 100644
>--- a/gnu/packages/geo.scm
>+++ b/gnu/packages/geo.scm
>@@ -2200,7 +2200,7 @@ (define-public java-opening-hours-parser
> (define-public josm
> (package
> (name "josm")
>- (version "19160")
>+ (version "19253")
> (source (origin
> (method svn-fetch)
> (uri (svn-reference
>@@ -2209,7 +2209,7 @@ (define-public josm
> (recursive? #f)))
> (sha256
> (base32
>- "06m6rg9czs7mhkh0byd3c8n8y1gbzqqw2iy7qyn4084al4mdrw2z"))
>+ "1k5v591mkh0xkyfj66qmv1mamqsqw347nhax5hlwyg8hgfk7a6xr"))
> (file-name (string-append name "-" version "-checkout"))
> (modules '((guix build utils)))
> (snippet
>--
>2.46.0
>
>
>

--
Sent from my Android device with K-9 Mail. Please excuse my brevity.
Attachment: file
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 74466@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74466
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch