[PATCH] gnu: podman: Update to 5.3.1.

  • Done
  • quality assurance status badge
Details
2 participants
  • Z572
  • Tomas Volf
Owner
unassigned
Submitted by
Tomas Volf
Severity
normal

Debbugs page

Tomas Volf wrote 4 months ago
[PATCH] gnu: podman: Update to 5.3.0.
(address . guix-patches@gnu.org)(name . Tomas Volf)(address . ~@wolfsden.cz)
3922098358477ae0319b8749e00d84bace47f2c6.1732197932.git.~@wolfsden.cz
* gnu/packages/containers.scm (podman): Update to 5.3.0.
<native-inputs>: Use go-1.22.

Change-Id: Iefdaaa3bc8e612c930694dcd7b17d81e6db919ac
---
gnu/packages/containers.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (33 lines)
diff --git a/gnu/packages/containers.scm b/gnu/packages/containers.scm
index adae2f5bfc..3c84987d92 100644
--- a/gnu/packages/containers.scm
+++ b/gnu/packages/containers.scm
@@ -465,7 +465,7 @@ (define-public catatonit
(define-public podman
(package
(name "podman")
- (version "5.2.5")
+ (version "5.3.0")
(source
(origin
(method git-fetch)
@@ -473,7 +473,7 @@ (define-public podman
(url "https://github.com/containers/podman")
(commit (string-append "v" version))))
(sha256
- (base32 "1s0zjfclayqaknc457wy8iqlb9g170a7v3b8rnv59v3fkhkbpa81"))
+ (base32 "1rgg5s1m4i10vqkgs5ka3z7sl9dmnpp8zqbvh4773amqaikjpfxz"))
(file-name (git-file-name name version))))
(build-system gnu-build-system)
(arguments
@@ -554,7 +554,7 @@ (define-public podman
(inputs (list pcre2))) ; Drop once grep on master supports -P
bats
git
- go-1.21
+ go-1.22
go-github-com-go-md2man
mandoc
pkg-config
--
2.46.0
Tomas Volf wrote 4 months ago
[PATCH v2] gnu: podman: Update to 5.3.1.
(address . 74463@debbugs.gnu.org)(name . Tomas Volf)(address . ~@wolfsden.cz)
2c6650d5b0c703ba6fbc28bb89690c784b4c3b65.1732213550.git.~@wolfsden.cz
* gnu/packages/containers.scm (podman): Update to 5.3.1.
<native-inputs>: Use go-1.22.

Change-Id: Ifedb3843e7cead31945deb15f66945940597b05f
---
v2: Update to 5.3.1 instead.

gnu/packages/containers.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (31 lines)
diff --git a/gnu/packages/containers.scm b/gnu/packages/containers.scm
index adae2f5bfc..9a49dd5fd8 100644
--- a/gnu/packages/containers.scm
+++ b/gnu/packages/containers.scm
@@ -465,7 +465,7 @@ (define-public catatonit
(define-public podman
(package
(name "podman")
- (version "5.2.5")
+ (version "5.3.1")
(source
(origin
(method git-fetch)
@@ -473,7 +473,7 @@ (define-public podman
(url "https://github.com/containers/podman")
(commit (string-append "v" version))))
(sha256
- (base32 "1s0zjfclayqaknc457wy8iqlb9g170a7v3b8rnv59v3fkhkbpa81"))
+ (base32 "1315rqsfiwq4i2vvdzb6nkwbvgwimsj7f71ma1svvqhp8kbly04h"))
(file-name (git-file-name name version))))
(build-system gnu-build-system)
(arguments
@@ -554,7 +554,7 @@ (define-public podman
(inputs (list pcre2))) ; Drop once grep on master supports -P
bats
git
- go-1.21
+ go-1.22
go-github-com-go-md2man
mandoc
pkg-config
--
2.46.0
Tomas Volf wrote 4 months ago
control message for bug #74463
(address . control@debbugs.gnu.org)
416512ad4d20e984461ec724670ba308@wolfsden.cz
retitle 74463 [PATCH] gnu: podman: Update to 5.3.1.
quit
Z572 wrote 4 months ago
Re: [bug#74463] [PATCH v2] gnu: podman: Update to 5.3.1.
(name . Tomas Volf)(address . ~@wolfsden.cz)(address . 74463-done@debbugs.gnu.org)
871pz15t4f.fsf@iscas.ac.cn
Tomas Volf <~@wolfsden.cz> writes:

Toggle quote (3 lines)
> * gnu/packages/containers.scm (podman): Update to 5.3.1.
> <native-inputs>: Use go-1.22.

[native-inputs]: Use go-1.22.

Toggle quote (40 lines)
>
> Change-Id: Ifedb3843e7cead31945deb15f66945940597b05f
> ---
> v2: Update to 5.3.1 instead.
>
> gnu/packages/containers.scm | 6 +++---
> 1 file changed, 3 insertions(+), 3 deletions(-)
>
> diff --git a/gnu/packages/containers.scm b/gnu/packages/containers.scm
> index adae2f5bfc..9a49dd5fd8 100644
> --- a/gnu/packages/containers.scm
> +++ b/gnu/packages/containers.scm
> @@ -465,7 +465,7 @@ (define-public catatonit
> (define-public podman
> (package
> (name "podman")
> - (version "5.2.5")
> + (version "5.3.1")
> (source
> (origin
> (method git-fetch)
> @@ -473,7 +473,7 @@ (define-public podman
> (url "https://github.com/containers/podman")
> (commit (string-append "v" version))))
> (sha256
> - (base32 "1s0zjfclayqaknc457wy8iqlb9g170a7v3b8rnv59v3fkhkbpa81"))
> + (base32 "1315rqsfiwq4i2vvdzb6nkwbvgwimsj7f71ma1svvqhp8kbly04h"))
> (file-name (git-file-name name version))))
> (build-system gnu-build-system)
> (arguments
> @@ -554,7 +554,7 @@ (define-public podman
> (inputs (list pcre2))) ; Drop once grep on master supports -P
> bats
> git
> - go-1.21
> + go-1.22
> go-github-com-go-md2man
> mandoc
> pkg-config

pushed, closing.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEfr6klGDOXiwIdX/bO1qpk+Gi3/AFAmdCflAACgkQO1qpk+Gi
3/A2khAAjWVFBr86NTRWv/JWZ9ntVKY1UoCHb54XlhjL1+QZ9gOWT56Y/xo0UtDQ
zp7YQrzgJeAIB4zvhPnJ0C6Qk+Ove1b+KjOL8eMR/I5K/cE1sI32IkBRmS8ifPgM
Tj3s74pY7pXbWuvaVCJsssXXP+iRzfIva2tCnPXeAcpiYPswLwesmF+vRyiheMG+
WD1sKKmYaiucDYwwbFTZAbMRoG6SGkrOrfst2jATngEQLdRoaNV37n82ttl6oWq0
B3A2AxKO+9q/SgxoEoakTidDiUGGChh+m7xCxpPbvjMRnL7U9omxIigr/drDV2lE
J6OvghnplHqgcXzeuV5eIxV2z4st8WRXvYvUA2ekxB9q4rSgeVk5kdSZo6o4B+vW
Vf1bv/OrExh0Qe2ijy8kARLiDAnwRoF2lOOhJJZW3f/IyqR/xJlMXJbH8sQR9kBl
4DhDN+GIG4WlcS8WqQPzXgfsKvZxzpRk6SjfxYry4hy2x948UVam9PIS0OY4tYO3
uJ+prP4M96/qYfueVWSrr85QZnn/1jdDFPomUqHzhVvQABqwptYmdjJs5ftzfb0T
+B5asTUgnRALxBemUknPoIQb/MDBll1l1Nc7CwZeO0cZH7AtIfAoUr5EobwcH54Y
Vl1hpRl7mJDFA6EAMNdQHqpQdPTw6mU5KMJVTo0UYa94ghxCqG0=
=klNx
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 74463@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74463
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help