[PATCH] gnu: Add python-shxparser.

  • Open
  • quality assurance status badge
Details
One participant
  • Evgeny Pisemsky
Owner
unassigned
Submitted by
Evgeny Pisemsky
Severity
normal
E
E
Evgeny Pisemsky wrote 7 days ago
(address . guix-patches@gnu.org)
87mshs26ff.fsf@pisemsky.site
From 6298330046d3685321cb88273da059a3684cb7c8 Mon Sep 17 00:00:00 2001
Message-ID: <6298330046d3685321cb88273da059a3684cb7c8.1732186805.git.mail@pisemsky.site>
From: Evgeny Pisemsky <mail@pisemsky.site>
Date: Thu, 21 Nov 2024 13:55:13 +0300
Subject: [PATCH] gnu: Add python-shxparser.

* gnu/packages/python-xyz.scm (python-shxparser): New variable.

Change-Id: Iaa4bdc216f0e06595237d6fb8e5ee138797605bc
---
gnu/packages/python-xyz.scm | 23 +++++++++++++++++++++--
1 file changed, 21 insertions(+), 2 deletions(-)

Toggle diff (52 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9a42072cee..5014353e6f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -116,7 +116,7 @@
;;; Copyright © 2021 Greg Hogan <code@greghogan.com>
;;; Copyright © 2022, 2023 John Kehayias <john.kehayias@protonmail.com>
;;; Copyright © 2022 Aleksandr Vityazev <avityazev@posteo.org>
-;;; Copyright © 2022 Evgeny Pisemsky <mail@pisemsky.site>
+;;; Copyright © 2022, 2024 Evgeny Pisemsky <mail@pisemsky.site>
;;; Copyright © 2022 drozdov <drozdov@portalenergy.tech>
;;; Copyright © 2022 Peter Polidoro <peter@polidoro.io>
;;; Copyright © 2022, 2023 Wamm K. D. <jaft.r@outlook.com>
@@ -157,7 +157,6 @@
;;; Copyright © 2024 Rick Huijzer <ikbenrickhuyzer@gmail.com>
;;; Copyright © 2024 Peter Kannewitz <petre-vps@posteo.net>
;;; Copyright © 2024 Aaron Covrig <aaron.covrig.us@ieee.org>
-;;; Copyright © 2024 Evgeny Pisemsky <mail@pisemsky.site>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -32636,6 +32635,26 @@ (define-public python-dparse
(description "This package provides a parser for Python dependency files.")
(license license:expat)))
+(define-public python-shxparser
+ (package
+ (name "python-shxparser")
+ (version "0.0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "shxparser" version))
+ (sha256
+ (base32 "0w7j5ywskandp91v74966pw1pvq9d5zrx5gkjcn84xi8wsyf8hc5"))))
+ (build-system pyproject-build-system)
+ (native-inputs (list python-svgelements))
+ (home-page "https://github.com/tatarize/shxparser")
+ (synopsis "SHX line font parser")
+ (description
+ "This is a pure python parser for SHX Hershey font files that are an
+AutoCad format which can encode single line fonts. This format is
+used for many CNC and laser operations.")
+ (license license:expat)))
+
(define-public python-dpath
(package
(name "python-dpath")

base-commit: 603bee5f3b670b06d6594e63066dc0c6d836c921
--
2.46.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 74458@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74458
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch