[PATCH 0/2] Add C/C++ team.

  • Open
  • quality assurance status badge
Details
3 participants
  • Greg Hogan
  • Ludovic Courtès
  • Z572
Owner
unassigned
Submitted by
Greg Hogan
Severity
normal
G
G
Greg Hogan wrote on 19 Nov 2024 22:22
(address . guix-patches@gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
cover.1732050358.git.code@greghogan.com
Let's build a C/C++ team. All are welcome to join!

The dual-language "C/C++" is used as descriptor and the simpler "c++"
as the team name for use with the etc/teams.scm commands.

Greg Hogan (2):
teams: Add C/C++ team.
teams: Add entry for Greg Hogan.

etc/teams.scm | 18 ++++++++++++++++++
1 file changed, 18 insertions(+)


base-commit: 20ecc8b5a995dd782891dcfe213dd3c67295fe30
--
2.46.0
G
G
Greg Hogan wrote on 19 Nov 2024 22:33
[PATCH 1/2] teams: Add C/C++ team.
(address . 74440@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
15c2f60108d785c346a72263e54c579c6f1e2a46.1732050358.git.code@greghogan.com
* etc/teams.scm (c++): New team.
---
etc/teams.scm | 14 ++++++++++++++
1 file changed, 14 insertions(+)

Toggle diff (27 lines)
diff --git a/etc/teams.scm b/etc/teams.scm
index ddd790a03f..2e2f938230 100755
--- a/etc/teams.scm
+++ b/etc/teams.scm
@@ -609,6 +609,20 @@ (define-team zig
"guix/build/zig-build-system.scm"
"guix/build-system/zig.scm")))
+(define-team c++
+ (team 'c++
+ #:name "C/C++ team"
+ #:description
+ "C and C++ compilers, libraries, tools, and programs"
+ #:scope (list "gnu/packages/c.scm"
+ "gnu/packages/cpp.scm"
+ "gnu/packages/llvm.scm"
+ "gnu/packages/llvm-meta.scm"
+ "gnu/packages/ninja.scm"
+ "gnu/packages/valgrind.scm"
+ "gnu/build/cmake-build-system.scm"
+ "gnu/build-system/cmake.scm")))
+
(define-member (person "Eric Bavier"
"bavier@posteo.net")
--
2.46.0
G
G
Greg Hogan wrote on 19 Nov 2024 22:33
[PATCH 2/2] teams: Add entry for Greg Hogan.
(address . 74440@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
7855d4aa616937d945a75fdb2b0c991a02537b98.1732050358.git.code@greghogan.com
* etc/teams.scm ("Greg Hogan"): New member.
---
etc/teams.scm | 4 ++++
1 file changed, 4 insertions(+)

Toggle diff (17 lines)
diff --git a/etc/teams.scm b/etc/teams.scm
index 2e2f938230..f1a5f3570c 100755
--- a/etc/teams.scm
+++ b/etc/teams.scm
@@ -793,6 +793,10 @@ (define-member (person "André Batista"
"nandre@riseup.net")
mozilla)
+(define-member (person "Greg Hogan"
+ "code@greghogan.com")
+ c++)
+
(define (find-team name)
(or (hash-ref %teams (string->symbol name))
--
2.46.0
Z
Re: [bug#74440] [PATCH 0/2] Add C/C++ team.
(name . Greg Hogan)(address . code@greghogan.com)(address . 74440@debbugs.gnu.org)
87wmgt4d9d.fsf@iscas.ac.cn
Greg Hogan <code@greghogan.com> writes:

Toggle quote (15 lines)
> Let's build a C/C++ team. All are welcome to join!
>
> The dual-language "C/C++" is used as descriptor and the simpler "c++"
> as the team name for use with the etc/teams.scm commands.
>
> Greg Hogan (2):
> teams: Add C/C++ team.
> teams: Add entry for Greg Hogan.
>
> etc/teams.scm | 18 ++++++++++++++++++
> 1 file changed, 18 insertions(+)
>
>
> base-commit: 20ecc8b5a995dd782891dcfe213dd3c67295fe30

I think you still need to discuss it on guix-devel


One or more people may propose the creation of a new team by reaching
out to the community by email at <guix-devel@gnu.org>, clarifying the
intended scope and purpose. When consensus is reached on the creation
of this team, someone with commit access formalizes its creation by
adding it and its initial members to ‘etc/teams.scm’.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEfr6klGDOXiwIdX/bO1qpk+Gi3/AFAmdChN4ACgkQO1qpk+Gi
3/AGyRAArMcLk7S76iADuxzwowDJkCeyXylTqVSaD19GfMHPSKG2UY/pU+uW0Ekk
M4z0WNFqSG5QPtmFIuPsiodz9zDkAuVXdXo+EIz2UlPafA0MTkSPjxMe8s9iV3lO
ioUjEnDv6vSLsfGgtVuRVBTNtfMCOameCFHIKyZVTzTzW+JHOMoyaiw8qaDh7AWO
oahLvJ18I1ZtzhhRbc0pqsl+tqvf2a9YkKECi1hwASe838X+xmENucGoh0FPKz96
ydtYb6YV8L1ZG2XEyOR+EyOUiP1ST8SxgOBmVU6exkFlkNdjdSXfQLqzA30/HXiH
nYXJOp14QQL2YZawfNIitcZ00rrsy2hITzGJ+BirpORDwFamTQ0CcXOEP2MaUJoB
+oCPK67P5xW67un6zhuUiKj517W6AkJMyMr/mDW+0ibCZ67ztqzcmJqtteWYN4EE
/Le3hgKbtf2MX7GcYnekC0FHr9eBUlvzhlxKLrGw5IR7lkghhb9XBLhPxbFNmNzm
0TJvYyg+cE2tBKSgmTU1dBS1l9O5URTfWW9ub+iYcDkc17zDZpvmSOselhJC9u6H
N8GET9uWuqB+Io6b9mmKjHbEvuxoMq9Bg97pWsomSmHzF9ylIEOfYcBwZrhHNRNp
MFNvKZyGes3f/05fw/l9fLDnKiVIaghhHe3Wuus0KuEepbRjc0g=
=mQNW
-----END PGP SIGNATURE-----

G
G
Greg Hogan wrote on 25 Nov 2024 14:45
(name . Z572)(address . zhengjunjie@iscas.ac.cn)(address . 74440@debbugs.gnu.org)
CA+3U0Zn6iFoFQ8JO4C+=yjp0ZfQCSaJeRsk93KTtMy9m-=wQZg@mail.gmail.com
On Sat, Nov 23, 2024 at 8:44?PM Z572 <zhengjunjie@iscas.ac.cn> wrote:
Toggle quote (28 lines)
>
> Greg Hogan <code@greghogan.com> writes:
>
> > Let's build a C/C++ team. All are welcome to join!
> >
> > The dual-language "C/C++" is used as descriptor and the simpler "c++"
> > as the team name for use with the etc/teams.scm commands.
> >
> > Greg Hogan (2):
> > teams: Add C/C++ team.
> > teams: Add entry for Greg Hogan.
> >
> > etc/teams.scm | 18 ++++++++++++++++++
> > 1 file changed, 18 insertions(+)
> >
> >
> > base-commit: 20ecc8b5a995dd782891dcfe213dd3c67295fe30
>
> I think you still need to discuss it on guix-devel
>
> see https://guix.gnu.org/manual/devel/en/html_node/Teams.html
>
> One or more people may propose the creation of a new team by reaching
> out to the community by email at <guix-devel@gnu.org>, clarifying the
> intended scope and purpose. When consensus is reached on the creation
> of this team, someone with commit access formalizes its creation by
> adding it and its initial members to ‘etc/teams.scm’.

Ah, yes, thank you! Got ahead of myself here.
L
L
Ludovic Courtès wrote on 19 Jan 00:26 +0100
(name . Greg Hogan)(address . code@greghogan.com)
875xmbsny8.fsf@gnu.org
Hi Greg,

Greg Hogan <code@greghogan.com> skribis:

Toggle quote (2 lines)
> On Sat, Nov 23, 2024 at 8:44?PM Z572 <zhengjunjie@iscas.ac.cn> wrote:

[...]

Toggle quote (12 lines)
>> I think you still need to discuss it on guix-devel
>>
>> see https://guix.gnu.org/manual/devel/en/html_node/Teams.html
>>
>> One or more people may propose the creation of a new team by reaching
>> out to the community by email at <guix-devel@gnu.org>, clarifying the
>> intended scope and purpose. When consensus is reached on the creation
>> of this team, someone with commit access formalizes its creation by
>> adding it and its initial members to ‘etc/teams.scm’.
>
> Ah, yes, thank you! Got ahead of myself here.

I think there was consensus on the team on guix-devel, with comments
regarding its scope. Perhaps you can go ahead and create the new team?

Thanks,
Ludo’.
L
L
Ludovic Courtès wrote 7 hours ago
(name . Greg Hogan)(address . code@greghogan.com)
87bjvbrv8n.fsf@gnu.org
Hello,

Here’s a kind reminder. :-)

Ludo’.

Ludovic Courtès <ludo@gnu.org> skribis:

Toggle quote (25 lines)
> Hi Greg,
>
> Greg Hogan <code@greghogan.com> skribis:
>
>> On Sat, Nov 23, 2024 at 8:44?PM Z572 <zhengjunjie@iscas.ac.cn> wrote:
>
> [...]
>
>>> I think you still need to discuss it on guix-devel
>>>
>>> see https://guix.gnu.org/manual/devel/en/html_node/Teams.html
>>>
>>> One or more people may propose the creation of a new team by reaching
>>> out to the community by email at <guix-devel@gnu.org>, clarifying the
>>> intended scope and purpose. When consensus is reached on the creation
>>> of this team, someone with commit access formalizes its creation by
>>> adding it and its initial members to ‘etc/teams.scm’.
>>
>> Ah, yes, thank you! Got ahead of myself here.
>
> I think there was consensus on the team on guix-devel, with comments
> regarding its scope. Perhaps you can go ahead and create the new team?
>
> Thanks,
> Ludo’.
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 74440@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74440
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch