[PATCH 0/2] Add C/C++ team.

  • Open
  • quality assurance status badge
Details
One participant
  • Greg Hogan
Owner
unassigned
Submitted by
Greg Hogan
Severity
normal
G
G
Greg Hogan wrote 34 hours ago
(address . guix-patches@gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
cover.1732050358.git.code@greghogan.com
Let's build a C/C++ team. All are welcome to join!

The dual-language "C/C++" is used as descriptor and the simpler "c++"
as the team name for use with the etc/teams.scm commands.

Greg Hogan (2):
teams: Add C/C++ team.
teams: Add entry for Greg Hogan.

etc/teams.scm | 18 ++++++++++++++++++
1 file changed, 18 insertions(+)


base-commit: 20ecc8b5a995dd782891dcfe213dd3c67295fe30
--
2.46.0
G
G
Greg Hogan wrote 34 hours ago
[PATCH 1/2] teams: Add C/C++ team.
(address . 74440@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
15c2f60108d785c346a72263e54c579c6f1e2a46.1732050358.git.code@greghogan.com
* etc/teams.scm (c++): New team.
---
etc/teams.scm | 14 ++++++++++++++
1 file changed, 14 insertions(+)

Toggle diff (27 lines)
diff --git a/etc/teams.scm b/etc/teams.scm
index ddd790a03f..2e2f938230 100755
--- a/etc/teams.scm
+++ b/etc/teams.scm
@@ -609,6 +609,20 @@ (define-team zig
"guix/build/zig-build-system.scm"
"guix/build-system/zig.scm")))
+(define-team c++
+ (team 'c++
+ #:name "C/C++ team"
+ #:description
+ "C and C++ compilers, libraries, tools, and programs"
+ #:scope (list "gnu/packages/c.scm"
+ "gnu/packages/cpp.scm"
+ "gnu/packages/llvm.scm"
+ "gnu/packages/llvm-meta.scm"
+ "gnu/packages/ninja.scm"
+ "gnu/packages/valgrind.scm"
+ "gnu/build/cmake-build-system.scm"
+ "gnu/build-system/cmake.scm")))
+
(define-member (person "Eric Bavier"
"bavier@posteo.net")
--
2.46.0
G
G
Greg Hogan wrote 34 hours ago
[PATCH 2/2] teams: Add entry for Greg Hogan.
(address . 74440@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
7855d4aa616937d945a75fdb2b0c991a02537b98.1732050358.git.code@greghogan.com
* etc/teams.scm ("Greg Hogan"): New member.
---
etc/teams.scm | 4 ++++
1 file changed, 4 insertions(+)

Toggle diff (17 lines)
diff --git a/etc/teams.scm b/etc/teams.scm
index 2e2f938230..f1a5f3570c 100755
--- a/etc/teams.scm
+++ b/etc/teams.scm
@@ -793,6 +793,10 @@ (define-member (person "André Batista"
"nandre@riseup.net")
mozilla)
+(define-member (person "Greg Hogan"
+ "code@greghogan.com")
+ c++)
+
(define (find-team name)
(or (hash-ref %teams (string->symbol name))
--
2.46.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 74440@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74440
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch