[PATCH 0/2] Respect --cores build argument.

  • Done
  • quality assurance status badge
Details
2 participants
  • Nicolas Graves
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Nicolas Graves
Severity
normal
N
N
Nicolas Graves wrote 41 hours ago
(address . guix-patches@gnu.org)(name . Nicolas Graves)(address . ngraves@ngraves.fr)
20241119141244.13904-1-ngraves@ngraves.fr
This commit ensures that a user-provided --cores argument to guix
build is respected.

Nicolas Graves (2):
gnu: python-botocore: Respect --cores build argument.
gnu: python-boto3: Respect --cores build argument.

gnu/packages/python-xyz.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

--
2.46.0
N
N
Nicolas Graves wrote 41 hours ago
[PATCH 1/2] gnu: python-botocore: Respect --cores build argument.
(address . 74436@debbugs.gnu.org)(name . Nicolas Graves)(address . ngraves@ngraves.fr)
20241119142158.15651-1-ngraves@ngraves.fr
This commit ensures that a user-provided --cores argument to guix
build is respected.

* gnu/packages/python-xyz.scm (python-botocore)[arguments]
<#:test-flags>: Replace "auto" numprocesses by parallel-job-count.
---
gnu/packages/python-xyz.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 576e0e626f..6394999b78 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -19340,7 +19340,7 @@ (define-public python-botocore
(arguments
(list
#:test-flags
- #~(list "--numprocesses" "auto"
+ #~(list "--numprocesses" (number->string (parallel-job-count))
;; It strugles to find 'botocore'.
"--ignore" "tests/functional/leak/test_resource_leaks.py"
;; Tests require networking.
--
2.46.0
N
N
Nicolas Graves wrote 41 hours ago
[PATCH 2/2] gnu: python-boto3: Respect --cores build argument.
(address . 74436@debbugs.gnu.org)(name . Nicolas Graves)(address . ngraves@ngraves.fr)
20241119142158.15651-2-ngraves@ngraves.fr
This commit ensures that a user-provided --cores argument to guix
build is respected.

* gnu/packages/python-xyz.scm (python-boto3)[arguments]
<#:test-flags>: Replace "auto" numprocesses by parallel-job-count.
---
gnu/packages/python-xyz.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 6394999b78..1439c278bc 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -19379,7 +19379,7 @@ (define-public python-boto3
(arguments
(list
#:test-flags
- #~(list "--numprocesses" "auto"
+ #~(list "--numprocesses" (number->string (parallel-job-count))
;; Integration tests are trying to connect to AWS.
"--ignore" "tests/integration")))
(native-inputs
--
2.46.0
S
S
Sharlatan Hellseher wrote 39 hours ago
Nicolas Graves <ngraves@ngraves.fr>
(address . 74436@debbugs.gnu.org)
871pz7jldk.fsf@gmail.com
Hi Nicolas,

I see the regression in CI as well. Thanks for the patches I'll apply
them.

--
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmc8rgcACgkQdtcnv/Ys
0rVs3Q/9EdJzp3Lz1cy1wea2GO4hMjUHAqE0xpQPJq0LtYHtfofr8e3bySZXIsiV
HiO95ruegaD0PFA9vKDlNbiZ438k1636xAFrWEQYfDWVejolHbwTdq/Wlo0Qqn8t
agh5NQJGccN4bYKUARKUZbLOLMJlVCGYOlYZdE4YBuCfurCH+WOk38SGpNR06Vti
jzLzJr8MJ2q2JfsnuJ0EI7JzjU8G0wu5ul1mltUo/2+/kz6UcB79e/V19SH1yCID
47ntTnjirULAJrPSv90hN3kZ6dTUKLjFwEt+93MODcQrMY5Z9/hc9QqZKL4rRnIF
gBKR7GxbJrkpJDBuDdNKDsrU8VpB5t7hRzTf/3iMrzY6AT9gGGgZN1I14XXDjIE7
RV6G+FuYU+wyKx77J8+NGjtmzhkYPt/VRNTQzuYnAvKzgFZCg/OxIJW4uB4g2aS2
QpT8XFBlWtyI+WD6KGLVH9Ewh0GRg9dy4dfvCmizqer8EJPjD5jx4Yvv+oHJ/T/m
1judBhjQSVgT8inyyph6pl7xFX2hF5keXgQrhYtWQLC2p/2UlX3UpH4YwlyyXGmB
2wK7BgfC7TMCyTor46U/IrhNDhUnOdR+Mr0XT9RF+Z5anOL0noL/qkCbvE43fCWH
By5/56J5RYVcfGo4IK/mqcltBJmkIb7HM64ttb0XUxVE3rJQhds=
=V/FH
-----END PGP SIGNATURE-----

S
S
Sharlatan Hellseher wrote 35 hours ago
[PATCH 0/2] Respect --cores build argument.
(address . 74436-done@debbugs.gnu.org)
87y11fhuv9.fsf@gmail.com
Hi,

Pushed as 20ecc8b5a995dd782891dcfe213dd3c67295fe30, and
3f6691b77bccc13c5038232c77f7f1bb780e1de5 to master.

--
Thanks,
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmc86noACgkQdtcnv/Ys
0rXHMQ//ZNbvVEPKfpMgSap1yqBSqHnZ2GGqrYxSfG+V9wVdaT1rCrukr5omMV7A
5hd9nWiN+L4y5zqfGXPA/QL/nJRzXpK/KbtroXY2qE5KRu+wvrxfbnAzKDs6pwm+
r7fvc3WosfgVt8kCOgCLcwqhrnJdoslDKeL+7ufdFmSK+cpUmhCMOMShdOOlhte1
juPI/IaGkKCefVRpB+mr7kyw6SCVH2KxPc6HktJxO4JeLmSva/gbgXN7PvyN4Lob
aZbfgDxg0n4B2yauVGOAx8q0RXLHMS3yvGNCmiQDfsxpa1IubkI5AAEN9euv0WMa
vqpOuQ2EWopxAevDpIQIASMGrVe/IGSKtmvHL7Av43uNj+mUzwl/0mcZKf1YSWW2
AM7xAvLRlu2EK3/wAwkhp7Mc6pHOm6JGc4Yqy3NUEo1V7EIaUpSrVxyk3Nc0t/gX
CYjCZTDNotlc8Fl2Mjg4H61BlZ5Aw9lkFX8lHOEOYeenUasJiEd4DwGHrJhO/dGJ
6dlppNd4pB8HKMKDYiZnUAEigCV9eNtAp8DAYLW9bUy7LY01SWZIdhCWqh5zyWzK
g5hVuendf+NPkoNogEBbFqznTLC4xIFLHBvn1enpc8koQhhbDShifQTmMr97/hWF
wA9J+Dducf6z/bDiv94r+upX5RGYpLyMkzbZq2j69JbEu+AFvVI=
=m0yW
-----END PGP SIGNATURE-----

Closed
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 74436@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74436
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch