[PATCH] gnu: petsc: Remove arch version from uname output.

  • Done
  • quality assurance status badge
Details
2 participants
  • Lars Bilke
  • Ludovic Courtès
Owner
unassigned
Submitted by
Lars Bilke
Severity
normal

Debbugs page

Lars Bilke wrote 4 months ago
(address . guix-patches@gnu.org)(name . Lars Bilke)(address . lars.bilke@ufz.de)
f4cf3dc4ae8a771480b240557c66b3e05c7d4dbb.1731932191.git.lars.bilke@ufz.de
Enables reproducible building on machines with have a different
arch-suffix in uname output, e.g.:

Machine·characteristics:·Linux-x.x.x-arch1-1-x86_64-with-glibc2.39

vs.

Machine·characteristics:·Linux-x.x.x-arch2-1-x86_64-with-glibc2.39

Will become

Machine·characteristics:·Linux-x.x.x-archx-x-x86_64-with-glibc2.39

Change-Id: Icc37a298c0c2d16e96f2c8eaf5aa4781cc4e5ac4
---
gnu/packages/maths.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (19 lines)
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 62b4f63ac9..d76937265d 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -3421,8 +3421,8 @@ (define-public petsc
(substitute* (find-files "." "^petsc(conf|machineinfo).h$")
;; Prevent build directory from leaking into compiled code
(((getcwd)) out)
- (("Machine characteristics: Linux-[0-9]+\\.[0-9]+\\.[0-9]+")
- "Machine characteristics: Linux-x.x.x"))
+ (("Machine characteristics: Linux-[0-9]+\\.[0-9]+\\.[0-9]+-arch[0-9]+-[0-9]+")
+ "Machine characteristics: Linux-x.x.x-archx-x"))
(substitute* (find-files "." "petscvariables")
;; Do not expose build machine characteristics, set to defaults.
(("MAKE_NP = [[:digit:]]+") "MAKE_NP = 2")

base-commit: 23cbbe6860782c5d4a0ba599ea1cda0642e91661
--
2.44.0
Lars Bilke wrote 4 months ago
[PATCH v2 1/2] gnu: petsc: Remove arch version from uname output.
(address . 74416@debbugs.gnu.org)(name . Lars Bilke)(address . lars.bilke@ufz.de)
f4cf3dc4ae8a771480b240557c66b3e05c7d4dbb.1732025886.git.lars.bilke@ufz.de
Enables reproducible building on machines with have a different
arch-suffix in uname output, e.g.:

Machine·characteristics:·Linux-x.x.x-arch1-1-x86_64-with-glibc2.39

vs.

Machine·characteristics:·Linux-x.x.x-arch2-1-x86_64-with-glibc2.39

Will become

Machine·characteristics:·Linux-x.x.x-archx-x-x86_64-with-glibc2.39

Change-Id: Icc37a298c0c2d16e96f2c8eaf5aa4781cc4e5ac4
---
gnu/packages/maths.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (19 lines)
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 62b4f63ac9..d76937265d 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -3421,8 +3421,8 @@ (define-public petsc
(substitute* (find-files "." "^petsc(conf|machineinfo).h$")
;; Prevent build directory from leaking into compiled code
(((getcwd)) out)
- (("Machine characteristics: Linux-[0-9]+\\.[0-9]+\\.[0-9]+")
- "Machine characteristics: Linux-x.x.x"))
+ (("Machine characteristics: Linux-[0-9]+\\.[0-9]+\\.[0-9]+-arch[0-9]+-[0-9]+")
+ "Machine characteristics: Linux-x.x.x-archx-x"))
(substitute* (find-files "." "petscvariables")
;; Do not expose build machine characteristics, set to defaults.
(("MAKE_NP = [[:digit:]]+") "MAKE_NP = 2")

base-commit: 23cbbe6860782c5d4a0ba599ea1cda0642e91661
--
2.44.0
Lars Bilke wrote 4 months ago
[PATCH v2 2/2] gnu: petsc: Remove store references on make and gcc.
(address . 74416@debbugs.gnu.org)(name . Lars Bilke)(address . lars.bilke@ufz.de)
663600da2062af7334e0406a752cd571bf627ce0.1732025886.git.lars.bilke@ufz.de
Reduces closure size from 970 MB to around 700 MB for petsc-openmpi
package and also makes `guix pack` packages containing petsc
bit-reproducible (by removing make it removes implicit guile
dependency).

Change-Id: I465c325b152b09befdb746e5bc47fbeaf9a061dc
---
gnu/packages/maths.scm | 6 ++++--
1 file changed, 4 insertions(+), 2 deletions(-)

Toggle diff (26 lines)
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index d76937265d..caa7b97b0c 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -3422,7 +3422,8 @@ (define-public petsc
;; Prevent build directory from leaking into compiled code
(((getcwd)) out)
(("Machine characteristics: Linux-[0-9]+\\.[0-9]+\\.[0-9]+-arch[0-9]+-[0-9]+")
- "Machine characteristics: Linux-x.x.x-archx-x"))
+ "Machine characteristics: Linux-x.x.x-archx-x")
+ (("([[:graph:]]+)/bin/make") "\"make"))
(substitute* (find-files "." "petscvariables")
;; Do not expose build machine characteristics, set to defaults.
(("MAKE_NP = [[:digit:]]+") "MAKE_NP = 2")
@@ -3462,7 +3463,8 @@ (define-public petsc
(("([[:graph:]]+)/bin/make") "make")
(("([[:graph:]]+)/bin/diff") "diff")
(("([[:graph:]]+)/bin/sed") "sed")
- (("([[:graph:]]+)/bin/gfortran") "gfortran")))))
+ (("([[:graph:]]+)/bin/gfortran") "gfortran")
+ (("([[:graph:]]+)/bin/gcov") "gcov")))))
;; Some of the tests get linked with '-L$prefix/lib -lpetsc' (even
;; though that's unnecessary because they also explicitly link
--
2.44.0
Ludovic Courtès wrote 3 months ago
Re: [bug#74416] [PATCH v2 1/2] gnu: petsc: Remove arch version from uname output.
(name . Lars Bilke)(address . lars.bilke@ufz.de)
87ttboyc5i.fsf@gnu.org
Lars Bilke <lars.bilke@ufz.de> skribis:

Toggle quote (15 lines)
> Enables reproducible building on machines with have a different
> arch-suffix in uname output, e.g.:
>
> Machine·characteristics:·Linux-x.x.x-arch1-1-x86_64-with-glibc2.39
>
> vs.
>
> Machine·characteristics:·Linux-x.x.x-arch2-1-x86_64-with-glibc2.39
>
> Will become
>
> Machine·characteristics:·Linux-x.x.x-archx-x-x86_64-with-glibc2.39
>
> Change-Id: Icc37a298c0c2d16e96f2c8eaf5aa4781cc4e5ac4

[...]

Toggle quote (7 lines)
> Reduces closure size from 970 MB to around 700 MB for petsc-openmpi
> package and also makes `guix pack` packages containing petsc
> bit-reproducible (by removing make it removes implicit guile
> dependency).
>
> Change-Id: I465c325b152b09befdb746e5bc47fbeaf9a061dc

Adjusted the commit log and applied it, thanks!

Ludo'.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 74416@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74416
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help