[PATCH 0/2] gnu: sslh: Update to 2.1.2.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Artyom V. Poptsov
Owner
unassigned
Submitted by
Artyom V. Poptsov
Severity
normal
A
A
Artyom V. Poptsov wrote on 17 Nov 2024 09:59
(address . guix-patches@gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
cover.1731833680.git.poptsov.artyom@gmail.com
This patchset updates sslh to 2.1.2 and fixes its build.

Unfortunately I had to disable "tcp-wrappers" as it leads to linker errors due
to missing "allow_severity" and "deny_severity". As a reference, MPD
(MusicPlayerDaemon) author decided to solve the same problem simply by
dropping "tcp-wrappers" support altogether:

Also I had to disable "libcap" support for now as tests would fail with
"permission denied" error. It is sub-optimal indeed, but at least now tests
run without such errors.

Artyom V. Poptsov (2):
gnu: sslh: Update to 2.1.2.
gnu: sslh: Use GEXPs.

gnu/packages/networking.scm | 63 ++++++++++++++++++++-----------------
1 file changed, 34 insertions(+), 29 deletions(-)


base-commit: 0e1ffbc7f5f060f89c890472377a6102f27f6e9b
--
2.46.0
A
A
Artyom V. Poptsov wrote on 17 Nov 2024 10:02
[PATCH 1/2] gnu: sslh: Update to 2.1.2.
(address . 74391@debbugs.gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
5efc66babbe61a9cc66a9de1f635bca5fd8fd377.1731833680.git.poptsov.artyom@gmail.com
* gnu/packages/networking.scm (sslh): Update to 2.1.2.
[native-inputs]: Add pcre2.
[inputs]: Remove tcp-wrappers and libcap. Add libev.
[arguments]<phases>: Patch tests; disable a failing test.
<make-flags>: Disable USELIBCAP as it leads to "permission denied" errors.
Disable USELIBWRAP as it leads to linker errors. Add USELIBCONFIG.

Change-Id: I20ba6e5ec1af4c7666d2b1f9870c850207e9c2c9
---
gnu/packages/networking.scm | 28 ++++++++++++++++++----------
1 file changed, 18 insertions(+), 10 deletions(-)

Toggle diff (77 lines)
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index f0f0619161..091ed06d3d 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -147,6 +147,7 @@ (define-module (gnu packages networking)
#:use-module (gnu packages libidn)
#:use-module (gnu packages libusb)
#:use-module (gnu packages linux)
+ #:use-module (gnu packages logging)
#:use-module (gnu packages lua)
#:use-module (gnu packages kerberos)
#:use-module (gnu packages man)
@@ -2716,7 +2717,7 @@ (define-public enet-moonlight
(define-public sslh
(package
(name "sslh")
- (version "1.21c")
+ (version "2.1.2")
(source
(origin
(method git-fetch)
@@ -2725,28 +2726,36 @@ (define-public sslh
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "19h32dn0076p3s7dn35qi5yp2xvnxw9sqphppmn72vyb8caxvw1z"))))
+ (base32 "0v4wmwcjqlpiagq2q30v7459ffvxb7i6kvjq1av6ajdd5iib2vpq"))))
(build-system gnu-build-system)
(native-inputs
(list ;; Test dependencies.
lcov
+ pcre2
perl
perl-conf-libconfig
perl-io-socket-inet6
perl-socket6
psmisc)) ; for ‘killall’
(inputs
- (list libcap libconfig pcre tcp-wrappers))
+ (list libev libconfig pcre))
(arguments
`(#:phases
(modify-phases %standard-phases
- (delete 'configure) ; no configure script
(add-before 'check 'fix-tests
(lambda _
- (substitute* "./t"
- (("\"/tmp") "$ENV{\"TMPDIR\"} . \"")
- ;; The Guix build environment lacks ‘ip6-localhost’.
- (("ip6-localhost") "localhost"))
+ (substitute* "t"
+ ;; XXX: Disable a failing test.
+ (("my \\$DROP_CNX = 1;")
+ "my $DROP_CNX = 0;")
+ ;; XXX: "sslh-select" seems to not support this option for some
+ ;; reason. According to "sslhconf.cfg" this option just overrides the
+ ;; verbosity configuration so it seems that we can safely drop it.
+ (("-v 4")
+ ""))
+ (substitute* "test.cfg"
+ ;; The Guix build environment lacks ‘ip4-localhost’.
+ (("ip4-localhost") "localhost"))
#t))
;; Many of these files are mentioned in the man page. Install them.
(add-after 'install 'install-documentation
@@ -2761,8 +2770,7 @@ (define-public sslh
(find-files "scripts"))))
#t)))
#:make-flags (list ,(string-append "CC=" (cc-for-target))
- "USELIBCAP=1"
- "USELIBWRAP=1"
+ "USELIBCONFIG=1"
(string-append "PREFIX=" (assoc-ref %outputs "out")))
#:test-target "test"))
(home-page "https://www.rutschle.net/tech/sslh/README.html")
--
2.46.0
A
A
Artyom V. Poptsov wrote on 17 Nov 2024 10:02
[PATCH 2/2] gnu: sslh: Use GEXPs.
(address . 74391@debbugs.gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
2924c8c2d1d1ee64f90867729d837724edf98119.1731833680.git.poptsov.artyom@gmail.com
* gnu/packages/networking.scm (sslh): Use GEXPs.

Change-Id: I5b31afdfeb1f1f9b2e5f86290adc405f3a90a367
---
gnu/packages/networking.scm | 61 ++++++++++++++++++-------------------
1 file changed, 29 insertions(+), 32 deletions(-)

Toggle diff (74 lines)
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 091ed06d3d..6017654866 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -2740,38 +2740,35 @@ (define-public sslh
(inputs
(list libev libconfig pcre))
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'check 'fix-tests
- (lambda _
- (substitute* "t"
- ;; XXX: Disable a failing test.
- (("my \\$DROP_CNX = 1;")
- "my $DROP_CNX = 0;")
- ;; XXX: "sslh-select" seems to not support this option for some
- ;; reason. According to "sslhconf.cfg" this option just overrides the
- ;; verbosity configuration so it seems that we can safely drop it.
- (("-v 4")
- ""))
- (substitute* "test.cfg"
- ;; The Guix build environment lacks ‘ip4-localhost’.
- (("ip4-localhost") "localhost"))
- #t))
- ;; Many of these files are mentioned in the man page. Install them.
- (add-after 'install 'install-documentation
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (doc (string-append out "/share/doc/sslh")))
- (install-file "README.md" doc)
- (for-each
- (lambda (file)
- (install-file file (string-append doc "/examples")))
- (append (find-files "." "\\.cfg")
- (find-files "scripts"))))
- #t)))
- #:make-flags (list ,(string-append "CC=" (cc-for-target))
- "USELIBCONFIG=1"
- (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'check 'fix-tests
+ (lambda _
+ (substitute* "t"
+ ;; XXX: Disable a failing test.
+ (("my \\$DROP_CNX = 1;")
+ "my $DROP_CNX = 0;")
+ ;; XXX: "sslh-select" seems to not support this option for some
+ ;; reason. According to "sslhconf.cfg" this option just overrides the
+ ;; verbosity configuration so it seems that we can safely drop it.
+ (("-v 4")
+ ""))
+ (substitute* "test.cfg"
+ ;; The Guix build environment lacks ‘ip4-localhost’.
+ (("ip4-localhost") "localhost"))))
+ ;; Many of these files are mentioned in the man page. Install them.
+ (add-after 'install 'install-documentation
+ (lambda _
+ (let* ((doc (string-append #$output "/share/doc/sslh")))
+ (install-file "README.md" doc)
+ (for-each
+ (lambda (file)
+ (install-file file (string-append doc "/examples")))
+ (append (find-files "." "\\.cfg")
+ (find-files "scripts")))))))
+ #:make-flags #~(list (string-append "CC=" #$(cc-for-target))
+ "USELIBCONFIG=1"
+ (string-append "PREFIX=" #$output))
#:test-target "test"))
(home-page "https://www.rutschle.net/tech/sslh/README.html")
(synopsis "Applicative network protocol demultiplexer")
--
2.46.0
L
L
Ludovic Courtès wrote on 6 Jan 16:08 +0100
Re: [bug#74391] [PATCH 0/2] gnu: sslh: Update to 2.1.2.
(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)(address . 74391@debbugs.gnu.org)
87ttac6kva.fsf@gnu.org
"Artyom V. Poptsov" <poptsov.artyom@gmail.com> skribis:

Toggle quote (16 lines)
> This patchset updates sslh to 2.1.2 and fixes its build.
>
> Unfortunately I had to disable "tcp-wrappers" as it leads to linker errors due
> to missing "allow_severity" and "deny_severity". As a reference, MPD
> (MusicPlayerDaemon) author decided to solve the same problem simply by
> dropping "tcp-wrappers" support altogether:
> https://github.com/MusicPlayerDaemon/MPD/commit/22e6d95c4bbae15dd7f635eabe5fdde1ce06ba73
>
> Also I had to disable "libcap" support for now as tests would fail with
> "permission denied" error. It is sub-optimal indeed, but at least now tests
> run without such errors.
>
> Artyom V. Poptsov (2):
> gnu: sslh: Update to 2.1.2.
> gnu: sslh: Use GEXPs.

LGTM, thanks!
A
A
Artyom V. Poptsov wrote on 15 Jan 22:18 +0100
Re: [PATCH 0/2] gnu: sslh: Update to 2.1.2.
(address . 74391-done@debbugs.gnu.org)
877c6v4vyo.fsf@gmail.com
Merged to the "master" branch as:

Toggle snippet (4 lines)
d568c9295110c138bfb8641d971d308d7e8be0c5 gnu: sslh: Use GEXPs.
0ba2136df7f7a574e88d07fb0be176322ace94ed gnu: sslh: Update to 2.1.2.

--
Artyom "avp" Poptsov <poptsov.artyom@gmail.com>
CADR Hackerspace co-founder: https://cadrspace.ru/
GPG: D0C2 EAC1 3310 822D 98DE B57C E9C5 A2D9 0898 A02F
-----BEGIN PGP SIGNATURE-----

iQJNBAEBCgA3FiEEAf2F9Bp7f4IFgwalk16+BzbchX4FAmeIJjEZHHBvcHRzb3Yu
YXJ0eW9tQGdtYWlsLmNvbQAKCRCTXr4HNtyFfuO8D/9cBkgDxW1Fa/QtYSahrTcK
hXd8vV7COi3jVtcmBGnZXyttKwFaF0W3wnz34cV6xrR8ppbX8alYQ/GUsCsb38GF
8Ey5s4ZQI+NHkxiFfleN48/Fp1i0pfB8mbSd5nwEmQDNUcbwTYOkxDuiMRVkPgfZ
eBxHnlpA8HPXqGRDkgM2+78tlRt5D/8lsSk/3qOJC609E9rxjqjLpuJ28Kd79l8P
GLOzlf0OrKLzS3F1p5oyPqogSQ0z4YkDizD35ORPRV8NIl4h51J/VN6S6sZLQhS9
DVOLxBrn5KqOfjocHwsSt2fzs67nJZk8GjbKOcgdU12VI1wBSZcgCPx+PSEkH7+0
88FR9Q53rKfQoyV7ib/SSFHUV8di2YZmtvOaTVARnY/r4xJzmbL2wE+yeHOZWflL
QmJtr0+dQYlgbJr5ONy3VX85nK6kmu2kvchK+3ibRQcO6m9jghCb68ecjfTwx/YU
STZMfNyn+DTrx0+qZ+DX7GatUWiJL9Dh+xxS+XSayN0QpVxwQyr3SR5J5f0r8TeP
rbwu8jE5UGWDmBZoMdxUUaPvTDI+KKVZoPZB9QWRAlD75tRWQW6zqrhJWPhXYK8p
UuUGqNZv3GLcRh8BsFJS8FJ6gKqcsJc5F0lhM3anMYgqdWk6t/J00325PUosO/nk
/aPhDjY0nKSenJ9e8Dm8kQ==
=WITj
-----END PGP SIGNATURE-----

Closed
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 74391@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74391
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch