(address . guix-patches@gnu.org)(name . Mazin AlHaddad)(address . mazin@getstate.dev)
* gnu/packages/mpd.scm (ncmpcpp): Update to 0.10.1.
[origin]: Change URI to github.
[inputs]: Add libtool, autoconf-2.71, automake.
Change-Id: Id2662c10c143736d10320550b6ce6fffe841984c
---
gnu/packages/mpd.scm | 16 ++++++++++------
1 file changed, 10 insertions(+), 6 deletions(-)
Toggle diff (39 lines)
diff --git a/gnu/packages/mpd.scm b/gnu/packages/mpd.scm
index c5632203dd..5e8b615599 100644
--- a/gnu/packages/mpd.scm
+++ b/gnu/packages/mpd.scm
@@ -296,20 +296,24 @@ (define-public ncmpc
(define-public ncmpcpp
(package
(name "ncmpcpp")
- (version "0.9.2")
+ (version "0.10.1")
(source (origin
- (method url-fetch)
- (uri
- (string-append "https://ncmpcpp.rybczak.net/stable/ncmpcpp-"
- version ".tar.bz2"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ncmpcpp/ncmpcpp")
+ (commit (string-append version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "06rs734n120jp51hr0fkkhxrm7zscbhpdwls0m5b5cccghazdazs"))))
+ "1chs7xpbsd1kmrdi4z41s0qcl7b661548jj6va1najgm5r5mwxy3"))))
(build-system gnu-build-system)
(inputs (list libmpdclient
boost
readline
ncurses
+ autoconf-2.71
+ libtool
+ automake
taglib
icu4c
curl))
base-commit: c1cb7f1031c5dde2a260d8d8ad7547d6c79cc532
--
2.46.0