[PATCH] gnu: hdf5: Remove machine info from libraries.

  • Done
  • quality assurance status badge
Details
2 participants
  • Lars Bilke
  • Ludovic Courtès
Owner
unassigned
Submitted by
Lars Bilke
Severity
normal

Debbugs page

Lars Bilke wrote 4 months ago
(address . guix-patches@gnu.org)(name . Lars Bilke)(address . lars.bilke@ufz.de)
f785ad2cb0da0bccac1dac71b591f0554b3e926a.1731595771.git.lars.bilke@ufz.de
Change-Id: I1435b866babeb95af48e0fd970d931f022c8bc67
---
gnu/packages/maths.scm | 9 ++++++++-
1 file changed, 8 insertions(+), 1 deletion(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index bb6c1648b5..89fb9291b8 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1726,7 +1726,14 @@ (define-public hdf5-1.14
;; modifies the test reference.
(substitute* "test/test_check_version.sh.in"
(("TESTING\\(\\).*" all)
- (string-append all "\nSKIP; exit 0\n")))))))))))
+ (string-append all "\nSKIP; exit 0\n")))))
+ (add-after 'patch-configure 'patch-configure-build-settings
+ (lambda _
+ (substitute* "src/H5build_settings.autotools.c.in"
+ ;; Don't record the build-time kernel version to make the
+ ;; library file reproducible.
+ (("@UNAME_INFO@")
+ "Linux"))))))))))
(define-public hdf5
;; Default version of HDF5.

base-commit: b10ce47d8be5b6c15987f4e1d93b3bd71b1eb220
--
2.44.0
Ludovic Courtès wrote 4 months ago
(name . Lars Bilke)(address . lars.bilke@ufz.de)
87h684gaoi.fsf@gnu.org
Lars Bilke <lars.bilke@ufz.de> skribis:

Toggle quote (23 lines)
> Change-Id: I1435b866babeb95af48e0fd970d931f022c8bc67
> ---
> gnu/packages/maths.scm | 9 ++++++++-
> 1 file changed, 8 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
> index bb6c1648b5..89fb9291b8 100644
> --- a/gnu/packages/maths.scm
> +++ b/gnu/packages/maths.scm
> @@ -1726,7 +1726,14 @@ (define-public hdf5-1.14
> ;; modifies the test reference.
> (substitute* "test/test_check_version.sh.in"
> (("TESTING\\(\\).*" all)
> - (string-append all "\nSKIP; exit 0\n")))))))))))
> + (string-append all "\nSKIP; exit 0\n")))))
> + (add-after 'patch-configure 'patch-configure-build-settings
> + (lambda _
> + (substitute* "src/H5build_settings.autotools.c.in"
> + ;; Don't record the build-time kernel version to make the
> + ;; library file reproducible.
> + (("@UNAME_INFO@")
> + "Linux"))))))))))

Added a commit log and applied it, thanks!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 74353@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74353
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help