[PATCH 0/2] gnu: bootterm: Update to 0.5.

  • Open
  • quality assurance status badge
Details
One participant
  • Artyom V. Poptsov
Owner
unassigned
Submitted by
Artyom V. Poptsov
Severity
normal
A
A
Artyom V. Poptsov wrote 25 hours ago
(address . guix-patches@gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
cover.1731531177.git.poptsov.artyom@gmail.com
This patchset updates bootterm to the version 0.5 and updates the package
style.

Artyom V. Poptsov (2):
gnu: bootterm: Update to 0.5.
gnu: bootterm: Use GEXPs.

gnu/packages/terminals.scm | 30 +++++++++++++++---------------
1 file changed, 15 insertions(+), 15 deletions(-)


base-commit: 9aae575828f263d71fdb16efcaebe4d8e9de7e41
--
2.46.0
A
A
Artyom V. Poptsov wrote 25 hours ago
[PATCH 2/2] gnu: bootterm: Use GEXPs.
(address . 74351@debbugs.gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
4e7eccadd24dd62750cf9c1708347940ce6683b3.1731531177.git.poptsov.artyom@gmail.com
* gnu/packages/terminals.scm (bootterm): Use GEXPs.

Change-Id: I6c718e57eba9304fde8c4ed1fa2f00cf20d44051
---
gnu/packages/terminals.scm | 25 ++++++++++++-------------
1 file changed, 12 insertions(+), 13 deletions(-)

Toggle diff (38 lines)
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index 19b667107f..6cf0d01607 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -1731,19 +1731,18 @@ (define-public bootterm
"1xag6agcqkq2p7gp20qxjb95ah7p6lia65jmm5v51rqxfzclx2h1"))))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f ; no test suite
- #:make-flags (list (string-append "CC=" ,(cc-for-target))
- (string-append "PREFIX=" (assoc-ref %outputs "out")))
- #:phases
- (modify-phases %standard-phases
- ;; No ./configure script
- (delete 'configure)
- (add-after 'install 'install-doc
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (doc (string-append out "/share/doc/" ,name "-" ,version)))
- (install-file "README.md" doc)
- #t))))))
+ (list #:tests? #f ; no test suite
+ #:make-flags #~(list (string-append "CC=" #$(cc-for-target))
+ (string-append "PREFIX=" #$output))
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; No ./configure script
+ (delete 'configure)
+ (add-after 'install 'install-doc
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (doc (string-append out "/share/doc/" #$name "-" #$version)))
+ (install-file "README.md" doc)))))))
(home-page "https://github.com/wtarreau/bootterm")
(synopsis "Serial terminal")
(description "Bootterm is a terminal designed to ease connection to
--
2.46.0
A
A
Artyom V. Poptsov wrote 25 hours ago
[PATCH 1/2] gnu: bootterm: Update to 0.5.
(address . 74351@debbugs.gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
0e491ca7864447a757bf883a6ee7deb2da321401.1731531177.git.poptsov.artyom@gmail.com
* gnu/packages/terminals.scm (bootterm): Update to 0.5.

Change-Id: I374a778bb81e8a37849e1dd592fc247c43be6486
---
gnu/packages/terminals.scm | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)

Toggle diff (32 lines)
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index fbfc4439db..19b667107f 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -42,6 +42,7 @@
;;; Copyright © 2024 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2024 Ashish SHUKLA <ashish.is@lostca.se>
;;; Copyright © 2024 Ashvith Shetty <ashvithshetty10@gmail.com>
+;;; Copyright © 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1718,7 +1719,7 @@ (define-public alacritty
(define-public bootterm
(package
(name "bootterm")
- (version "0.4")
+ (version "0.5")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1727,7 +1728,7 @@ (define-public bootterm
(file-name (git-file-name name version))
(sha256
(base32
- "1k3jacld98za41dbpr10sjms77hrw91sb10m0cnwv3h7aifiwmrs"))))
+ "1xag6agcqkq2p7gp20qxjb95ah7p6lia65jmm5v51rqxfzclx2h1"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; no test suite
--
2.46.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 74351@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74351
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch