* gnu/packages/terminals.scm (bootterm): Use GEXPs.
Change-Id: I6c718e57eba9304fde8c4ed1fa2f00cf20d44051
---
gnu/packages/terminals.scm | 25 ++++++++++++-------------
1 file changed, 12 insertions(+), 13 deletions(-)
Toggle diff (38 lines)
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index 19b667107f..6cf0d01607 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -1731,19 +1731,18 @@ (define-public bootterm
"1xag6agcqkq2p7gp20qxjb95ah7p6lia65jmm5v51rqxfzclx2h1"))))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f ; no test suite
- #:make-flags (list (string-append "CC=" ,(cc-for-target))
- (string-append "PREFIX=" (assoc-ref %outputs "out")))
- #:phases
- (modify-phases %standard-phases
- ;; No ./configure script
- (delete 'configure)
- (add-after 'install 'install-doc
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (doc (string-append out "/share/doc/" ,name "-" ,version)))
- (install-file "README.md" doc)
- #t))))))
+ (list #:tests? #f ; no test suite
+ #:make-flags #~(list (string-append "CC=" #$(cc-for-target))
+ (string-append "PREFIX=" #$output))
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; No ./configure script
+ (delete 'configure)
+ (add-after 'install 'install-doc
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (doc (string-append out "/share/doc/" #$name "-" #$version)))
+ (install-file "README.md" doc)))))))
(home-page "https://github.com/wtarreau/bootterm")
(synopsis "Serial terminal")
(description "Bootterm is a terminal designed to ease connection to
--
2.46.0